Flashback + editor - octaver not working ?

2019-09-20

I'm going through the new great features of Flashback 2 and the TP editor

However I can't seem to activate the octaver soundwise
It's enabled in the settings, Wet level 0db and Router 0db Octaver to Effect but nothing happens

Are others having this issue or if not, what might I be doing wrong ?