Statistics

241,182 members
117,433 posts
  • New
    CindyDoire
    Newcomer - Level 1
    2021-07-26
    1. Hi everyone,

    i don't have much experience working with midi, and I bought the TC helicon perform VE used, and I'm having issues connectibg it to my midi keyboard (Yamaha reface Cp).

    I'm wondering if I'm just missing something? Am I using the wrong keyboard? Should the pedal connect to something else, or is the keyboard the only connection it needs to create vocal samples into midi ane use it with the keyboard? 

    Also, perhaps I've connected it wrong?

    It seems like this should be an easy pedal to use, so there's also the option that the midi in is damaged... 

    read more...
    0 2
  • New
    TC Electronic
    Triber Moderator
    2021-07-26

    The new ultimate plug-in bundle with 20 pristine TC sound machines for music and film editing, mixing, and mastering.

    The Studio Elite Collection includes our award-winning plug-ins straight from the legendary TC Electronic SYSTEM 6000, TC Legacy Catalog, Midas Consoles, and more. Some of them are even available for DAW-based productions for the first time!

    From USD 2499 down to only USD 1299 - we've made the price just as awesome as the contents!

    Upgrades:

    • If you already own the Icon Series Legacy Native Bundle, you can get it for only USD 1049!

    • Already using the System 6000 Native Bundle? Then the Studio Elite Collection will be available to you for only USD 799.

    • “One more thing,” we hear you ask, “what if I have both?” We got you! Those who have both bundles can get the upgrade for just USD 499!

    All the professional production and mastering algorithms in the Studio Elite Collection integrate smoothly with all major music and film editing, mixing, and mastering applications. To grab it right now, and check out other great plug-ins, visit our store: https://store.tcelectronic.com/bundles/

    This amazing bundle comes with:           

    • TC 2290 NATIVE
    • DVR 250 NATIVE
    • TC 8210 NATIVE
    • TC 1210 NATIVE
    • MASTER X HD NATIVE
    • BRICKWALL HD NATIVE
    • PEQ 3000 NATIVE
    • DYN 3000 NATIVE
    • LM2 NATIVE
    • POLYTUNE NATIVE
    • VSS4 HD NATIVE
    • MD3 NATIVE
    • MD4 HD NATIVE
    • NONLIN2 NATIVE
    • VSS3 NATIVE
    • STEREO CHORUS + FLANGER NATIVE
    • BOOSTER + DISTORTION NATIVE
    • TC XII PHASER NATIVE
    • DUAL EQUALIZER NATIVE
    • SUSTAIN + EQUALIZER NATIVE
    read more...
    0 78
  • New
    LeonPearce
    Newcomer - Level 1
    2021-07-26

    Hi,

     

    Recently purchased a second hand LAKE LP4D12, but without a control surface. Does anyone have any advice on what is the best way to get appropriate software for an old LP4D12?

     

    Hoping to use it with a windows tablet, but the tablet will be new, the lake is old.

     

    Thanks

    read more...
    0 1
  • New
    Analog1
    Newcomer - Level 1
    2021-07-26

    Hello Tribe,

    I am looking for a replacement power suppy for my Tannoy Reveal 5A monitor. Its not your common universal power supply. inside of the power hook up on monitor only has two prongs. Can someone help me find a replacement power supply cord for this monitor please? 

    Cheers, Analog 

    read more...
    0 2
    • Analog1
      Nigel67 Hi Analog. Please contact our spares department and they will be able to advise you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare parts tab and submit a ticket. Many thanks.
      • Jul 25
  • New
    ninutat
    Newcomer - Level 1
    2021-07-25

    Hi everyone!
    I have TC Helicon Play electric.

    The manual says when output is in 'Mono' mode & Guitar Out is connected, left and right XLR outputs give dry and wet vocals respectively. This feature is not working on my device!

    Any thoughts? 

    read more...
    0 2
    • ninutat
      Nigel67 Hi ninutat. Can you advise further what outputs you are getting in this mode, i.e are you not getting any output at all, all wet, all dry. This may help identify the issue. Many thanks.
      • Jul 25
      • Dry and Wet Vocals
        ninutat Hi!! Thanks Nigel! Kind of you to respond.
        The connections on my Play Electric are as follows: -

        -Mic Connected
        -Guitar In connected
        -Have tried guitar 'thru' and guitar 'out' alternately connected to my DAW via preamp and audio interface
        -XLR left connected to DAW via preamp/audio interface
        -XLR right connected to DAW via preamp/audio interface
        -aux in not connected
        -Headphones connected.

        Second page under setup menu is 'Output' setup. Therein I have selected 'mono'.
        As given in manual page 33 (2014 version), in this setup expected o/p from XLR are-

        Left XLR- Only Dry Vocals
        Right XLR- Only effects (no dry vocals)

        What I am Getting: -

        Left XLR- effected vocals (dry and wet vocals)
        Right XLR- Dry Vocals.

        -Ninutat


        PS- Another anomaly I found (which I suspect is an hardware issue)- on 'Input' under Setup menu, my 'RoomSense Parameter' is inactive showing 'Disconnect Aux in' constantly. Can this be related?
        • 10 hours ago
    • ninutat
      ninutat Hi!! Thanks Nigel! Kind of you to respond.
      The connections on my Play Electric are as follows: -

      -Mic Connected
      -Guitar In connected
      -Have tried guitar 'thru' and guitar 'out' alternately connected to my DAW via preamp and audio interface
      -XLR left connected to DAW via preamp/audio interface
      -XLR right connected to DAW via preamp/audio interface
      -aux in not connected
      -Headphones connected.

      Second page under setup menu is 'Output' setup. Therein I have selected 'mono'.
      As given in manual page 33 (2014 version), in this setup expected o/p from XLR are-

      Left XLR- Only Dry Vocals
      Right XLR- Only effects (no dry vocals)

      What I am Getting: -

      Left XLR- effected vocals (dry and wet vocals)
      Right XLR- Dry Vocals.

      -Ninutat


      PS- Another anomaly I found (which I suspect is an hardware issue)- on 'Input' under Setup menu, my 'RoomSense Parameter' is inactive showing 'Disconnect Aux in' constantly. Can this be related?
      • 10 hours ago
  • New
    Gezzie
    Newcomer - Level 1
    2021-07-24

    Hi all,

    I'm trying to control the arpeggiator on the Behringer Monopoly using the trigger input and coming from the trigger out of the RD8. What am I missing here. Having no luck. Using a TRS cable as instructed  if I trigger using accent on the rd8 every 4 beats I hear a sound from the Monopoly but it's the same one. Was expecting it to cycle through the arpeggiator. Is this even possible?

    Cheers.

    read more...
    0 1
  • New
    gilcarter
    Newcomer - Level 1
    2021-07-24

    Hi folks, I have an X32 rack (which doesn't have the XLR AES/EBU connector on back panel), and hoping to connect digitally to a DCX2496.

    How can I connect from the AES50 Ethercon connector on the X32 Rack to the AES/EBU XLR on the DCX2496?

    read more...
    0 2
    • gilcarter
      RexBeckett Hi gilcarter, I think you would need to use an S32 stagebox which has two AES/EBU outputs. It would be an expensive solution unless you had a need for the extra analogue I/O.
      • Jul 24
  • New
    Anthony215
    Newcomer - Level 1
    2021-07-24

    This is the worst forum software I have ever experienced.  I don't have time to read post after post of unrelated topics trying to find useful information.  Especially as slow as this website is. 

     

    This place reminds be of the Behringer quality that I grew up with long, long ago.  Not good.

    read more...
    0 5
  • New
    David20k
    Newcomer - Level 1
    2021-07-23

    greetings guys, i just acquired the flow 8 recently but am finding it difficult updating it. the SimplyPUT (MAC) Update-Tool is not installing on my mac. this is what its showing on my screen. please help

    read more...
    0 1
  • New
    JohnFry
    Contributor - Level 2
    2021-07-22

    Hey guys& gals I just recently bought the wing. I'm learning my way around it ok i guess . In older videos I've seen that you could press an edit button and then move the fx and EQ in what ever position you want or order you want. . I guess with the firmware changes they have gotten rid of the edit button or at least I can't find it I see a wrench icon there instead . I'm using the latest firmware 1.11 I believe. How would I go about doing the task I want to achieve.  ????   Thanks 

    read more...
    1 2
Go to page