• 2020-07-01
    Hi guys, I am experiencing a noise issue with may Deepmind 12 only purchased last week, I am using balanced leads going into an Audient iD22 insert return (bypassing the pre amps. The noise level is very low - around -80dB, but the noise that concerns me appears to be coming from the oscillators themselves. It's like a kind of fluttering sound, almost as if the noise generator was turned up (but it's not, it's off). It gets more noticeable when playing higher notes. I start with a Default Program and slowly lower the filter cutoff and I start to hear the noise come in under the saw or other waveforms. It almost makes it unusable when creating unison bass type sounds as the noise increases and the filter isn't able to filter it out enough. The only way around it was to insert a MoodFilter in the FX section and assign that to an envelope via the mod matrix. This totally cuts the noise out. Again, this isn't a noise floor issue, it's actually a noise that's inherent in the oscillators themselves. Has anyone else noticed this or do I have a faulty unit? Cheers!
    read more
    0 2
    • GeoffPinckney
      GeoffPinckney Further to the above - this is after a full calibration and can be heard using headphones or the line outputs. It's also more noticeable when playing low notes with the filter cutoff at low settings. The filter is in 4 pole mode as well.
      • Wed at 3:08 AM
  • 2020-06-25
    Hello, I just got my TD-3 and I love it, except I can only run it when I have it connected to a DAW as the clock host. However without any input, it will not play using it's own internal timer, which is frustrating because that is how I would like to use it. I don't know if this is an error on my part, I have read the manual, watched countless youtube videos, and I can't seem to get it to play using the internal timer. I have tried changing it both on the TD-3 itself and through the synthtool. I have tried to create a help ticket, but it never goes through, hoping the community can help me out here. Thanks for the help!
    read more
    0 12
    • idb22
      Cris Supp Follow these steps to the rule.. turn on,wait 10, select pattern write, hold function and button 1 and clear, you can test now to see if pattern is empty by play /stop, make sure youre in stop, now were going to set the steps, hold function down and keep hitting the step button say 8 times(8 steps),now were going to record the sequence of keys(theyre not notes at this stage, hit pitchmode it should light the led , you can now play 8 keys, this is the special bit, hit time mode and then hit step 8 times , this sets every note to on, some lights should flash that you have finished the sequence, now select mode pattern play and start/stop to play youre sequence, NOTE :- you can select other types of note in that four square section add accents and slide after this by hitting pitch mode and next,if you can manage to get sounds out then the rest will come, you can now adjust the speed rate and tune, keyfact which i havnt done yet if you hit a key in the sequence and you want a break (no key on) hit next,ps if you hit pitch mode this brings you back to the start of your pattern and run through using next, this allows you to add slides etc.. hope this did it,..take care
      • Wed at 9:41 PM
  • 2020-06-23
    I purchased my Burgera Veyron BV1001M amp on 9-4-17. I never owned this brand before. I was impressed of the small compact size and sound that came from it. 2000watts @4ohms/1000watts@ 8ohms. HMMMM? I got it for a back up amp. It was used about 20 times. I used it last Saturday to practice. It worked find. I turned it on Monday (6-22-20)to practice, then only a buzzing sound was coming from the speaker. I am not getting no bass sounds. The preamp still sends a signal but no output to speaker. I'm trying to contact a tech with Sweet Water, I'm still waiting for a call to see what is my best options? Did anyone else have issues with this type amp? or has any ideas where to send it to get repaired?
    read more
    0 6
    • Chris Martin
      Alexander Lane Hi there, could you please raise a service ticket using the Support button at the top of the page, thankyou!
      • Jun 24
  • 2020-06-22
    I have tried to set up a repair ticket without success. The pedal powers up but provides no effect. I'd like to get it repaired. I live in Toronto, Canada.
    0 8
    • mjbrn
      Nic Jones Thanks for posting. Can you confirm whats happening when you try to open a ticket? Please be aware that as this is an old legacy product, parts may not be available. If you look at the following link this shows all of our international service centres who will be able to advise you further; https://www.tcelectronic.com/brand/tcelectronic/store-finder?division=CREA&isoCode=GB&type=POS#googtrans(en|en)
      • Jun 22
  • 2020-06-16
    Hey - is anyone else experiencing this. If so, do you have a solution? My DeepMind 12 is experiencing a strange power cut/power short whenever I play all 12 voices. It's like the system overloads and shuts down (almost like a safety feature) to about 1/2 power. Volume cuts, LCD display dims, fans cut, lights across board fade, and overall noise increases. Also, a distinct high frequency bleeds from ANY output jack. All of this makes the entirety of the synth more annoying to play than enjoyable.. I've tried creating a care card, but haven't heard anything from anyone. Any thoughts..?
    read more
    0 4
    • John Laws
      Alexander Lane Hi John, this certainly sounds like a fault that our support team will need to look into. Could you private message me your case number and I will follow up and ensure it's being looked at. Thanks
      • Jun 17
      • Deep Mind 12 Power Cut
        John Laws Hey Alexander. I'm not sure how to private message you, but my case number is CAS-109469-R0C8H3
        • 4 hours ago
  • 2020-06-14
    Having a mare with this firmware update.... Lots of. Bugs on the td3. I want to put a good firmware on there. But which is the best? One firmware update supplied by behringer wipes the td3 turning it into a paperweight! Not sure how to do it anyway.... I am quite annoyed that I've been sold a machine that is full of annoying bugs. What can I do? Anyone have any solutions? It's so unclear as to what to do.
    read more
    0 27
    • Nick Davis
      Joe Rivers Hi Nick - thank you for getting in touch. What bugs are you experiencing here? Are you running the latest firmware?
      • Jun 22
      • Behringer td 3 firmware update
        Nick Davis Hi! When I first loaded the synth tool onto my laptop it gives error messages on start up. I believe my. Version is 1.2.5 or something.... I'd have to check again. In step edit mode there are drop outs in the slide information storage. They disappear and you can't step back through a pattern only forwards. I'm unsure if I load the new firmware and it bricks it I'll be disappointed and may even void my warranty.
        • Jun 22
      • Behringer td 3 firmware update
        Nick Davis I really like the machine though, it's cool and I've always. Wanted a 303, now I do I'd like to think that these problems were ironed out long before the product hit the market.
        • Jun 22
      • Behringer td 3 firmware update
        Joe Rivers Hi Nick, thanks for explaining further. If you don't mind could you submit a support ticket via SUPPORT at the top of this page please? Feel free to mark it for my attention in the subject line.
        • Jun 23
    • Nick Davis
      Cris Supp Do youre homework !!
      • Wed at 7:53 PM
    • Nick Davis
      Cris Supp you can step back one step by hitting the back button, why dont you just restep through by hitting the pitch mode then / step
      • Wed at 7:55 PM
  • Welcome to our new Music Tribe community 2.0, I’m Paul O’Farrell-Stevens, leader of the Music Tribe Customer Branding team. 

My highly-skilled team of Customer Branding Specialists are really looking forward too engaging, co-collaborating and co-developing new and exciting product content. We will be seeking new talent, fans and beta testers that want to join us to co-create inspiring content. We Empower, You Create
    read more
    0 1
  • 2020-06-10

    I bought the Go and it arrives soon. The Go has 3 zones that handle an Amp per zone. If you were to hook up 3 model d's you would (if 1000 mA's is correct in the Model D's usage) be out of power. In the video they do much more.  I need to know what the true Model D mA usable is. Modulargrid says 580 mA's but im afraid to go by that. Im surprised Behringer has not posted this anywhere but they havent. Any info would be appreciated.

    read more
    0 19
  • 2020-06-10

    Not very good on the Internet can you please call me at 808-321-2181 really need your help fixing my pedal I love this pedal and have shown it to hundreds of people as I am a touring musician is not working properly now

    0 10
  • 2020-06-10

    Today, I found the oscillators on my Neutron have practically stopped working. If I increase the levels to max, I can barely hear the oscillators which seem to be accompanied by a noise. I just wanted to check here if this is a hardware malfunction or if it's something people have seen and can be solved easily

    read more
    0 8