Statistics

216,324 members
89,537 posts
  • New
    elG4bi
    Newcomer - Level 1
    2021-02-25

    Hi everyone! I don't know if here is the right place to put this, but could someone confirm me if the MINI VERSION of the hypergravity compressor has the option to choose between true bypass or buferred. Thanks

    0 3
    • elG4bi
      WilliamR Hello, William from music tribe here. Yes, you can choose between true bypass and buffered bypass. You can turn it on and off via a little dim switch under the bottom plate of the pedal. If you look on the circuit board, and the switch is not there, then all you need to do is connect your pedal to tone print on your computer via USB and engage it there.
      • Feb 25
  • New
    Ronk
    Newcomer - Level 1
    2021-02-24

    I'm simply trying to find out if the toneprints are just particular dial settings on the unit or do they contain things that do not exist in the original unit?

    0 4
    • Ronk
      WilliamR Hello Ronk, The toneprints for the spectra drive would be the spectracomp tone prints. These toneprints would give you access to deeper editing functions not accesable from the face of the pedal.
      • Feb 23
  • New
    thefollower66
    Newcomer - Level 1
    2021-02-23

    I have been re-routing my pedalboard and the pedal was working fine.  Just when I thot I was done...suddenly no audio.  When bypassed signal passes  thru the pedal to the amp...so I know the cables are fine.  But when I activate the pedal the audio stops.  Yes I have turned the knobs up.   Any ideas?


    Stephen 

    read more...
    0 20
    • thefollower66
      Dale_M Hi there, the first thing I would do is remove the pedal from the board and simply plug your guitar in the input and and your amp to the output and do a sanity check that the pedal works outside of this set up.
      • Feb 23
    • thefollower66
      thefollower66 Thanks Dale. I neglected the most obvious step. So....as I unplugged the pedal I caught my error. I had the cables reversed....of course audio still passed due to true bypass. The audio passing thru really threw me off. Thanks again.
      • Feb 23
      • Sub-n-Up no sound
        Dale_M no problem easily done!
        • Feb 23
  • New
    HeyBurt
    Contributor - Level 2
    2021-02-22

    Hi Guys,
    I recently made the investment to consolidate my existing tc pedals. Updated the firmware to latest build 1.2.18 (latest version available on 17/02/21)
    Great concept,  great sounds, but some MAJOR BUGS need sorting to make this usable! (Luckily the world is still in lockdown - so there's time before gigs start up again)

    Bugs found:

    1. Midi is STILL problematic - when the Plethora X5 is set to a defined Midi channel, any additional CC# messages get ignored after a PC# command is recieved on the same channel. Working with some guys on the Facebook forum, it looks unique to the Boss Switchers so far.
    I tested some ideas for a work around on the ES-8 switcher that will allow me to send a CC# message (CC#102 - Val 0 - (Pedal 1_Off) for eg.) manually after the PC# has gone through to the PX5, but if I try and send multiple CC#s it will only complete the first CC# out of the list sent. I don't think the PX5 is listening to all messages correctly as they come in on a defined channel as a bulk load of comands.

    2. If a Midi PC# command is sent and the the Plethora is already on the correct corresponding board,  the unit reloads the board again which has this dry signal and lag (trails are cut off) - see next point regarding LAG. This issue is important to fix as Boards can be used on multiple Presets in live setups - and switching presets needs to be as seemless as possible and there is no need for the PX5 to reload it. it almost needs a code to check to see if the board matches the corresponding PC# received before anything happens.

    3. THE LAG! - OH the LAG! Lag between board changes is not acceptable for live performances - along with the awkward dry signal that sneaks through with it. Many other multi effects with heavy computing demands handle this change instantly (eg. Boss SY-300 / Boss GT1000 Core) so this should be possible here with some refined coding ;) - I use the PX5 as a Stereo D.I. Rig at the end of my signal chain, with no other delay or reverb effects on my board to compensate for the lag - It's impossible not to notice when i'm changing boards and is my biggest gripe!

    4. The tails are still cut off between board changes, this makes mid song changes between boards unusable. As the pedal features time based effects - Delays and reverb should be designed as standard to carry across in board changes. - The response to this point I imagine will be that the 'DSPs are dropping all their programming to load the new board config'... but if a BOSS GT1000 Core can acheive it - PX5 should be able to also. (perhaps some cpu capacity needs to be reserved in every board to capture tails and carry over in board changes? - perhaps even an option to choose buffered bypass in Board Settings to enable it?)

    Additional Suggestions for Future Features:

    1. Auto save function needs to be optional feature - we don't want all tweaking to be permanent whilst we try new sounds out - add a save board command on the main board perhaps using a long press on the Toneprint button? Presets are a good thing! ;)

    2. BodyRez for acoustic guitars would be great and EASY addition - as the digital and editable version is already included in the TC Helicon Play Acoustic Pedal - with this in mind an Acoustic IR might be a good shout to accompany it.

    3. Make Cab Sims Board Specific to allow easier changes to accompany board swaps (helpful when switching between acoustic, bass, different guitars...etc)

    4. Filters and Auto Wah would be a nice addition

    Hopefully these Bugs can be looked into ASAP - I know there are guys begging for these fixes in the social media forums and being an issue on one of the leading Pedal Switching Brands, there is a demand to escalate this to avoid people shopping else where.

    I still trust in TC to pull it out the bag, but Updates this early on need to be very regular to justify the £££ spent on the pedal and retain the customers ;) - I have Faith in TC still!

    Thanks guys,
    Mike :)

    read more...
    2 32
    • HeyBurt
      PedroRodrigues Hi HeyBurt I will forward all your concerns and suggestions to our DEV. team . Thank you
      • Feb 23
    • HeyBurt
      PedroRodrigues Hi HeyBurt I will share a full statement from the Development team regarding all your comments but please consider that when changing board all FX need to be re/initialized which takes 500ms ms, so all MIDI messages send in that time span will get ignored, effectively this is the same with other multi Fx
      • Feb 23
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        HeyBurt Thanks for the reply Pedro. I'll be honest, that's seems a little untrue, I've mentioned a couple of multi effects pedals that change instantly (including one that even carry over the time based effects between changes).
        • Feb 23
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        HeyBurt As for the midi messages being ignored, it's going to come down to coding to change this, the switcher doesn't face this issue with any other pedal. In fact, i can get multiple PC#s accompanied with CC#s to send and work simultaneously on the TC Triple Delay, so the technology and theory is all there, it just needs refining
        • Feb 23
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        HeyBurt Hi Pedro, did you send a full statement from Development team? Some of the issues raised haven't been answered yet? E.g the board Reload when the same PC# is sent and the board is already on the correct board
        • Tue at 2:10 PM
    • HeyBurt
      CSurieux +1 for Auto save function needs to be optional feature, bug and missing trails
      other concerns are midi clock + global tempo
      +1 for I have Faith in TC still!
      • Feb 23
    • HeyBurt
      tangozebra To add my perspective, I don't think the X5 was really designed to change boards "mid-song" and I think that is OK for what it is. I'm not an engineer but I would imagine it would take a lot more memory, etc. to make it instantaneous and drive up the cost. For me I'm just live within the paradigm that I can't switch board between songs.
      • Feb 25
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        CSurieux So you bought such an expensive gear just to stay on one board ???
        • Feb 25
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        HeyBurt I would agree, it's alot of money! Almost as much a the competitors who have over come these issues! I could be content for now if I were able to send multiple CC#s to turn off/on effects within a board (this is an issue with the Boss switchers atm) and the board wouldn't reload when the same PC# is sent and it's on the correct board already
        • Feb 25
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        tangozebra I do this successfully with a Morningstar MC3 MIDI pedal. With one press I send the CC commands to start the looper in slot 5 and switch on pedals 1-4. Then I press again to do the opposite. No issues whatsoever.
        • Feb 25
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        tangozebra My perspective is that the X5 costs the about the same or less that 5 pedals, so if I just bought 5 individual pedals instead then I could only use 5 pedals on a song. In my case I literally sold 5 pedals and used that money to buy an X5. With the X5 I get lots more pedals that I can combine for other songs (boards) plus have different saved settings for multiple instances of a pedal. I just think that is the X5 paradigm - one board per song. Every device has trade-offs and I think TC did a great job. It's a great device and provides great value, just wish they would add a MIDI Looper Stop command! Hopefully they keep adding functionality.
        • Feb 25
      • Plethora X5 - Boss ES-8 Switcher - Midi Bugs Found
        HeyBurt Appreciate the input, but as the title mentions, these are issues we're seeing with the Boss ES-8/5 switchers. I could be content with sticking to one board per song but the issues mentioned above regarding PC#s reloading when already on a board, multiple CC#s aren't working and this is the only pedal the switcher has this issue with (and other TC pedals mentioned don't have this issue either) need to be addressed - leaning to improvements needed on the PX5. My concern at the moment is that I haven't seen much detail on the past in the way of firmware revision updates, and I don't want to have paid near £350‐400 to not be able to use a pedal for months (and no assurance islt's going to be resolved - as I am yet to receive a full statement from DevTeam)
        • Feb 26
  • New
    Skibodeau
    Newcomer - Level 1
    2021-02-22

    Hi,

    I'm running the Plethora with the 4 cables method correctly set up (guitar -> Plethora L in -> Plethora fx send to amp in -> amp fx send to Plethora return -> Plethora L out to amp return).

    Whenever I make some sort of operation (changing pedalboard, swapping pedals, changing toneprint, loading pedal in a slot) while the Plethora is processing (a half second maybe?) there is a crazy volume increase as if my amp was jumping to its max volume.

    If I run the Plethora in front of the amp, issue doesn't occur. You can only hear that the unit kind of bypasses all effects for half a second.

    Issue occurs on both true bypass and buffered mode.

    Anyone else having this problem?

    Amp is an Egnater Rebel 20.

    read more...
    0 9
    • Skibodeau
      PedroRodrigues Hi Skibodeau have you confirm that you have set up your four cable on PLETHORA X5 as per picture below. Please confirm by checking the videos presnet on the link below and https://www.youtube.com/watch?v=STMU5G1gND0 https://www.youtube.com/watch?v=fY_xM8HP0SI
      • Feb 23
      • Plethora X5 - 4 cables method volume issue
        Skibodeau Yes that's exactly how I hooked it up, like I wrote.
        • Feb 23
    • Skibodeau
      Skibodeau Here, I've made a video so you can hear what happens :

      First half of video, PX5 plugged direct in front of amp. Some slight volume glitch sometimes when switching boards but not too bad.

      Second half of video, PX5 plugged 4CM. Huge volume jump whenever making operations.

      https://youtu.be/8aY51NxzZXM
      • Feb 23
    • Skibodeau
      Skibodeau I did a lot of tests and figured out what is happening.

      When using the 4 cable method, the PX5 mono output goes straight into the amp's fx return. In the case of my amp, this is straight into the power amp which is post master level (i.e. If I plug just my guitar straight into the amp fx return, it bypasses all controls and I have no control over volume, it is very loud).

      So when the PX5 does any kind of processing, the signal going from its effect send is cut out. Since this is the signal that is hitting the front of the amp, the amp suddenly receives signal only at its the return point. In the video I did, the amp was set to be quieter than its power amp level, which explain the volume jump. So whenever the PX5 is processing, it acts just like I was pulling out the cable from the front of the amp.

      Since the PX5 fx loop is part of boards this will always happen as it has to reset every time boards are switched. I mean, I don't think my unit is defective, it's more the way it is designed.

      There are two ways that I think this could be fixed :

      1 - That somehow, the signal would not cut out from the PX5 fx send out while it is processing

      or 2 - That the signal would be cut out from both the fx send and stereo outputs during processing so that it goes completely silent

      I have no idea if either ways are technically possible. But I'd like to be confirmed that I'm right about what's going on. I don't want to get into the process of returning the unit and wait for it to get back only to learn that it's the way it is designed and there is nothing to do.

      Thanks!
      • Feb 24
    • Skibodeau
      eld3rlyy Hi there,
      I was just about to post the same issue and found this post.

      I have a pedal board containing the Plethora X5
      The PX5 is wired with 4CM as mentioned above to a PRS MT15 amp.

      When switching between boards, or changing pedals/toneprints in a specific board in edit mode there is an unbearable jump in volume, similar to what OP described here.

      This happens even if an expression pedal configured as volume pedal for pedal is placed in the heel-down position which is supposed to cut down all volume.
      I have also tried using a JHS Little Amp Black Box (essentially a master volume in the loop) before the PX5 to attenuate the amp - still the same issue.

      4CM is essential to have some PX5 effects in front of the amp and some in the loop.
      This issue is very significant and may lead to hearing damage.
      Please fix it.
      • Feb 25
      • Plethora X5 - 4 cables method volume issue
        Skibodeau Hi eld3rlyy,

        I did some tests and here is what I believe is happening. When the PX5 is processing (switching boards, swapping pedals, etc.) the signal that goes out the fx send is temporarily cut while the signal going out the main output remains. When in 4CM, the main output is going straight in the amp fx return. In some amps, the return is after the master volume. So what I guess happens, is the amp stops receiving signal in the front preamp but keeps receiving in its fx return so it bypasses the whole preamp and let the signal flow directly in the power amp at full volume.

        I did another another video where you can hear what happens with both outputs separately when playing (main & fx send) :

        https://youtu.be/7q3YrUw5NMo

        This really needs some sort of fixing. Indeed it could lead to hearing damage (on a bigger amp this could be really nasty). This could also go really wrong on a gig. Best way to drive any soundman mad.

        I did submit an assistance request but I suggest you do it too. I guess the more people mention it, there's more chances it is taken seriously.
        • Feb 25
      • Plethora X5 - 4 cables method volume issue
        eld3rlyy Thanks skibodeau. That has alot of sense. Theres all sorts of weird things with 4CM on PX5, when moving the amp to standby and then turning on again sometimes it will lose the signal aswell. Switching boards/toneprints or pedals/pedal order not only increases volume but sometimes adds a pop that goes through the plethora fx chain so its high volume and also repeated by PX5 delay if its on. Ive also submitted a ticket on the issue.
        • 1
        • ·
        • Feb 26
  • New
    scut52
    Newcomer - Level 1
    2021-02-22

    By all means, the Plethora X5 is an awesome pedal and has the potential to become THE pedal to rule them all. ;)

    But to get there, there is still a long way ahead. Even though the Plethora concept is different from what we know of e.g. the Zoom multistomps or the Boss MS-30, which use patches of several effects to create a certain tone and make this patch instantly available via the press of a single button, the Plethora still has the potential to come fairly close to that without loosing its own advantages!

    So, I am going to separate my ideas in two main areas: 1. Basic feature ideas that I'd love to see on the Plethora X5 and 2. Ideas that serve the purpose of augmenting the Plethora concept, thus making it the only pedal I want and need in the future.

    1. Basic feature ideas and improvements

    A.) Additional effects/pedals that I'love to have

       * Bodyrez pedal for my acoustic guitar

       * Overdrive pedal 

       * Envelope filter / wah pedal

       * some kind of bit crusher with vinyl scratches to create great LoFi sounds

       * fully-fledged Ditto+ Looper with the option to sync the loopers across different slots (which basically makes it a multi-track looper)

       * EQ pedal (I am aware of the workaround by modifying the compressor pedal)

     

    B.) Various (minor) improvements with big impact

       * improve bluetooth connection for toneprint (sometimes sending toneprints via BT just doesn't work! I am using an iPhone 11 pro)

       * allow cab sim per board instead of only globally (amp sim would be great as well but other features are more important to me ;))

       * allow tap sync across different effect pedals within a board (e.g. delay and trem or two different delays, etc.)

       * allow us to control the volume of each slot/pedal without using an expression pedal (I basically want to create different boards with different presets to match them to particular songs or guitars). Volume adjustments in edit mode are actually preferred.

       * allow to adjust more than 3 parameters in edit mode, e.g. by scrolling down to the next 3 parameters (like volume, etc.)

       * display the values/parameters that are being changed via hotknobs/expression pedal while changing them. To do that the 4 corners of each display could be used to show a smaller depiction of multiple value/parameter gauges. Only values that are currently being changed should be shown on the display.

       * enable trails while switching boards/banks to prevent the Plethora from chopping the sound

     

    2. Ideas for augmented use scenarios

    To create an effect similar to what patch based multi-FX-pedals offer, there must be a way to activate and deactivate an entire effect chain by pressing as few buttons as possible.

    If processing power (as well as complexity of setting it up) prevents the Plethora to offer an entire effect chain within one single pedal slot, there is another way that pops into my mind:

    If there is a way to make an entire board active by default when loading switching to the board, you could create exactly the same effect. One board could be considered one patch of 5 effects and switching the boards would be the same as switching patches. I would rather press two to three buttons to switch the boards (and therefore patches) than having to switch the boards plus enabling all 5 slots individually to get the new board/effect chain active.

    To make this work, allowing trails while switching boards is a mandatory feature.

    A light version of this feature could be to let the user chain two or more slots/pedals within one board together and create some kind of switch (e.g. a switching pedal on slot 1) to enable the user to switch between the two presets within the board.

     

    It would be great to see any of this in future firmware versions. The Plethora X5 has such a huge potential, it would be a shame to see it all wasted at the end.

    But looking at what the TC team has been able to pull off in the past, I am sure anything is possible!! :)

     

    Cheers guys

     

    read more...
    1 8
    • scut52
      Dale_M Many thanks we have passed these comments on to the DEV team.
      • Feb 23
    • scut52
      Jerome650 Here is a feature request - Give us a Proper PDF Manual/User-Guide!!! The Quick start guide is useless. I do not wish to watch a bunch of YouTube videos from Third Party
      • Feb 26
      • Plethora X5: Feature and improvement requests
        Jerome650 users and product testers. For $450 we deserve a well written manual. This is really poor customer service. I am still trying to decide if I will return this damn thing.
        • Feb 26
    • scut52
      MANUELG A small request, but huge help.... mix level or send/return mix for the FX loop “pedal",
      • Wed at 11:42 AM
  • New
    LukasLange
    Newcomer - Level 1
    2021-02-21

    Hi togehther,

     

    I bought a ND-1 and the last ownder did not tell me that it has some issues... 

     

    Issue 1: Freezing after bootig.. I guess it has to do with the EPROM wich seems to be faulty in a lot of cases on this units - I raised a Ticket for that to get a new one.

    Issue 2: I realized that 2 SMD Caps (one is C16 and onebelow the R35) on the back are broken (really broken) and the one Cap C151 next to the DSP is missing. Is there someone who can tell me the values of the missing parts?

    Is there a schematic for this device and or a service manual?

    A unit wich is below 200€ and years old is nothing I send to a repair shop as I am an electrician.

    So I hope someone cloud help me to bring this lovely piece of gear back on stage.

     

    Greetings from Germany

     

     

    read more...
    0 8
    • LukasLange
      Dale_M Many thanks for your post but I am afraid we cannot share schematics or service documentation with non partners, we advise organising a non warranty repair with PMS in Germany. https://www.pms.eu/index.php?id=deutschland0
      • Feb 21
      • Nova Delay ND-1 Servicemanual / Spareparts
        LukasLange Thanks for the reply.. but I said that a repair is uneconomic in this price range - I would appreciate I you could tell me only the values of the missing parts. that would really help me. You can send them via PM. Thank you.
        • Feb 22
  • New
    Matopotato
    Newcomer - Level 1
    2021-02-20

    Is it possible to use Toneprint to make one of the buttons on Sub'n'Up to make a 5th? Like the T.Rex Quint Machine?

    0 7
    • Matopotato
      PedroRodrigues Hi Matopotato, please consider that the SUB 'N' UP OCTAVER was designed to work exclusively with octaves so in regard to your question it will not make a 5th
      • Feb 22
    • Matopotato
      Matopotato Ok, thanks Pedro. It is a bit confusing to understand what you can do and not do with the editor
      • 11 hours ago
  • New
    Matopotato
    Newcomer - Level 1
    2021-02-20

    Anyone knows how to make the Octave Up on Sub'n'Up less synthetic sounding. It is a bit organ like for my taste

    0 9
    • Matopotato
      PedroRodrigues Hi Matopotato, please consider that you can raise the amount of bands used to generate the octave signal and apply a LPF to the filter, but please consider that the pedal was designed for fast tracking instead of format corrected pitch shift.
      • Feb 22
    • Matopotato
      Matopotato Thanks Pedro, I understand you can't do anything with a pedal which the pedal "can't do". I am trying to grasp the editor and it seemed to be loads of things to set. Will have to take some online training I found. Cheers
      • 11 hours ago
  • New
    LordTyranus
    Newcomer - Level 1
    2021-02-19

    For some reason 50% if the time when I record a loop in beat sense mode the loop won't play. It acts like it records but there's no audio play back.  

    any suggestions?

     

    thanks

    0 9
    • LordTyranus
      PedroRodrigues Hi LordTyranus, please consider that Ditto Jam senses beats during the loop recording process as well as during playback,during these times, it needs to hear a steady groove from the percussionist. Basic drum fills are okay, but mega-syncopated rapid meter changes are not, if the drummer, without warning, starts playing 30 BPM faster, chances are somebody in the band is going to get confused and might drop out for a while. Ditto Jam is no different. The product was designed to follow subtle, natural tempo movements, Ditto Jam needs a lot of the percussion hits to land on the on-beats. If Jam sees lots of syncopation such as a string of 8th or 16th note anticipations in a row, they’ll be interpreted as downbeats and this will affect playback timing. As your percussionist gets used to you using the product in certain song sections, simpler playing during those bits will yield better looping.
      • Feb 19
      • Ditto Jam 2x won’t play loop
        LordTyranus I don’t think that’s the problem. It acts like it’s recording the loop but then no audio plays back. Tech support emailed me back and said that I need to update the firmware and that should fix it.
        • 1
        • ·
        • Feb 19
Go to page