Statistics

250,738 members
127,934 posts
  • New
    virendrajaywant
    Newcomer - Level 1
    2021-09-07

    I have purchased this unit but need to know , at every channel there is a line in input. But is it balanced or unbalanced?

    Though output is dual mono !!!

    0 10
  • New
    tet024
    Newcomer - Level 1
    2021-09-05

    Good Morning, 

    I purchased 2 x iNuke DSP and I would like to hook them up to a DIY Home Theater Speaker.  The Idea is to use the Xover on the iNuke rather then building a passive crossover. My Question is:- Is it possible to have the woofers on Channel A with a 2 Ohm Impedance then the Tweeter @ 8ohm on Channel B ? Would that cause any issues ? Or effect Sound Output? 

     

    Regards,

    Etienne

     

    read more...
    0 9
  • New
    rsparkle22
    Newcomer - Level 1
    2021-09-03

    Is it safe to use pmp 4000 powered amp without speakers connected. I would like to use headphones and do home recording on the pc with tracks adding vocals. Thanks

    0 12
    • rsparkle22
      WilliamR Hello, Yes, solid-state power amps are safe to use without a speaker load. Only tube-driven amplifiers should not be run without a speaker load.
      • Sep 3
    • rsparkle22
      rsparkle22 Thank you.
      • Sep 3
  • New
    Petethetrump
    Newcomer - Level 1
    2021-08-30

    Hi does anyone know where I can purchase a power circuit board for the Berhinger Air X 18 as ours has blown. We get 360 vaults going in and even part way across the board but then it splits and only some of the components are getting the voltage , in short it's dead . 

    read more...
    0 16
    • Petethetrump
      Dale_M Hi there if you are looking for parts simply go to the Support tab above and select Parts so the team can advise price and availability.
      • Aug 30
    • Petethetrump
      Petethetrump

      Nobody has replied and we really need the part or the X 18 is useless to us . I’d appreciate someone’s attention to this if possible?

      • Sep 2
  • New
    jp182
    Newcomer - Level 1
    2021-08-30

    I just bought a second hand AMP800 and I've plugged 3.5 to 1/4 cable into the input L & R into the amp with a pair of headphones plugged into the headphone jacks on the front.  

     

    Not only do I not get any sound, I also don't see any of the LEDs on the front moving which is making me think the AMP itself is not working.  I've tried multiple input sources in both input A and input B; same result. 

     

    Any other suggestions before I email the buyer to get a refund on a defective unit?

    read more...
    0 11
    • jp182
      ChrisEdwards1 Hi jp182, Are you aware if the unit was supplied with its original power supply or a third-party power supply? If a third-party power supply, I would recommend double-checking all specifications to ensure they match correctly including the polarity.
      • Aug 29
  • New
    AlGoddard
    Newcomer - Level 1
    2021-08-25

    so I just bought this 68.4 without knowing anything about it , I looked up specs and saw the power and that was good enough for me then I brought it home took a closer look and im like man I hope i didnt throw my money away so my question is simple do you have to use the software to control it and is it really only available on windows xp and 2000 and do i need this nomad hub thing any info would help thx 

     

    read more...
    0 9
    • AlGoddard
      DavidKnighton Hello AlGoddard,
      The Lab Gruppen C Series are not smart amplifiers, meaning there's no active DSP within them. Likewise, since there's no DSP there's also no proprietary software. The NOMARDLINK and software is only for use as a remote monitoring network. For example, you have 100 amplifiers and need to network/manage them all from a discreet location within an installation. The Nomadlink will allow you to do this, but it is not necessary for smaller standalone installations. As for compatibility, I have the software running on Windows 10, but that shouldn't matter much as I doubt you'll be using it.
      • Aug 25
  • New
    TobyWilson
    Newcomer - Level 1
    2021-08-22

    Hi there. Just looking for some help. I want to bridge channels A and B and also channels C and D together to effectively create a 2 channel amp (with more power). I have linked channels A & B and reversed the polarity oh channel B then connected to the +1 and +2 terminals of the speakon out for one side, then the same with channels C & D for the other side. Is this the correct way to do it?

    Also - how should I use the gain knobs on the front of the amp when in bridge mode in this way as gain knobs A and B both seem to affect the gain (same for C & D). I hope that I have explained this all ok. I am using the amp to drive 2 x Nexo PS15s in passive mode.

    Thank you for your help. If you have a manual for this amp I'd be very grateful as cannot find one online. 
    Best wishes,

    Toby

    read more...
    0 16
    • TobyWilson
      Nigel67 Hi TobyWilson. Well this has certainly perked up a few memories with some of the slightly older colleagues :). It seems as though this amplifier was an obsolete product in 2005, so its doing well. I am afraid that we do not have a manual, but three people have come up with all the answers for you. Its not pretty I am afraid, but better than nothing. Evidently, if you can find one, the 1300C manual was very similar
      • Aug 23
  • New
    SJFlesch74
    Newcomer - Level 1
    2021-08-21

    Hello!

    Does anyone know how to get in contact with someone regarding repairs for a Behringer power amp? We submitted a ticket (Ticket Number: CAS-480871-P8N9F6), but it was closed and we received no response. Any help would be greatly appreciated.

    Thanks!

    read more...
    0 20
    • SJFlesch74
      ChrisEdwards1 Hi SFlesch74, upon checking your case I can see one of my colleagues reached out to you on 20/08/2. Could you please double-check your spam and junk folder for their response? We have seen our replies route to this location before.
      If there is nothing in your spam/junk folder could you please let me know and provide an alternative email address? I will then request they reach out again.
      • Aug 21
  • New
    gelito
    Newcomer - Level 1
    2021-08-21

    Hola. Hace un par de meses compré este artículo a través de Thomann junto a la U-PHORIA UMC202HD. Las conexiones que tengo son del micro de condensador con xlr a una de las entradas del ULTRAGAIN (línea 2)y desde este una salida con xlr a una de las entradas de la interfaz, la cual está conectada por usb al pc. Creo que hasta ahí está todo correcto. Luego al dar volumen de entrada al micro (un RHODE NT1A), suena un ruido de como de metralleta de clips horrible, lo cual empezó a ocurrir desde hace varias semanas. Sin embargo, en el otro canal tengo conectado de la misma forma otro micro Presonus con AUDIOBOX USB96 y no ocurre lo mismo, igual que si todo lo anterior lo conecto a la línea 1. Por favor, ¿podéis decirme si estoy haciendo algo no correcto?. ¿Se puede deber a un problema en el ULTRAGAIN?. Os dejo un archivo para que lo comprobéis. Gracias.

    read more...
    0 58
  • New
    Parky58
    Newcomer - Level 1
    2021-08-16

    I have submitted a care ticket and now received an RMA to return for repair. I received an email requesting collection details but the email stated it does not accept direct incoming emails. Nowhere can I find who to respond to.

    I have found the Music Tribe website incredibly difficult to navigate, hence my question here. The site shows 4 support staff with telephone headsets but no number to speak to anyone.

    Can anyone advise how to contact Customer Care to relay these details?

    Thanks in advance.

    read more...
    0 25
    • Parky58
      KyleJohnson Hello, Kyle here with Music Tribe. You can reply directly to the email that you received. The system will not accept a new email from a separate thread if you try to send one in to that address, but as long as you reply directly to the email and do not alter the subject line the email will be received correctly.
      • Aug 16
Go to page