Statistics

254,563 members
132,264 posts
  • New
    Lergei
    Newcomer - Level 1
    2021-04-27

    Hi! I'm new here and don't know if i'm writing to right place but i bought this nice old SS300B power amp and i need service manual for it, can someone help me?

    Mikko 

    0 95
    • Lergei
      Nigel67 Hi Mikko, I am sorry, but I do not recognise this amplifier. If we do have schematics, then unfortunately we are not permitted to distribute them. There was a LAB 300. Is this what you have?
      • Apr 27
  • New
    mcolmer
    Newcomer - Level 1
    2021-04-22

    It is really hard to get importation organized during the pandemic, we just need one EPQ304 to complete our sound lab build...

    0 55
  • New
    neailyb
    Newcomer - Level 1
    2021-04-14

    Need amp fixed

    0 51
    • neailyb
      WilliamR Hello, William from musictribe here. Please click on the support link above and create a tech support case and someone will contact you ASAP.
      • Apr 14
  • New
    Disgrunt
    Newcomer - Level 1
    2021-04-14

    Hi everyone,

    I was wondering if anyone knows how I can track a delivery to Australia of Behringer KM750?

    My music store took my order in November 2020 and then said the unit was not available in Australia and they were awaiting delivery from China which was delayed due to political issues and COVID. Which all sounded reasonable.

    They said it would be delivered by end of December. This then got blown out to end of January. Then Feb etc. Today I got an email saying Behringer now wouldn't give any ETA at all.

    Can anybody help with this? Maybe how to track it down?Has anybody in Australia had a delivery since Novemeber or December come in?

    Thanks for your time.

    read more...
    0 78
  • New
    Mociralb
    Newcomer - Level 1
    2021-04-11

    I've lost the power supply in my Behringer PPA2000BT. Lights flash, no sound I need to fix this power supply or buy a new one.

    Schematics, sugestions, help?

    0 113
    • Mociralb
      RexBeckett Hi Mociralb, I suggest that you raise a Care ticket for this.

      At the top of this page, click Support then scroll down the new page and select Parts. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • Apr 11
  • New
    Pogre
    Newcomer - Level 1
    2021-04-10

    Oh boy, where to start. Hi there!

     

    Okay, a friend gave me a NX3000D to power my passive sub and told me one channel was inoperable. Right now I have it set to "Bridge" mode using a RCA to 1/4" T/S cable from my subwoofer preout to input A on the amp. I'm using a Speakon to bananas connector from output A to my 4 ohm subwoofer, a RBH SV-1212NR, a passive sub. Everything is working.

     

    My question is about the channel my friend said was inoperable. In stereo mode he said only the B input/output works and there's no signal for the A output (in stereo mode). I have it set on Bridge mode using the A input/output and it's working well. Both green lights above the A and B dials illuminate when I play something. Room correction had me set the gain at about 11 o'clock on the dial. Does this mean I have the amp set to maximize output and have available full rated power, 3000 watts, to my 4 ohm sub? Have I done this correctly?

     

    Sorry for the rudimentary questions. I'm new to pro amps and still a little confused with the menus. Plus my friend added to my confusion telling me about the inoperable channel when in stereo mode.

    read more...
    0 89
    • Pogre
      Paul_Vannatto If the one channel is not working, you will only get the power output of the other channel, even in bridge mode.
      • Apr 10
  • New
    jazzed
    Newcomer - Level 1
    2021-04-09

    Hello,

    How do I get in touch with Labgruppen in order to apply for a job or get information about available jobs.

    Jazzed

    0 75
    • jazzed
      DavidKnighton Hello jazzed,
      At the top of the page, please click ABOUT and then JOIN US from the drop down menu. Continue clicking through to find available job listings.
      • Apr 9
  • New
    Gheorghe17
    Newcomer - Level 1
    2021-04-05

    Hello,

    just got a used Lab Gruppen IP450, love this amp but the face plate ha some scratches.I need a new one and I was wondering if I can still find this kind of spare part ?

    Thank you in advance and hope for your positive reply.

    GD

    read more...
    0 53
    • Gheorghe17
      Nigel67 Hi Gheorghe, Please contact our spares team and they will be able to advise you availability and pricing. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spares tab and submit a ticket. Many thanks
      • Apr 5
  • New
    johnaldrsn
    Newcomer - Level 1
    2021-04-03

    Hi there, first post here.

    I have a Lab Gruppen C20:8x and am getting no output from channel F. The CPL fault LED is constantly illuminated (orange) for that channel, also the VHF fault LED. This is irrespective of whether inputs/outputs are connected or not.

    Can anyone advise pls? Feel free to ask for further info. Thanks in adv,

    John

    read more...
    0 74
    • johnaldrsn
      DavidKnighton Hello johnaldrsn,
      This type of issue would warranty a service request ticket. Please click on SUPPORT at the top of the page and then scroll down to SERVICE REQUEST to stat your inquiry.
      • Apr 3
  • New
    grundkvist
    Newcomer - Level 1
    2021-03-31

    I'm having issues with the firmware update crashing without installning. I have no problem connecting using the NX Edit.exe tool. I've tried to run the program in compatability mode, both windows 8 and 7 but with the same result. Dont know how to proceed. I cant really find any information regarding how to firmware update.

    read more...
    0 139
Go to page