Statistics

223,463 members
97,657 posts
  • New
    Mociralb
    Newcomer - Level 1
    2021-04-11

    I've lost the power supply in my Behringer PPA2000BT. Lights flash, no sound I need to fix this power supply or buy a new one.

    Schematics, sugestions, help?

    0 1
    • Mociralb
      RexBeckett Hi Mociralb, I suggest that you raise a Care ticket for this.

      At the top of this page, click Support then scroll down the new page and select Parts. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • 16 hours ago
  • New
    jazzed
    Newcomer - Level 1
    2021-04-09

    Hello,

    How do I get in touch with Labgruppen in order to apply for a job or get information about available jobs.

    Jazzed

    0 4
    • jazzed
      DavidKnighton Hello jazzed,
      At the top of the page, please click ABOUT and then JOIN US from the drop down menu. Continue clicking through to find available job listings.
      • Fri at 2:11 PM
  • New
    Gheorghe17
    Newcomer - Level 1
    2021-04-05

    Hello,

    just got a used Lab Gruppen IP450, love this amp but the face plate ha some scratches.I need a new one and I was wondering if I can still find this kind of spare part ?

    Thank you in advance and hope for your positive reply.

    GD

    read more...
    0 3
    • Gheorghe17
      Nigel67 Hi Gheorghe, Please contact our spares team and they will be able to advise you availability and pricing. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spares tab and submit a ticket. Many thanks
      • Mon at 1:38 AM
  • New
    johnaldrsn
    Newcomer - Level 1
    2021-04-03

    Hi there, first post here.

    I have a Lab Gruppen C20:8x and am getting no output from channel F. The CPL fault LED is constantly illuminated (orange) for that channel, also the VHF fault LED. This is irrespective of whether inputs/outputs are connected or not.

    Can anyone advise pls? Feel free to ask for further info. Thanks in adv,

    John

    read more...
    0 0
    • johnaldrsn
      DavidKnighton Hello johnaldrsn,
      This type of issue would warranty a service request ticket. Please click on SUPPORT at the top of the page and then scroll down to SERVICE REQUEST to stat your inquiry.
      • Apr 3
  • New
    jmott2
    Newcomer - Level 1
    2021-03-15

    I lost the power cord.

    Is there a replacement available as it has a unique female connection shape?

    0 10
    • jmott2
      Paul_Vannatto If it is like the PMH880S, it uses a standard IEC receptacle. That means that any computer style IEC cord will work.
      • Mar 15
    • jmott2
      Fourlane1956 Hi, I have the harmony singer tc helicon pedal that I purchased new a few years ago,item 996361005,looks new,kept in the original box and never dropped. something has gone wrong, the tone button stays on and I believe its affecting the sound, is there any info on this issue.
      • Mar 15
    • jmott2
      Fourlane1956 I have power,
      • Mar 15
    • jmott2
      Fourlane1956 the tone button will go up and down but red light stays on and the green light only stays on till i press the main footswitch, then only the tone stays red along with the harmony light till i press footswitch again to turn off harmony light
      • Mar 15
    • jmott2
      Fourlane1956 your reply did not make any sense
      • Mar 15
  • New
    CustomerServiceGroup
    Newcomer - Level 1
    2021-03-08

    Need to return one LAB GRUPPEN 4000W AMP W/4 FLEXIBLE OUTPUT CHANNELS/L Mfg Part #: D40-4L-US for credit but keep getting an automated email saying that I have to send it in for repair service.

    please assist

    read more...
    0 14
    • CustomerServiceGroup
      Nigel67 Hi. I will message my colleague in Service dealing with your case and ask him to advise why we will only repair the unit. I am afraid that only he knows the reason for this. The warranty policy is that a doa (credit) can only be claimed within 30 days of purchase by the customer. If it is over this, then the unit will be repaired and returned. As I mentioned, I do not know what the situation is here, but I will ask the colleague to explain this to you.
      • Mar 8
  • New
    NickWixom
    Contributor - Level 2
    2021-03-06

    I'm building an amp rack and using multiple NX6000 amps for my subwoofers in mono. I'm waiting for these amps to be delivered, so in the meantime... If I run these in Mono so that both channel A & B are using the same input, will the TRS input on channel B pass the signal to another amp?

    My EP4000 amps do this, and I've not run into an amp that doesn't, but I can't find any documentation on this for these. 

     

    Thanks

    For reference, I'm going to use 3 of these to power 6 Berlin series single 18" subs, I have 2 EP4000 amps that power 4 Berlin series 12" tops. Running an M32 Core with a DL32 for my small system. Double the subs and tops with a Wing, DL32, DL16, SD16 and SD8 for my bigger system. 

    read more...
    0 10
    • NickWixom
      PedroRodrigues Hi NickWixom please consider that you are correct the NX6000 in mono will in fact have the same signal on both channels A and B and you will be able to daisy chain the NX6000 using a Speakon cable . Thank you
      • Mar 25
  • New
    Robertdude
    Newcomer - Level 1
    2021-03-05

    I bought a used v22 bugera. It's missing the logo plate word. Where do I find some of those.

    0 11
    • Robertdude
      ChrisEdwards1 Hi Roberdude, if not already done so please open a parts request ticket and a member of the parts team will be able to assist further on this. To do this go to support at the top of the page and scroll down to the Parts section.
      • Mar 4
  • New
    Martydrummer
    Newcomer - Level 1
    2021-03-01

    Good Lord what a pain in the butt they make you fill out all this tribe crap just to ask customer service a question. What planet is this

    0 16
    • Martydrummer
      PedroRodrigues Hi Martydrummer please consider that the MT Community allows users to share knowledge and experiences to create a full sense of a knowledge sharing community . The MT Community also allows you to register your units and manage any request made to any MT department but you must consider that for specific requests you have specific areas you must go to request them such as service. On top of the MT Community page you have Support as you can see on the picture below, this will give you access to all the support options such as Product registration, Tech.Support and service among other as you can see on the picture below. I hope this clarifies the process. Thank you
      • Mar 3
    • Martydrummer
      Martydrummer I don't mind that you have the option to create an avatar and give us a form similar to filing taxes, for people that have nothing else to do. But there should also be a phone number or email just to ask a simple question about your product
      • Mar 3
  • New
    DJMD888
    Newcomer - Level 1
    2021-02-20

    Hi, new to the forum and about to take receipt of my first Behringer AMP. I would like to ask the tribe about running the NX3000 in bridge mode, do I have to rewire the output speakon cable amp end to +1+2 as well as flipping the bridge mode switch.

    My set up will comprise of a Numark Scratch mixer to a Behringer Ultragraph EQ with channel 1 split to my monitors and channel 2 to the NX3000, from there I intend to bridge the signal to my first sub (8ohms) then onto the second creating a 4ohm load and hopefully a stable clear sound to enjoy.

    Appreciate any advice and help.

    ??

    read more...
    0 29
    • DJMD888
      DaveMorrison Yes. Unless the cabinet has some type of mode switch or and extra input speakon wired specifically for bridge mode amps.
      • Feb 20
Go to page