Statistics

285,931 members
167,993 posts
  • New
    j0hn5c4t
    Newcomer - Level 1
    2022-05-21

    I have a

    Behringer V-Ampire LX1200H that needs knobs replaced.

    Do we have access to these type of parts?

    0 2
    • j0hn5c4t
      Nigel67 Hi j0hn5c4t. I am afraid that the LX1200H is a legacy product so it is unlikely that there are still spares around for it. You could try, by going to the nearest authorised service to you and asking there. here is a link to finding the closest service centre to you - https://www.behringer.com/buy.html?type=POS
      I do not have access to a full parts list, but from what I can see there are two types of knob, 9 of one and another with a red dot on it. I would however confirm that both parts are correct. All the best
      9 x W52-90500-28075
      1 x W52-20500-28076
      • May 22
  • New
    JimiCactus
    Newcomer - Level 1
    2022-04-12
    0 10
    • JimiCactus
      ChrisEdwards1 Hi JimiCatus, If you have not done so please submit a parts request. This can be done via the support tab at the top of the page.
      • Apr 12
      • Where can I order and get instructions on how to replace aBERHINGER EUROLIVE B208D 1.5 COMPRESSION HORN DRIVER
        JimiCactus BERHINGER EUROLIVE B208D 1.5 COMPRESSION HORN DRIVER ON EBAY
        • Apr 13
  • New
    jackman66
    Newcomer - Level 1
    2022-03-15

    Hello!

     

    I have a Behringer V-Ampire LX1-112 amp, and I finally replaced the damaged dual jack input module (input and headphones), but somewhere along the way, the volume pot and red light power level display has stopped working. Not sure why; all connections are solid and the module is brand new. Neither the new module nor the old module make a difference to the power to the volume pot. All the other pots and red light levels show up on all the other knobs, but not the volume. Can someone please tell me what pot I need to find? Is there a specific model number? The replacement looks pretty straightforward, so I am happy to do some soldering and resoldering if needed. Thanks for all your help!!!

     

    Jack

    read more...
    0 12
    • jackman66
      Dale_M Hi there if you are not familiar with electronics rework it can be easy to fix one problem and create another, we cannot share schematics but if you advise the pots component position on the PCB we could advise the part that is used. That said, it may be far quicker for us to assist you with a local non warranty repair at an official Behringer repair centre, if you wish to take this advice simply go to the Support tab above and select Service.
      • Mar 16
  • New
    Blackwido
    Newcomer - Level 1
    2022-03-14

    Thanks for reply I tried 9v battery on one no difference.. never mind think about a multi unit instead tks

    0 11
  • New
    sands
    Newcomer - Level 1
    2022-03-02

    I am using a Behringer EP4000 to drive two 15" Folded Horn Subwoofers i built in my home theatre.

    Is it possible to buy a quieter fan, or do away with the fan?

    0 7
    • sands
      Dale_M The fan is required we do not advice disconnecting. There may be quieter fans available on the market but we cannot advise on retro-fitting these due to health and safety and any possible damage that may be caused to your unit. Any existing warranty will be void.
      • Mar 2
  • New
    Petethetrump
    Newcomer - Level 1
    2021-08-30

    Hi does anyone know where I can purchase a power circuit board for the Berhinger Air X 18 as ours has blown. We get 360 vaults going in and even part way across the board but then it splits and only some of the components are getting the voltage , in short it's dead . 

    read more...
    0 25
    • Petethetrump
      Dale_M Hi there if you are looking for parts simply go to the Support tab above and select Parts so the team can advise price and availability.
      • August 30, 2021
    • Petethetrump
      Petethetrump

      Nobody has replied and we really need the part or the X 18 is useless to us . I’d appreciate someone’s attention to this if possible?

      • September 2, 2021
  • New
    PepaLesak
    Newcomer - Level 1
    2021-07-20

    Hello eveybody,

    my 12 year old  FP6400 stoped working. One channel stopped working / after 5 minutes is only noise on output .

    Second channel working normally.

    There is +- 155V on main power supply but on power trasistors is +9V and -2 V. Second channel have +-7V.

    All of the power transistor are OK

    Can somebody help me ? Do anyone have the scheme then I could try to fix it myself? 
    thank you

     

    read more...
    0 43
    • PepaLesak
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact our Service team for further assistance with this issue. Click on Support, and then on Service Request to submit a case.
      • July 20, 2021
  • New
    AndriusLau
    Newcomer - Level 1
    2021-07-20

    Hey eveyone, my CP1A -12 volts rail stopped working because of my own fault. Do anyone have the scheme so I could try to fix it myself? 
    thanks in advance!

    Andrius.

    0 60
    • AndriusLau
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact our Service team for further assistance with this issue. Click on Support, and then on Service Request to submit a case.
      • July 20, 2021