• 2020-07-31

    Hey,

    Does anyone know if you can turn the reverb on the IP3000 manually instead of using the iPhone app? I went through the menu on the sub and didn't see any options to turn effects on. Maybe I'm overlooking something ?

    Thanks

    Andrew

    read more
    0 3
    • Apgilbert2
      Alexander Lane I am sure this is possible, but don't have a unit to find the exact button sequence right now. Let me see if I can find out for you!
      • Jul 31
    • Apgilbert2
      Alexander Lane I feel like this is somewhere on the Process -> Input menu...
      • Jul 31
    • Apgilbert2
      Apgilbert2 Thanks, Alexander....I did go through the menu but didn't see. I read the instructions and it says that you can do it manually or with the app...I will check the speaker out tonight - maybe I overlooked it.
      • Jul 31
    • Apgilbert2
      Apgilbert2 If anyone else knows how to turn the effects on, feel free let me know what I should be looking for. Any help is appreciated!
      • Jul 31
  • 2020-07-17
    Hello all... I own 2 x ip2000 and 1 ip300. I am looking for specific details of the DSP settings that are provided. What exactly is happening between the various options? (IE: Wall position versus Floor... Live Music versus Speech) What electronic changes are taking place? Does anyone have access to any graphs or written information? best!
    read more
    0 3
  • 2020-07-13
    I cannot find an archived post in the old forum about this but have seen it mentioned. My IP1000 has a crazy buzz/rattle in a certain low-mid frequency. Once I dial it out it with an EQ it sounds 'empty' with no body. I'm mixing through an MR18 for an acoustic setup. I've tried numerous things to remedy with little success. It's like the sub bass cabinet vibrates at a frequency and it rattles the column at it's mechanical connection. Help, I own two and they both do it. Any suggestions appreciated. I love the units.
    read more
    0 2
    • James Leblanc
      Goetz Hi James,
      sorry to hear that! Could you please go to "Support" and create a new ticket – my colleagues will help with a solution!
      Cheers
      Goetz
      • Jul 13
  • 2020-07-10
    Anyone know what the typical response time is after you create a Care Ticket? Other than the automated email resonse I got back 5 days ago I've heard nothing.
    0 33
    • Michael Wise
      William Reichling Hello Michael, I'm sorry, due to a server migration we are running a little behind. What is your case number?
      • Jul 10
      • Response time?
        Michael Wise I'll send him an email.
        • Jul 14
      • Response time?
        Michael Wise Thanks for your help!!!
        • Jul 14
      • Response time?
        Michael Wise Any word???
        • Jul 20
      • Response time?
        Michael Wise I wrote another email to you and Colton. Just checking.
        • Jul 20
    • Michael Wise
      Michael Wise William. Help again. I emailed Colton on Tuesday and I haven't heard back from him. We are obviously having email problems. Or he hates me and thinks I'm ugly. Is there a phone number I can call to get this ball rolling faster? I need that speaker for a wedding I'm doing on August 1st. Sorry to bug you with this.
      • Jul 16
    • Michael Wise
      Michael Wise Hello Again...Sorry for being a pain. I just really need to get a new speaker soon. I sent you and Colton another email to see if it was working yet. Please let me know. Thank you!
      • Jul 18
  • 2020-07-10
    Hello, I tried to update the firmware to 2.2.2 via the Android Turbosound app. The connection between tablet and turbo sound is established (.. handshake ... erasing rom ...) but then the progress bar remains at 0% and the turbo sound is permanently in firmware mode. Unfortunately the firmware file cannot be loaded from the Turbosound homepage (error message on page, seems to be offline). CARE ticket already created, so far no feedback. Ideas why? Otherwise I send everything back to MusicStore, soon I don't feel like it anymore. Maybe someone can send me the firmware as a file and then try the Bluetooth share please. By the way: there are pixel errors in both displays, although the resolution is very low. Why that bad quality?
    read more
    0 12
    • Patrick Lenuweit
      Chris Edwards Hi Patrick, hope you are well. I have just sent the firmware file across to you in your case along with some additional feedback on the display. Hope this helps.
      • Jul 10
    • Patrick Lenuweit
      Patrick Lenuweit Dear Chris, Thank you for sending the firmware file quickly, the firmware upgrade worked perfectly for both speakers without an APP via Bluetooth Share. The speakers are working properly.
      • Jul 10
  • 2020-07-08
    Hi all, any help greatly appreciated. My active wedges have developed a fault.......they both emit a loud squeal / hiss / crackle whenever I plug any XLR into them. Anyone come across this? As above, annoyingly I can't open a care ticket. They were bought directly from Turbosound when they were in Partridge Green, UK. https://www.fullcompass.com/common/files/17445-TXP121UserManual.pdf Adam
    read more
    0 4
    • TT23
      Nigel Turner Hi TT23, if you could put in a support ticket, put another model name in, but in the Subject and Description just highlight the actual speakers you are describing and a colleague will pick the case up and answer you.
      • Jul 8
    • TT23
      TT23 Thanks Nigel, as I'm then prompted to add the serial number I suspected the ticket wouldn't go thru but will try. Fingers crossed
      • Jul 8
      • TXP-121 Fault (Not a model option when opening a care ticket)
        Nigel Turner Just put in 123456. There isn't a check on the serial number
        • Jul 9
  • 2020-07-07
    Hello, we are located in Southern Ohio. We were wondering if Turbosound has released the Manchester series yet? Also, wondering if they’ve done any events concerning the Manchester series. We held off on purchasing a different brand because of our history with Turbosound TMS-3, Flashlight/Floodlight series...
    read more
    0 7
  • 2020-07-06
    Anyone know where to buy a TS-18SW2000A6? It's the 18" speaker in a Turbosound iQ18B.
    0 10
    • Michael Wise
      Rex Beckett I suggest that you open a Care ticket. At the top of this page, click Support -> Care -> Create a Care Ticket and select Type: Spare Parts. Make sure that you enter all required (*) data before clicking Submit.
      • Jul 6
    • Michael Wise
      Michael Wise I already did that. Thanks Rex!
      • Jul 6
  • 2020-06-21
    I have two IP2000 speakers and one works fine but the other has very little volume and sound seems to break easily. Looking for advice since I have little knowledge about speakers.
    0 35
    • mmccutchen
      Gary Higgins Hi, the only advice to start anyway is duplicate every setting from the working one to the faulty one, if no improvement, you may need to put in a CARE ticket to have it repaired.
      • Jun 21
    • mmccutchen
      Gary Higgins The gain settings need to be equal, dsp etc. Easy to skip one by mistake.
      • Jun 21
    • mmccutchen
      Alexander Lane Try Performing a factory reset;

      Hold down the encoder Knob and Setup button while powering on the unit, follow all the on screen test instructions.
      • Jun 23
  • 2020-05-30

    Hi everyone, I just bought a pair of IQ15 and a IQ18B, anyone knows how can I do a Factory reset on the settings and parameters? Would it do it automatically if I just run the firmware update? Also it is the older version of both, they still have the 1.7 firmware, any problem when updating to 2.2? Greetings 

    read more
    0 80
    • Jose Alas
      Gary Higgins

      @netoalas 


      Hello, they should update just fine to the latest firmware. I don't recall a factory reset option but the parameters are straightforward enough to easily set such that the DSP is bypassed and eq is flat etc etc. I also think it more or less resets when you update it.

      • May 30
    • Jose Alas
      Alexander Lane

      Hi @netoalas 


      Power up the unit whilst holding down the PROCESS button to enter the self test.


       


      Press the buttons in sequence to run through the self test. The buttons on the LCD will fill as buttons are pressed, once complete the unit will be reset to factory settings.

      • May 31
    • Jose Alas
      Jose Alas


      @AlexLane wrote:


      Hi @netoalas 


      Power up the unit whilst holding down the PROCESS button to enter the self test.


       


      Press the buttons in sequence to run through the self test. The buttons on the LCD will fill as buttons are pressed, once complete the unit will be reset to factory settings.





      Hi Alex, Thanks for your help. I tried this and it did make a sort of test but it didn't reset the settings. I just updated the firmware and gave a reset to everything by selecting the loaded parameters the speakers have. It worked like a charm, everything is sounding tight.  I am loving the crisp high and mids I am getting, and the sub is not as chest pumping as I expected but I am loving the sound and depth it produces.  


       

      • Jun 1
    • Jose Alas
      Jose Alas

      Hi @AlexLane @GaryHiggins, I have a different question. Would you consider the SETUP that it brings INIT_DATA the best standard setup for the speakers? What would you consider the BEST standard parameters for the IQ 15 and the IQ 18B?  


       


      greetings and thanks for your awesome help 

      • Jun 1
    • Jose Alas
      Alexander Lane

      Hi @netoalas 


       


      In the Xover settings menu, on the iQ15 select the iQ18B setting


       


      SImilarly, on the iQ18B, in the Xover menu, select the iQ15 setting


       


      That will match the two up perfectly, with no need for extra settings


       


       

      • Jun 1