Statistics

229,104 members
104,079 posts
  • asui
    Contributor - Level 1
    2019-10-29

    Where can i relocate the Top columns for the turbosound ip 3000 for purchase  thanks

    0 78
  • dilbert_3000
    Contributor - Level 2
    2019-10-21

    I have a switch in the booth on my TBV123 line arrays to remove and apply power, before powering up and down the X32.  When I use the switch, the speakers power up normally but when I power them down, while the X32 is powered up, the speaker LCD screens flash blank a few times and occassionally I can hear a slight clicking in the speakers in conjunction with the flashes. 

    The speakers do not try to boot and  nothing appears on the screen, only the LCD screen backlight flashes blank multiple times over 5-10 seconrds before going dark completely. (The number of flashes and duration is never the same)  I have a couple floor monitors on the same circuit, which go dark immediately as expected. All the speakers are supported over Ultranet connections back to the X32 through a P16 Distributor.   

    read more...
    0 103
  • oregandave
    Contributor - Level 1
    2019-10-13

    Just wanting to keep with the turbo sound brand and look and am looking for subs that would compliment the ip300s. Was looking at the ip12b but have no use for the extra power amps for passive tops and also would need a crossover from what I've been reading. Any help/suggestions would be very welcome.

    read more...
    0 141
    • oregandave
      oregandave

      Anyone ?

      • January 17, 2020
    • oregandave
      Diepsloot

      What is the main way you are using them? Mobile dj, solo musician, indoors, outdoors, corporate events? Maybe someone's ears might perk up to help if you are more specific and they can tell you what use they have given them. 

      • January 18, 2020
  • gm12338
    Contributor - Level 1
    2019-10-12

    I sent back a Samson VX8.1 line array pa unit that was not working properly and decided instead to buy a Turbosound IP1000 which I rec'd 10/12/2019.  I only ran the IP1000 a few hours to practice on my Roland RD-2000. The rear metal plate where inputs plug in, gets almost too hot to touch.  Should I be concerned about internal heat build up as I don't see a visible cooling fan nor any air vent ports.  On the Samson VX8.1 I returned, plus many other models I've researched, do have a visible cooling fan and or air venting with some having possible non-visible internal fans. On this blog somewhere, I read someone was asking IF there was an effective way to retrofit a cooling fan solution for their speaker.  I do "know" that excessive heat does in fact break down electronics over time.  IS there any internal fan or any air porting/venting in any of the Turbosound Inspire IP1000 thru IP3000 models? I like the sound I'm hearing, I'm also thinking about pa system longevity too.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    read more...
    0 105
  • scredly
    Contributor - Level 2
    2019-10-09

    Is there a button/power sequence to reset an IP2000?   Out of nowhere, the input sensitivity of one of my units is out of whack.   One unit volume is at 4.5 and the other is now at 26 to match it.     

    0 152
  • FrankHarlan
    Contributor - Level 2
    2019-10-02

    I can here a signal from the HF driver, but nothing from the LF driver. I have updated the firmware and it did not fix the problem.  Any suggestions?

    0 166
    • FrankHarlan
      Paul_Vannatto


      @FrankHarlan wrote:


      I can here a signal from the HF driver, but nothing from the LF driver. I have updated the firmware and it did not fix the problem.  Any suggestions?





      Hi Frank,


      Welcome to the forum. Have you had a look at the EQ or crossover settings in the DSP? It may have a very high high-pass setting.


       

      • October 2, 2019
    • FrankHarlan
      MatteoBarbaro

      Hi Frank,



      I think that shoud be the connector between the amplifier and the LF speaker, if you don't solve the problem with the suggestions of Paul of course. Remember that iQ loudspeakers are Two way biamp, so you have two amplifier output, one for each way.


      If it's in warranty i suggest you to contact your reseller.



      Regards,



      Matteo

      • October 28, 2019
  • Djchillb
    Contributor - Level 1
    2019-10-02

    Hello, 

    I will be attending the bpm trade show this weekend in Birmingham and o note that you will also be attending, I did enquire last year about the ip300 but you hadn't brought 1 with you

    if poss can I ask that you take 1 this year so I can have a look / listen as very interested in a pair

     thanks Ryan

    read more...
    0 86
  • BigFire
    Contributor - Level 1
    2019-09-25

    I recently purchased a brand new full TLX84 rig and for the life of me cannot find crossover points at all for the HF and LF in this box. Can someone give me the HF and LF ranges? I can only find the range for the entire box.

    Also, when I was researching the Turbosound website said I would be provided with EASE files with these. I got nothing and can't find anywhere to download these. Help! I just invested a lot of money and would like to have these basic things. Thanks!

    read more...
    0 181
    • BigFire
      MatteoBarbaro

      Hi,
      Turbosound doesn't release DSP settings for TLX array's series, you must use dedicated amps, Lab gruppen PLM+ with Lake DSP on board. Eq settings, limiters, crossover and eq overlay are in the DSP presets downloadable from the product page.


       


      BR

      • October 16, 2019
  • dhsherbert
    Contributor - Level 1
    2019-08-12

    Hello!

    I have an iP300 that I use with my EWI5000. It is stated that the iP300 has Reverb/EQ, but I can not find how the control the Reverb (and neither can the Tech Support for Sweetwater Music). Can anyone help?

    Thanks!

     

     

     

    read more...
    0 150
    • dhsherbert
      KenMitchell

      Hi Douglas ( @dhsherbert ), 


       


      Welcome to tthe community. 


       


      Disclaimer: I don't have one of these in front of me.   From looking at the QSG on Page 9 and 10, it looks like you press the "Process" button, use the encoder to get to "Input", and then it gets fuzzy.  I can't tell if you press the encode knob to select or the "Enter" button to select.  Once selected, you should see Channel A, Channel B, and Channel BT.  Again, use the encoder to rotate through the options and then select it with whatever method you found above that works.  You should be able to adjust input level EQ and Reverb for A and B. 


       


      Hope this helps, 


      Ken


       

      • August 13, 2019
    • dhsherbert
      LiamArthurs

      Get the app - its is excellent ;- 2 screens and you have control- inputs vol FX Eq - EZ 

      • January 1, 2020
  • BobKraus
    Contributor - Level 1
    2019-07-19

    I have been trying to get this to work using the instructions, but they just seem to be missing a step. I would like to use the Turbo Control App to control both of my IP1000s, but I can only seem to get one to be controlled. The Master/Slave feature doesn'r seem to work either... Any help?

    read more...
    0 178
Go to page