Statistics

216,313 members
89,523 posts
  • JudeLeBlanc
    Contributor - Level 2
    2020-07-13
    I cannot find an archived post in the old forum about this but have seen it mentioned. My IP1000 has a crazy buzz/rattle in a certain low-mid frequency. Once I dial it out it with an EQ it sounds 'empty' with no body. I'm mixing through an MR18 for an acoustic setup. I've tried numerous things to remedy with little success. It's like the sub bass cabinet vibrates at a frequency and it rattles the column at it's mechanical connection. Help, I own two and they both do it. Any suggestions appreciated. I love the units.
    read more...
    0 23
    • JudeLeBlanc
      Goetz Hi James,
      sorry to hear that! Could you please go to "Support" and create a new ticket – my colleagues will help with a solution!
      Cheers
      Goetz
      • July 13, 2020
  • etbMike
    Newcomer - Level 1
    2020-07-10
    Anyone know what the typical response time is after you create a Care Ticket? Other than the automated email resonse I got back 5 days ago I've heard nothing.
    0 58
    • etbMike
      WilliamR Hello Michael, I'm sorry, due to a server migration we are running a little behind. What is your case number?
      • July 10, 2020
      • Response time?
        etbMike I'll send him an email.
        • July 14, 2020
      • Response time?
        etbMike Thanks for your help!!!
        • July 14, 2020
      • Response time?
        etbMike Any word???
        • July 20, 2020
      • Response time?
        etbMike I wrote another email to you and Colton. Just checking.
        • July 20, 2020
    • etbMike
      etbMike William. Help again. I emailed Colton on Tuesday and I haven't heard back from him. We are obviously having email problems. Or he hates me and thinks I'm ugly. Is there a phone number I can call to get this ball rolling faster? I need that speaker for a wedding I'm doing on August 1st. Sorry to bug you with this.
      • July 16, 2020
    • etbMike
      etbMike Hello Again...Sorry for being a pain. I just really need to get a new speaker soon. I sent you and Colton another email to see if it was working yet. Please let me know. Thank you!
      • July 18, 2020
  • PatrickLenuweit
    Contributor - Level 2
    2020-07-10
    Hello, I tried to update the firmware to 2.2.2 via the Android Turbosound app. The connection between tablet and turbo sound is established (.. handshake ... erasing rom ...) but then the progress bar remains at 0% and the turbo sound is permanently in firmware mode. Unfortunately the firmware file cannot be loaded from the Turbosound homepage (error message on page, seems to be offline). CARE ticket already created, so far no feedback. Ideas why? Otherwise I send everything back to MusicStore, soon I don't feel like it anymore. Maybe someone can send me the firmware as a file and then try the Bluetooth share please. By the way: there are pixel errors in both displays, although the resolution is very low. Why that bad quality?
    read more...
    0 39
    • PatrickLenuweit
      ChrisEdwards1 Hi Patrick, hope you are well. I have just sent the firmware file across to you in your case along with some additional feedback on the display. Hope this helps.
      • July 10, 2020
    • PatrickLenuweit
      PatrickLenuweit Dear Chris, Thank you for sending the firmware file quickly, the firmware upgrade worked perfectly for both speakers without an APP via Bluetooth Share. The speakers are working properly.
      • July 10, 2020
  • TT23
    Newcomer - Level 1
    2020-07-08
    Hi all, any help greatly appreciated. My active wedges have developed a fault.......they both emit a loud squeal / hiss / crackle whenever I plug any XLR into them. Anyone come across this? As above, annoyingly I can't open a care ticket. They were bought directly from Turbosound when they were in Partridge Green, UK. https://www.fullcompass.com/common/files/17445-TXP121UserManual.pdf Adam
    read more...
    0 27
    • TT23
      Nigel67 Hi TT23, if you could put in a support ticket, put another model name in, but in the Subject and Description just highlight the actual speakers you are describing and a colleague will pick the case up and answer you.
      • July 8, 2020
    • TT23
      TT23 Thanks Nigel, as I'm then prompted to add the serial number I suspected the ticket wouldn't go thru but will try. Fingers crossed
      • July 8, 2020
      • TXP-121 Fault (Not a model option when opening a care ticket)
        Nigel67 Just put in 123456. There isn't a check on the serial number
        • July 9, 2020
  • RettichProd
    Newcomer - Level 1
    2020-07-07
    Hello, we are located in Southern Ohio. We were wondering if Turbosound has released the Manchester series yet? Also, wondering if they’ve done any events concerning the Manchester series. We held off on purchasing a different brand because of our history with Turbosound TMS-3, Flashlight/Floodlight series...
    read more...
    0 42
    • RettichProd
      billygallagher Hi RettichProd, How are you. There are some currently some in stock so I would contact you sales rep.
      • July 8, 2020
  • etbMike
    Newcomer - Level 1
    2020-07-06
    Anyone know where to buy a TS-18SW2000A6? It's the 18" speaker in a Turbosound iQ18B.
    0 59
    • etbMike
      RexBeckett I suggest that you open a Care ticket. At the top of this page, click Support -> Care -> Create a Care Ticket and select Type: Spare Parts. Make sure that you enter all required (*) data before clicking Submit.
      • July 6, 2020
    • etbMike
      etbMike I already did that. Thanks Rex!
      • July 6, 2020
  • mmccutchen
    Newcomer - Level 1
    2020-06-21
    I have two IP2000 speakers and one works fine but the other has very little volume and sound seems to break easily. Looking for advice since I have little knowledge about speakers.
    0 79
    • mmccutchen
      GaryHiggins Hi, the only advice to start anyway is duplicate every setting from the working one to the faulty one, if no improvement, you may need to put in a CARE ticket to have it repaired.
      • June 21, 2020
    • mmccutchen
      GaryHiggins The gain settings need to be equal, dsp etc. Easy to skip one by mistake.
      • June 21, 2020
    • mmccutchen
      AlexLane Try Performing a factory reset;

      Hold down the encoder Knob and Setup button while powering on the unit, follow all the on screen test instructions.
      • June 23, 2020
  • netoalas
    Contributor - Level 2
    2020-05-30

    Hi everyone, I just bought a pair of IQ15 and a IQ18B, anyone knows how can I do a Factory reset on the settings and parameters? Would it do it automatically if I just run the firmware update? Also it is the older version of both, they still have the 1.7 firmware, any problem when updating to 2.2? Greetings 

    read more...
    0 234
    • netoalas
      GaryHiggins

      @netoalas 


      Hello, they should update just fine to the latest firmware. I don't recall a factory reset option but the parameters are straightforward enough to easily set such that the DSP is bypassed and eq is flat etc etc. I also think it more or less resets when you update it.

      • May 30, 2020
    • netoalas
      AlexLane

      Hi @netoalas 


      Power up the unit whilst holding down the PROCESS button to enter the self test.


       


      Press the buttons in sequence to run through the self test. The buttons on the LCD will fill as buttons are pressed, once complete the unit will be reset to factory settings.

      • May 31, 2020
    • netoalas
      netoalas


      @AlexLane wrote:


      Hi @netoalas 


      Power up the unit whilst holding down the PROCESS button to enter the self test.


       


      Press the buttons in sequence to run through the self test. The buttons on the LCD will fill as buttons are pressed, once complete the unit will be reset to factory settings.





      Hi Alex, Thanks for your help. I tried this and it did make a sort of test but it didn't reset the settings. I just updated the firmware and gave a reset to everything by selecting the loaded parameters the speakers have. It worked like a charm, everything is sounding tight.  I am loving the crisp high and mids I am getting, and the sub is not as chest pumping as I expected but I am loving the sound and depth it produces.  


       

      • June 1, 2020
    • netoalas
      netoalas

      Hi @AlexLane @GaryHiggins, I have a different question. Would you consider the SETUP that it brings INIT_DATA the best standard setup for the speakers? What would you consider the BEST standard parameters for the IQ 15 and the IQ 18B?  


       


      greetings and thanks for your awesome help 

      • June 1, 2020
    • netoalas
      AlexLane

      Hi @netoalas 


       


      In the Xover settings menu, on the iQ15 select the iQ18B setting


       


      SImilarly, on the iQ18B, in the Xover menu, select the iQ15 setting


       


      That will match the two up perfectly, with no need for extra settings


       


       

      • June 1, 2020
  • triaudiovisual
    Contributor - Level 1
    2020-05-29

    Hello,

    I am looking for the TS-Parameters of these drivers.

    Would be really helpful.

    Thanks !

    0 128
    • triaudiovisual
      PedroRodrigues

      Thank you for your contact.


      Please follow the link below to acess the information avalable to end user:


      https://www.turbosound.com/Categories/Turbosound/Loudspeaker-Systems/Components-and-Drivers/TS-10W300-8A/p/P0E4N#googtrans(en|en)


      Thank you 

      • June 2, 2020
    • triaudiovisual
      PeterRainbow Can you help me. Thanks contatti me mail [email protected]
      • July 2, 2020
    • triaudiovisual
      PedroRodrigues Hi Peter thank you for your reply, the e-mail used to submit the assistance request was deactivated a while ago, to submit an assistance request please follow the link below: https://community.musictribe.com/pages/care-portal
      • July 2, 2020
    • triaudiovisual
      ConorNoakes From the linked product page:
      "The die-cast aluminium frame is extremely rigid and light in weight, making it ideal for use as a replacement driver – or for deployment in custom-engineered multi-way PA enclosures"

      How is one expected to custom engineer an enclosure without the TS parameters of the driver?
      • July 21, 2020
    • triaudiovisual
      PedroRodrigues Hi Peter thank you for your reply, the e-mail used to submit the assistance request was deactivated a while ago, to submit an assistance request please follow the link below: https://community.musictribe.com/pages/care-portal
      • August 10, 2020
      • Turbosound TS-10W300/8A
        ConorNoakes Are you a bot or something?
        • 1
        • ·
        • August 10, 2020
      • Turbosound TS-10W300/8A
        PedroRodrigues Hi Conor no Bot here just trying to help you by stating how you should proceed so we can help you resolve this matter.
        • August 10, 2020
  • kendrum1
    Contributor - Level 1
    2020-04-26

    Hey all!

    Currently own 2 ip1000 v1s and love them! The only issue I keep running into is drunken college kids thinking they're sturdy enough to hold onto. It's only happened a couple of times, but that sickening crash of one of these things hitting the floor is enough to cause a panic attack. Thankfully, they are built like a tank and I haven't had any sound problems, but I know that can only last a few more tumbles.

    Has anyone built or 3D printed some sort of stand/bracket/legs for the sub unit to help prevent this from happening? All suggestions welcome!

    read more...
    0 75
    • kendrum1
      AlexLane

      Hi @kendrum1 



      I believe I have seen some solutions from users on the facebook forums, I would suggest joining the "Turbosound INSPIRE users" group on facebook and posting this there.


       


       

      • April 26, 2020
Go to page