Statistics

187,705 members
57,652 posts
  • 2020-10-19

    Anybody have issues with the system not turning on after use meaning the sytem works fine then I turned off and try to turned back on and it won't turn on for several hours then it will work fine

    0 5
    • Jose Garcia
      Chris Edwards Hi Jose, I hope you are well. If you have not already done so I would suggest that you open a Care ticket for this. At the top of this page, click Support and scroll down to Service. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • Oct 19
  • 2020-10-15

    I have an ip1000 pa system . The sub woofer is not reproducing any lows. I checked the sub speakers - OK..

    The mid/hi pack is ok .. It is definatley the sub. If you can send me the circuit board , I can replace it here.

    0 4
    • Howard Mock
      Nigel Turner Hi Howard. We can definitely help you with the repair, but we need you to submit a service request ticket. One of my colleagues will then be able to advise you how we go about repairing your unit. If you can go to the Support tab at the top of the page and submit a service request ticket. Many thanks
      • Oct 15
  • 2020-10-04

    Is it possible to purchase a new V2  processor/ bluetooth interface to install in older V1, We have a new V2 on order and what to use them as a pair. We have lost the app connectivity and have no way to update firmware, thouht this might  be our only fix.

    Cheers regards brad

    read more...
    0 12
    • Brad Auld
      David Knighton Hello Brad Auld,
      The components between the two versions are not cross compatible. This would technically void your warranty as well, because it's not a modification we offer.
      • Oct 7
    • Brad Auld
      Brad Auld Thanks David so under warranty how do I get the ip2000 v1 to work properly as it no longer connects to control app and needs firmware upgrade . Your help in this would be appreciated.
      • Oct 7
      • Ip2000v1 to v2 retroetrofit upgrade (turbosound)
        David Knighton Hi Brad,
        The V1 systems don't support firmware upgrades at all. Only the V2 systems support firmware upgrades. Can you tell me whether you're using Android or Apple device? First thing you need to do is establish whether the speaker connects via Bluetooth. The app 'should' connect as long as the bluetooth function is working. You may want to try a different device, maybe from a friend or colleague just for the sake of testing.
        • Oct 8
  • 2020-09-23

    I just received my ip2000. And at least one of the drivers in the bottom half of the column array is rattling. When I swapped it out with my old ip2000 lower column it dived the problem. So I need another bottom column for the new ip2000 that I bought from Musistribe. 
    also my older V1 ip2000 has developed a rattle in the top column . I'd rather not return the whole unit . I'd like to return the defective column instead of the entire unit.

    and I'd like to also get a top column that doesn't have a diver that rattles 

    read more...
    0 11
    • Kurt Wheeler
      John Matthews Hi Kurt, please submit a service request via the support button at the top of the page. The team can then advise of the options available depending on the warranty status. Thanks
      • Sep 22
  • 2020-07-21

    Hi, how is power RMS and MAX active subbas Vq1800d?

    0 19
  • 2020-07-17
    Hello all... I own 2 x ip2000 and 1 ip300. I am looking for specific details of the DSP settings that are provided. What exactly is happening between the various options? (IE: Wall position versus Floor... Live Music versus Speech) What electronic changes are taking place? Does anyone have access to any graphs or written information? best!
    read more...
    0 13
  • 2020-06-21
    I have two IP2000 speakers and one works fine but the other has very little volume and sound seems to break easily. Looking for advice since I have little knowledge about speakers.
    0 51
    • Mike McCutchen
      Gary Higgins Hi, the only advice to start anyway is duplicate every setting from the working one to the faulty one, if no improvement, you may need to put in a CARE ticket to have it repaired.
      • Jun 21
    • Mike McCutchen
      Gary Higgins The gain settings need to be equal, dsp etc. Easy to skip one by mistake.
      • Jun 21
    • Mike McCutchen
      Alexander Lane Try Performing a factory reset;

      Hold down the encoder Knob and Setup button while powering on the unit, follow all the on screen test instructions.
      • Jun 23