Statistics

181,559 members
50,500 posts
  • 2020-09-24

    Ip2000 V1 abd v2 will not link. Can this be remedied? 

    0 0
  • 2020-09-22

    I just purchased the Milan15 Tops and subs. The dealer (Sweetwater) had covers for the tops, but not the subs. 

     

    Does anyone know IF there are covers for the subs? If so, how do I find them. There is no mention of accessories on the Turbosound site.

     

    Blessings.

    read more...
    0 5
  • 2020-09-10

    Hallo 

    ich wollte mal fragen warum die passiv Variante gleich 3dB leiser ist als die aktiv Variante?

    liebe Grüße Aaron John

    0 7
    • Aaron  John
      Alexander Lane Hi, just letting you know I removed the duplicate threads for this question.

      The difference will be due to the different DSP's used for driving the two speakers. -AN version has an active amp module with in built DSP and the Passive will be driven by Lab.gruppen PLM series and LAKE presets. Both would have been power tested to figure out the spec and difference would be expected.

      Bear in mind too the -AN version would have slightly different cabinet volume due to the amp module being placed in the rear panel so this may also contribute to slight changes.
      • Sep 10
      • NuQ115B unterschied zu NuQ115B-AN
        Aaron John Merkt man denn bei den beiden einen großen Unterschied Von Lautstärke und Qualtität wenn man 4 Passive mit einer Powersoft k3 oder vergleichbarer Endstufe ansteuert? Oder sogar ein Eisenschwein
        • Sep 10
      • NuQ115B unterschied zu NuQ115B-AN
        Alexander Lane You can drive four NuQ115B per channel from an amplifier with no issues, as long as it is within the power specification of that channel that is.

        It's always best to allow for headroom. NuQ115B is 500W RMS at 8 Ohms, so four is 2000W RMS at 2 Ohms. To drive four from a channel you will need to make sure it can deliver 3000 to 4000 Watts RMS to allow for headroom. Then use a limiter to ensure you don't over drive the speakers.

        It's recommended to use Lab.gruppen PLM series amplifiers and the LAKE presets to ensure you have correct DSP settings in place. PLM12K44 or PLM20K44 would be a good choice for this.
        • Sep 11
    • Aaron  John
      Aaron John Und sind die Kisten gut Für Techno geeignet?
      • Sep 10
  • 2020-08-12

    Does anyone know if the monitor out sockets are balanced? I wanted to run some 30m-40m cables to the audio in of a Camcorder and was concerned about noise.

    0 15
    • Paul Humphreys
      Kyle Johnson Hi Tricamel, My name is Kyle with Music Tribe technical support. To answer your question, the outputs are unbalanced TS jacks. You can also find this information in the quick start guide which is at: https://www.behringer.com/product.html?modelCode=P0AA8
      • Aug 12
      • EPS500MP3 Monitor Out
        Paul Humphreys Many thanks, I saw the section entitled output but wasn't sure it referred to the monitor out jacks. Think I'll put a DI in the way in that case.
        • Aug 12
  • 2020-07-28

    How do I register products like my new pair of Beringer speakers?

    0 67
    • Jay Buzy
      Kyle Johnson Hi there, to register a product you can click the Support button at the top of this page, and then select Create a ticket and select Product Registration from the drop down menu.
      • Jul 28
  • 2020-07-23

    Just purchased and can't find where to plug headphones jack,is this possible?

    I don't want to make enemies with my neighbours with the noise.

    cheers

    0 6
    • Greg Deeble
      Chris Edwards Hi Gorminator, I hope you are well. It is not possible to use headphones with the ACX 900, none of the ACX models come with a headphone output.
      If you wish to use headphones with the ACX900 and ACX1800 you could do this by utilizing the balanced line outputs on the back into a mixer or audio interface, however, this does not bypass the speaker.
      • Jul 23
    • Greg Deeble
      Greg Deeble Thanks Chris,I suspected not.....
      • Jul 23
  • 2020-07-13
    I cannot find an archived post in the old forum about this but have seen it mentioned. My IP1000 has a crazy buzz/rattle in a certain low-mid frequency. Once I dial it out it with an EQ it sounds 'empty' with no body. I'm mixing through an MR18 for an acoustic setup. I've tried numerous things to remedy with little success. It's like the sub bass cabinet vibrates at a frequency and it rattles the column at it's mechanical connection. Help, I own two and they both do it. Any suggestions appreciated. I love the units.
    read more...
    0 4
    • James Leblanc
      Goetz Mueller-Duerholt Hi James,
      sorry to hear that! Could you please go to "Support" and create a new ticket – my colleagues will help with a solution!
      Cheers
      Goetz
      • Jul 13
  • 2020-07-10
    Anyone know what the typical response time is after you create a Care Ticket? Other than the automated email resonse I got back 5 days ago I've heard nothing.
    0 41
    • Michael Wise
      William Reichling Hello Michael, I'm sorry, due to a server migration we are running a little behind. What is your case number?
      • Jul 10
      • Response time?
        Michael Wise I'll send him an email.
        • Jul 14
      • Response time?
        Michael Wise Thanks for your help!!!
        • Jul 14
      • Response time?
        Michael Wise Any word???
        • Jul 20
      • Response time?
        Michael Wise I wrote another email to you and Colton. Just checking.
        • Jul 20
    • Michael Wise
      Michael Wise William. Help again. I emailed Colton on Tuesday and I haven't heard back from him. We are obviously having email problems. Or he hates me and thinks I'm ugly. Is there a phone number I can call to get this ball rolling faster? I need that speaker for a wedding I'm doing on August 1st. Sorry to bug you with this.
      • Jul 16
    • Michael Wise
      Michael Wise Hello Again...Sorry for being a pain. I just really need to get a new speaker soon. I sent you and Colton another email to see if it was working yet. Please let me know. Thank you!
      • Jul 18
  • 2020-07-10
    Hello, I tried to update the firmware to 2.2.2 via the Android Turbosound app. The connection between tablet and turbo sound is established (.. handshake ... erasing rom ...) but then the progress bar remains at 0% and the turbo sound is permanently in firmware mode. Unfortunately the firmware file cannot be loaded from the Turbosound homepage (error message on page, seems to be offline). CARE ticket already created, so far no feedback. Ideas why? Otherwise I send everything back to MusicStore, soon I don't feel like it anymore. Maybe someone can send me the firmware as a file and then try the Bluetooth share please. By the way: there are pixel errors in both displays, although the resolution is very low. Why that bad quality?
    read more...
    0 17
    • PatrickLenuweit
      Chris Edwards Hi Patrick, hope you are well. I have just sent the firmware file across to you in your case along with some additional feedback on the display. Hope this helps.
      • Jul 10
    • PatrickLenuweit
      PatrickLenuweit Dear Chris, Thank you for sending the firmware file quickly, the firmware upgrade worked perfectly for both speakers without an APP via Bluetooth Share. The speakers are working properly.
      • Jul 10
  • 2020-07-08
    Hi, I create a ticket for service request days ago, and I haven´t received the answer. Could you help me? Erick B.
    0 15
    • ERICK BOCKELMANN
      Leah D Hey Erick! I've looked into your case. Please expect a response from us shortly. Thanks!
      • Jul 8
Go to page