• 2020-07-13
    I cannot find an archived post in the old forum about this but have seen it mentioned. My IP1000 has a crazy buzz/rattle in a certain low-mid frequency. Once I dial it out it with an EQ it sounds 'empty' with no body. I'm mixing through an MR18 for an acoustic setup. I've tried numerous things to remedy with little success. It's like the sub bass cabinet vibrates at a frequency and it rattles the column at it's mechanical connection. Help, I own two and they both do it. Any suggestions appreciated. I love the units.
    read more
    0 2
    • James Leblanc
      Goetz Hi James,
      sorry to hear that! Could you please go to "Support" and create a new ticket – my colleagues will help with a solution!
      Cheers
      Goetz
      • Jul 13
  • 2020-07-10
    Anyone know what the typical response time is after you create a Care Ticket? Other than the automated email resonse I got back 5 days ago I've heard nothing.
    0 33
    • Michael Wise
      William Reichling Hello Michael, I'm sorry, due to a server migration we are running a little behind. What is your case number?
      • Jul 10
      • Response time?
        Michael Wise I'll send him an email.
        • Jul 14
      • Response time?
        Michael Wise Thanks for your help!!!
        • Jul 14
      • Response time?
        Michael Wise Any word???
        • Jul 20
      • Response time?
        Michael Wise I wrote another email to you and Colton. Just checking.
        • Jul 20
    • Michael Wise
      Michael Wise William. Help again. I emailed Colton on Tuesday and I haven't heard back from him. We are obviously having email problems. Or he hates me and thinks I'm ugly. Is there a phone number I can call to get this ball rolling faster? I need that speaker for a wedding I'm doing on August 1st. Sorry to bug you with this.
      • Jul 16
    • Michael Wise
      Michael Wise Hello Again...Sorry for being a pain. I just really need to get a new speaker soon. I sent you and Colton another email to see if it was working yet. Please let me know. Thank you!
      • Jul 18
  • 2020-07-10
    Hello, I tried to update the firmware to 2.2.2 via the Android Turbosound app. The connection between tablet and turbo sound is established (.. handshake ... erasing rom ...) but then the progress bar remains at 0% and the turbo sound is permanently in firmware mode. Unfortunately the firmware file cannot be loaded from the Turbosound homepage (error message on page, seems to be offline). CARE ticket already created, so far no feedback. Ideas why? Otherwise I send everything back to MusicStore, soon I don't feel like it anymore. Maybe someone can send me the firmware as a file and then try the Bluetooth share please. By the way: there are pixel errors in both displays, although the resolution is very low. Why that bad quality?
    read more
    0 12
    • Patrick Lenuweit
      Chris Edwards Hi Patrick, hope you are well. I have just sent the firmware file across to you in your case along with some additional feedback on the display. Hope this helps.
      • Jul 10
    • Patrick Lenuweit
      Patrick Lenuweit Dear Chris, Thank you for sending the firmware file quickly, the firmware upgrade worked perfectly for both speakers without an APP via Bluetooth Share. The speakers are working properly.
      • Jul 10