Statistics

251,060 members
128,290 posts
  • New
    RLND
    Newcomer - Level 1
    2021-05-02

    Hi there,

     

    I have owned a Venice 32F for over six years and have it running on a Windows 7 (32 bit) system with a Sinux FWB3414G firewire PCI-e card. It has been working like a charm since day one.

    I have now put together a new PC because the old one is on its way out. It has a Windows 10 Pro (64 bit) system and I got a new fire wire PCI-e card by Star-Tech (2 Port PCI Express FireWire Card - PCIe 1394a FireWire Adapter).

    I installed the drivers, the card is being recognised by Windows but when I fire up my Venice it is not recognised (I have installed the drivers for the Midas console).

    I then tried my old firfewire PCI-e card (Sinux) and it does recognise the console but when I started REAPER the first time and set the sound device to the Midas console Windows popped up a blue window with an error code and restarted Windows.

    I tried it a few more times also with another audio program and the PC would just restart.

     

    1. Does anyone know what could be the issue? (Start Tech had drivers to install, Sinux had no drivers to install).

    2. Can anyone recommend a firewire card they know is working with Windows 10 (ideally available in Australia)

     

     

    Cheers, RLND

    read more...
    0 61
    • RLND
      Nigel67 Hi RLND, I think your problem is more to do with the driver. Unfortunately Midas support for the Venice F ceased a number of years ago now and there was never a driver released for Windows 10. There are many posts on forums asking if anyone has made the Windows 7 driver work successfully with Windows 10. The only time that I have seen a person answer with a successful outcome was this one, however I have never had anyone else verify it. The post went as follows; 'Downloaded the Win 7 driver. Then right click the .exe file and switch compatibility to Win 7 so now the driver runs in Win 10, thinking its Win 7'. I hope this works for you. If not, then I can only suggest that you search on the internet to see if you can find someone else who has managed to get the driver working. Many thanks
      • May 2
    • RLND
      RLND Thanks a lot Nigel,
      • May 4
    • RLND
      RLND ... I tried your tip with the Star-Tech card and it recognises now the console, however, when I start Reaper and switch to ASIO Midas the same scenario happens - blue screen and PC restarts. Meanwhile I read on another forum that there is a difference with different chip sets on firewire cards re Win 10 - some work with Win 10 and some don't. I'll do some further research. Cheers, Roland
      • May 4
  • New
    robsimons78
    Newcomer - Level 1
    2021-04-28

    Hi, I've sent in a parts request for a new FireWire board for my Venice F16 mixer. Can some please come back to me? Would really appreciate getting this mixer working again

    CAS-446634-M4P1Z2 

    Many thanks

    0 72
    • robsimons78
      Dale_M I have asked the Spares Team to assist.
      • Apr 28
      • FireWire board F16
        robsimons78 Thank you. I have been contacted now. I guess before I order a new firewire card, I want to be sure it's not working 100%. I've tried on OSC High Sierra and Catalina, newest drivers, and terminal hack OK. Drivers appear fine, the FireWire lights are green, but no devices found. Do the FireWire lights need to be RED to indicate that it's faulty??
        • Apr 28
      • FireWire board F16
        DavidKnighton Hello robsimons78,
        From my experience, the LED does not change color. It is constantly illuminated during power on. The only true way to know if the firewire chip is gone is by interfacing with a firewire enabled computer running Windows 7 or Mac OS El Capitan or earlier. These are the latest known working and supported operating systems. Any other operating system is not officially supported or tested.
        • 1
        • ·
        • Apr 28
      • FireWire board F16
        robsimons78 Thanks, that's helpful. I have one more machine with a legacy OSX that I'll try. If that doesn't work then I suppose I have my answer Also, I know it's been pitched a few times before, but an updated Thunderbolt card for these mixers would be a godsend, thousands of Venice owners would jump all over it.
        • Apr 29
  • New
    N1Ckp
    Newcomer - Level 1
    2021-04-06

    Hello. I recently purchased at Midas Vidas 320 desk and I love it. However, to improve longevity of this beauty I would like an EPS 1200 but cannot find one online. Seeking any help here if possible. Does Midas have any back stock of discontinued products they would sell ?

    Thanks,

    Nick 

    read more...
    0 80
    • N1Ckp
      Nigel67 Hi N1Ckp. Please contact our spares team and they will be able to advise on the stock availability of a psu. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. The only other option would be to post on some of the Midas FB forums and see if anyone has a second hand one. Try 'Long Live Midas Analogue Consoles'. Hope this helps.
      • Apr 5
  • New
    Beppone
    Newcomer - Level 1
    2021-03-18

    Hi everyone, I'm using a Midas f32 mixer and I'm trying to record on a Macbook pro with M1 chip. I already tried to download midas drivers but no one works for my macbook. My macbook does not receive any information from the mixer, I think midas hasn't released current drivers yet, so If you have some solutions I would be grateful, if you haven't, I urge Midas to release new drivers!

    Thank you 

    read more...
    0 85
    • Beppone
      Nigel67 Hi Beppone, I am sorry, but Midas ceased any support for the Venice F drivers a number of years ago now. There will not be any new drivers released for the Macbook Big Sur with the M1 chip.
      • Mar 18
  • New
    PhilJutras
    Newcomer - Level 1
    2021-03-18

    Hey there everyone, I'm new to the forum, I have that MIDAS H-3000 which is sadly stuck in the LOCK mode.

    As soon as I press on the system button, the segment display tells me I'm in LOCK mode.
    The UP and DOWN button doesn't do anything, the confirm button either. If I press CANCEL, the LOCK disappear.

    I'll mention that the LOCK LED is lit but it's really dimmed.

    I measure the Power on the output of the 12V REG1, I have 12V.

    Something weird is that I have 11.2V on the XL Auto Central Control Panel board.

    Anyone ever experienced this problem? Would it be more related to power or maybe a logical gate?

    Thanks!

    read more...
    0 78
    • PhilJutras
      DavidKnighton Hello Phil,
      If anyone knows anything it would be Jim Sawyer at Sawyer Audio. He is quite the authority on legacy Midas consoles and may be able to help fix whatever issues you're having.
      • Mar 18
      • H3000 Issue, stuck in LOCK
        PhilJutras Thank your for the hint!
        • Mar 18
  • New
    Musiccc3000
    Newcomer - Level 1
    2021-02-09

    Im at the point of buying a Midas  Venice 16U; 

     

    The seller used it as an backup and said it turned off, then on then off (while being connected to a generator);

    I might be a easy fix or the unit might be bricked; the seller doesnt really care to invest a repair.

     

    Are parts still available and what could be a possible fix (theres no voltage on the internal PSU according to the seller)

    read more...
    0 78
  • New
    RenzoNerucci
    Newcomer - Level 1
    2021-01-28

    Good morning,

    I bought a Midas VF24 and I have this problem..

    I switch on the mixer and It Will go on whenever It wants, but when it's on is ok. The problem it's Just on the start.

    Some ideas?

    0 42
    • RenzoNerucci
      DavidKnighton Hello Renzo,
      Is the environment colder than average? Sometimes this can happen if the ambient temperature is extremely low. Otherwise, I would lean towards a replacement PSU. You might want to check the PSU connectors and cabling are all seated properly, as a bad fit could also cause problems,.
      • Jan 28
  • New
    TurdFerguson19
    Newcomer - Level 1
    2021-01-24

    Hi everyone, I'm new to the forum but not to Midas, I have recently purchased a pristine Venice F32. The only issue is my channel #4 fader is missing ? at least the knob plus the slider, the body is still on the circuit board. Can someone point me in the right direction for a replacement fader plus the knob? 

    read more...
    0 111
    • TurdFerguson19
      Nigel67 Hi, please click on the support tab at the top of the page. In the new page that opens, scroll down, click on the spare parts tab and submit a ticket. One of my colleagues will then get back to you with pricing and availability. many thanks
      • Jan 24
  • New
    Miklos
    Newcomer - Level 1
    2021-01-12

    Hi there, 

    I wrote to your service team and they suggested I should write to you intead. My Midas XL4 

    has a broken IC circuit in the motherboard, i need either a new motherboard or just another IC cucuit. 

    I Have attached a picture in hope that someone in your network can help with this as without this the console 

    will be completely worthless, and that would be really bad. 

     

    Thanks in advance 

    read more...
    0 123
    • Miklos
      Nigel67 Hi Miklos, I am going to set up a case for this. I will e-mail you in the next few hours and we can go from there.
      • Jan 12
  • New
    Geoffwalker55
    Newcomer - Level 1
    2021-01-08

    Hi I have a midas f32 operating on windows7 using protools12 and a uad thunderbolt device somehow my pc aint seeing the mixer if i click on the midas icon i can see it anyone know how i a get rouind this issue please i would normaly take my rig to Parr Street Studios in Liverpool but thanks to covid this is not possible any help would be gratefullt welcomed

    Thank you

    Geoff

    read more...
    0 58
    • Geoffwalker55
      john0121 Hi Geoff, is this the firewire version or the USB version? Either way it would be best to fill out the tech support form via the Support button (top of page). A member of the team can then work through some troubleshooting with you. Thanks
      • Jan 10
Go to page