Statistics

267,754 members
147,251 posts
  • klapklapklap
    Contributor - Level 1
    2019-12-16

    Hello,
    I need one information about Alter Ego X4 and I don't know where to ask, so. ❤
    Is Behringer FCV100 compatible expression pedal with Alter Ego X4.

    Thank You ?
    Martin

    read more...
    0 95
    • klapklapklap
      TC-Samuel

      Hi Martin
      Glad you found us
      The Behringer FCV100 is a volume pedal as far as I can tell. You need a dedicated expression pedal as they will have different potentiometer values or a combined option. I haven't tried Behringers FC600. That might work, but if you have the option where you live, you can go down to a store and hook up your X4 to any expression pedal you like and open up the toneprint editor. There you'll see a graph showing the exact range of the potentiometer specific expression pedal you're looking at. They can be quite different. I now it's a bit geeky, but we can't help it


      Hope you find something and have tons of fun with it.

      Cheers
      Sam

      • December 17, 2019
  • bpmben
    Contributor - Level 1
    2019-12-16

    Just got a BC208 and it buzzes on the top speaker. My Music tribe case number is 01040995. Help please!

    0 77
    • bpmben
      TC-Samuel

      Hi bpmben
      If you have an open support ticket, I promise you the great guys in support will get back to you as soon as they can
      Cheers,
      Samuel

      • December 17, 2019
  • bpmben
    Contributor - Level 1
    2019-12-16

    Just got a BC208 and it buzzes on the top speaker. My Music tribe case number is 01040995. Help please! 36B171DD-1A9C-45FB-B3C3-E492057A40F2.jpeg

     

    read more...
    0 93
    • bpmben
      TC-James

      Hi Ben! Let's continue our discussion over on Twitter. We'll get you sorted.


      Cheers,


      James

      • December 17, 2019
  • Eb1
    Contributor - Level 1
    2019-12-14

    I am returning 4 TC Pedals I bought just two weeks ago from the GC promotion. The Nether, Surfer, HoneyPot Fuzz, and the Swell Pedal.  All of these pedals were pretty much abismal in sound quality, and sounded different each time I would use them. 
    I understan they are a consumer line of stomp boxes, but I believer I can get better results by buying the components to build these myself. Sorry, TC, but IMO you failed on this line of products.

    read more...
    0 111
    • Eb1
      TC-Samuel

      Hi @Eb1 
      I'm very sorry to hear that. If you think they sound awful that is totally legit, but I assure you they should sound the same everytime you use them! I hope you find some pedals that better suit your taste
      Cheers,
      Samuel

      • December 15, 2019
  • rjferretti
    Contributor - Level 1
    2019-12-13

    Just got the HOF 2 and Flashback 2 today. Right away I noticed the selector knob on the HOF is very firm and exact when turning but the selector knob on the Flashback feels mushy and has a lot of play in between options. Is this normal or should I return it and get another one?

    Thanks

    read more...
    0 117
    • rjferretti
      TC-Rasmus

      Hi Rjferetti
      The two knobs should feel almost exactly the same, with "a little play" in between options, and a quick snap when you select a mode. It might be that the HOF2 just needs some turning, or you may try to pull off the knob and reinsert it. If this doesn't work, and you still think it is an issue, then report back to us here 

      Hope this helps

      • December 15, 2019
  • stevetrembley
    Contributor - Level 2
    2019-12-09

    You open a ticket. You get one response. You reply. You get "we haven't heard from you". Has happened twice now. Where the hell are you Jason Brewer? You need to be fired. This is utter nonsense. Absolutely useless support system. I've never seen such ridiculous lack of support ever. It's like the entire support system is run by idiots.

     

    read more...
    1 227
    • stevetrembley
      TC-Kristian

      Hey @stevetrembley 


      Sorry to hear about your experience.
      Can i ask you for your care ticket number? I'll pass it on to a support colleague.


      In the meantime, here are some tips you can try if you haven't already.


      1) Have you tried to do a memory reset (press and hold Loop 1 switch for 13 seconds until LED blinks orange)?
      2) Which version number are you running? The advice above won't work if by any chance you still have the original build 35 firmware. ---< Connect your X4 via USB to computer and take a look at the Ditto partition for "about.txt" file which contains firmware number.
      3) Have you tried updating to latest build 91 beta? if not I'll send you a download link.


      After that, connect your pedal to your computer via USB, but don’t connect the power supply.


      Hold down the far left footswitch while inserting the power supply. KEEP THE SWITCH PRESSED DOWN UNTIL ALL LIGHTS TURN SOLID GREEN.


      Open the firmware update application and in the drop-down menu select DITTO BOOT.


      Click the UPDATE button.


      Once the update has reached 100% and the LEDs have changed you can disconnect your pedal.


      4) If your unit cannot be set to boot mode it means the memory card is shot and needs to be serviced --> If thats the case, it seems you have a unit from the first batch and needs to be exchanged - your exchange unit will come with a new updated memory card.


      - Kristian

      • December 10, 2019
    • stevetrembley
      stevetrembley

      Here's the deal. I've udated the firmware and it seems to operate with fewer glitches, but why did I recieve a "new" unit last month with firmware from 2017? If I did receive an old stock unit with older, now updated components, I need to know this before it's too late to return. It's a simple question and Jason can't seem to answer this question. Weeks have gone by with 2 sporadic replies that don't come close to a relevant, "hey I read your email" response. Very frustrating. 


      1. Serial number 14307305. Someone please tell me the date of manufacture on this unit.


      2. Someone please tell me if this unit is older stock, now updated with a more current, trouble free design or components/memory card.


      3. Do all the new units still come with the two year old Version:1.0.00 BUILD 35 firmware?


      I've only got another couple weeks to determine this so I can get a refund and then a more current X4.

      • December 11, 2019
    • stevetrembley
      stevetrembley

      My original ignored case number was Case: 01031637. Since I received no replies, I opened another ticket Case: 01036840

      • December 11, 2019
    • stevetrembley
      stevetrembley

      And because their email support system is absolutely USELESS, they have closed my most recent case number. I swear, this is the worst customer service ever.


       

      • December 12, 2019
    • stevetrembley
      TC-Kristian

      Dear @stevetrembley 


      I am deeply sorry to hear about your issues - this shouldn't happen.


      I have contacted the head of the support department and they will resolve this promptly.


      Sincerely, Kristian


       


       


       

      • December 12, 2019
  • TopherConner
    Contributor - Level 1
    2019-12-04

    I just got the Hall of Fame 2 in the mail. I plugged it in, the red light comes on but no sound comes through. I turn the pedal off, I can hear my guitar. Turn the pedal back on, the light shows the pedal in on, but I have no sound. Any ideas??

    read more...
    0 157
    • TopherConner
      macfilipe

      Which setting do you have it on? IIRC, toneprint slot 3 comes preloaded with a toneprint that cuts off your sound until you use the MASH switch. Is it also cutting off on the named presets, such as the Hall / Plate / etc?

      • December 4, 2019
    • TopherConner
      TC-Samuel

      Hi TopherConner,


      Have you gotten it to work?


      Can you check which preset you are on?


      As Macfilipe said TP slot 3 turns the pedal into a faux volume pedal. So you can only hear your guitar when the MASH switch is engaged.

      • December 5, 2019
  • sj1
    Contributor - Level 1
    2019-12-03


    Hi All,

    Using my Ditto X4, in Serial Mode, locked to incoming MIDI clock, suppose I have two loops recorded, one of which is currently playing back.

    Is it possible to arrange to seamlessly replace one of the loops with a brand new recording while the other continues to play?

    I have tried alot of different tap dances and have not been able to make it happen, and I am beginning to think it is not possible.

    Can the community advise me here? Thanks!

    read more...
    0 120
  • DCM8004
    Contributor - Level 1
    2019-12-02

    Good evening, 

    I was wondering if anyone would be able to help me find the Value and Type of potentimeter that is used for the control knob on the Hall Of Fame Mini reverb pedal, i am looking to incorporate it into another piece and would like to replace the potentiometer with one that is located remotely if possible.

     

    read more...
    0 92
  • Disappointed777
    Contributor - Level 1
    2019-12-02

    My daughter bought my a tc electronic clip-on guitar  for my birthday 2 months and it suddenly stopped working.   I'd like to talk to someone at this company about this, but instead I've  been stuck here in cyberspace on music tribe getting no help at all.

    If I dont get a response and some assistance soon I am going swear off of a TC products for good and share my rotten TC electronics experience with everyone I know..

    If you guys dont stand  behind your products then you are not the company I thought you were for all of these years.

     

    read more...
    0 337
    • Disappointed777
      KenMitchell

      Hi John ( @Disappointed777 ), 


       


      Welcome to the community.  That's a tough way to start off if you're asking for our help.  We are a user community not an MT company so we can only do so much.  Threatening to trash a company is also not a good way to get help. 


       


      In your post you say she bought you a "clip-on guitar" but a "clip-on guitar what?".  Do you know where she bought it?   


       


      Have you opened a support ticket here: https://www.tcelectronic.com/brand/tcelectronic/support#googtrans(en|en)


       


      Ken


       

      • December 2, 2019
    • Disappointed777
      TC-Lars

      Hi Disappointed777
      Sorry to hear about your bad experience. 
      I expect that you're talking about a clip-on tuner. Correct?

      Just to get it out of the way: Have you exchanged the battery (sorry for asking, but this product needs a fresh battery to work the best). 
      If you have, then as Ken says, you'll have to create a "ticket" with support, so you can get your product fixed/exchanged. 

      All the best,
      Lars

      • December 2, 2019
Go to page