Statistics

223,657 members
97,874 posts
  • New
    zander1973
    Newcomer - Level 1
    2021-04-12

    I need to replace the removable "chip" inside the Nova System, where can I obtain a new chip. The one in the unit must have burned out, as is it has a mark on it and was hot to the touch. The unit is stuck and wont function. The "factory default" light is permenatly on and when I try any of the reset techniques nothing works. 

     

    Thank you

    read more...
    0 4
    • zander1973
      Nigel67 Hi zander1973. Please contact our Spares Team and they should be able to help you. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. A colleague will then get back to you with availability and pricing.
      • Apr 11
  • New
    EdPolo
    Newcomer - Level 1
    2021-04-11

    Hi,

     

    I'm looking to get BG250-208 combo and RS112 cabinet to compliment my amp. However, they are not in stock at any retailer on Canada. Same thing with major USA web stores. However, none of them can confirm their ETA. TCE logistic people, do you have better idea when these are going to be shipped to North America? 

     

    Thanks,

    Ed

    read more...
    0 2
  • New
    JuezDredd
    Newcomer - Level 1
    2021-04-11

    Hi. I am looking for a FSB104 pedal for a Bugera 333 Infinium.

    I can't find it anywhere. I am from Spain. Could someone tell me where to get it?

    read more...
    0 2
  • New
    JoeRojas
    Newcomer - Level 2
    2021-04-10

    I don't know if it's me or is this actually happening. I've noticed that few suppliers carrying Bugera products are phasing them out. I live here in the USA, I finally got my stimulus check and was interested in getting the 212TS cabinet. Right now, I only can them on the used market but like they're like becoming rare. Sites like Sweetwater don't even have them anymore. I would like to compliment my G5 head with it, but can't find even a new one in stock. Can anyone at Bugera let me know what is the status and if Bugera instill going to be around? Thanks. 

    read more...
    0 1
    • JoeRojas
      Dale_M Hi No Bugera is not phasing out there is currently a lot restructuring in the world of sales added to Covid 19 which halted a lot of production of certain lines so this is most likely what is causing the delay.
      • 12 hours ago
  • New
    michaeldurig
    Newcomer - Level 1
    2021-04-09

    Greetings,

    I am attempting to utilize the gear I own for a solo project.  I have a Ditto Looper, an IPad (8th gen) 128GB <100GB available, and a Beat Buddy.  My intention is to use the ditto looper to record tracks with the Beat Buddy and save them to my IPad to be played in a live setting.  Currently, my IPad isn't operating correctly.  I will not overdue on either channel.  I have tried to up date the firmware and after following the instructions mulitple time, the ditto looper doesn't respond as advertised.  Holding the leftmost button while powering up doesn't get light the first light, it lights them all.  

    Apparently something with the software has gone awry.  Please advise as to a possible solution if familiar with this problem.  Thank you.

    read more...
    0 3
  • New
    jlittle3917
    Newcomer - Level 1
    2021-04-08

    hey guys,

    I just got my polytune 3 today. worked great and loved it. updated firmware to 1.4 and now it does not recognize my 5 string bass. It tunes great for individual strings but only shows 4 strings when I strum. 

    Thanks a ton,

    Josh

    read more...
    0 4
    • jlittle3917
      PedroRodrigues Hi jlittle, please consider that if you press the display mode button on the rear of POLYTUNE 3 once, the currently selected display mode will be shown. Pressing the display mode button repeatedly will cycle through these modes:

      -Guitar / Needle mode (indicated by a “G” and the centre LED column lighting up).
      -Guitar / Strobe mode (indicated by a “G” and the middle row of LEDs lighting up).
      -Bass / Needle mode (indicated by a “B” and the centre LED column lighting up).
      -Bass / Strobe mode (indicated by a “B” and the middle row of LEDs lighting up).

      In Needle mode, when you tune a single string, pitch is indicated by a column of five LEDs in the upper part of the display, and the name of the target note is displayed at the bottom of the display.
      If the string you are tuning is too low, LEDs to the left of the centre column will light up. If the string is too high, LEDs to the right of the centre column will light up. Tune the string until the middle column and the middle row of green LEDs lights up. This means you are “on target”.

      In Strobe mode, the difference between the correct (target) frequency and the actual detected frequency is displayed by two indicators simultaneously:

      1. Red LEDs to the left (pitch too low) or to the right (pitch to high) of the centre LED column
      2. Rotating segments in the display. The closer the detected frequency is to the target frequency, the slower the rotation.

      Tune the string until the rotating pattern has come to a stop and only the middle column of green LED lights up.

      As you know, POLYTUNE 3 is a polyphonic tuner, you can strum your instrument, and POLYTUNE 3 will analyse and display the tuning of all strings.
      So, you don’t need to activate the polyphonic tuning mode, it just works. Please Strum and tune. (PLEASE SEE THE IMAGE BELOW)

      Please consider that only the strings that are actually present and played will be shown in the display.
      Therefor if you tune a four string bass, only four LED columns will light up.
      • Apr 9
    • jlittle3917
      jlittle3917 Thank you for the quick response. I am currently in bass strobe mode. Tunes great! but the strum mode is only showing me four strings even when I am hitting all 5 on my bass. Prior to the 1.4 firmware update this was working fine and has never been a problem on my previous polytune.
      • Apr 9
  • New
    BigBaby
    Newcomer - Level 1
    2021-04-06

    Howdy,

    I just got a new Corona Chorus and have a few questions about how the Tone knob functions.

    When I have the switch set to Chorus or TriChorus, rotating the Tone knob completely counter-clockwise appears to completely remove the wet signal from the output - it almost seems like it is acting in the same way as the FX Level knob.  This was very surprising to me.  For the NON-TonePrint sounds, it does not act like a conventional tone control as far as I can tell.  Is the the expected behavior?

    When I set the switch to TonePrint, then the behavior of the knob changes according to the TonePrint that is loaded.  This is what I expected.  For some TonePrints, the behavior appears to be the same as the built-in Chorus and TriChorus settings.  For others, the Tone knob act as assigned (e.g. changes Delay params).

    If the Tone knob is mapped to the Chorus - Hi Cut function, should rotating the knob completely counter-clockwise result in a compltely dry signal?  Am I essentially "cutting" the effect from anything over 20Hz leaving only the dry signal as audible?

    Thanks for any assistance that anybody can provide.

    Scott

    read more...
    0 11
    • BigBaby
      DavidKnighton Hello BigBaby,
      I was hoping to reference the user manual on this one, but apparently it is missing from the website at the moment. I submitted a request to get this solved so we can have a look at the possible functions. can you clarify whether you have the green Corona Chorus pedal or the black Corona Chorus + Tri Chorus + Toneprint pedal?
      • Apr 7
      • Corona Chorus - Tone Knob Function
        msdf Hello David, there are many manuals missing on the website. For example for the Spark Booster. Please get that fixed, too. Thanks!
        • 14 hours ago
      • Corona Chorus - Tone Knob Function
        BigBaby Hi David, I replied the other day but I am not sure what happened... my reply seems to have disappeared. Anyways, I have the green Corona Chorus and I did eventually find the manual on-line, but it seems to imply that the tone control should function by rolling off the highs, whereas it seems to roll off the wet signal. Perhaps that is by design, but that is what I'd like to confirm. Thanks!
        • 3 hours ago
      • Corona Chorus - Tone Knob Function
  • New
    DRSisco
    Newcomer - Level 1
    2021-04-05

    I am running a BAM 200 through a RX210 and a RS212 currently. I saw a video on your site that said  most TC Electronics bass amps could handle 3 cabinets, which would push the ohm load to 2.66ohms

    My question is will my little BAM 200 handle this, and if not which TC Electronics bass amp will?

    read more...
    0 10
  • New
    gman5920
    Newcomer - Level 1
    2021-04-05

    Hello,

    On the Plethora X5, I would like to kick off the echo while having it finish the last decaying echoes versus just a hard stop of sound.  Is this possible via the Toneprint app?  I have tried to find where I would allow echos to ring after turning off effect but can't find anything. Any assistance is greatly appreciated.  Thank you!

    read more...
    0 13
    • gman5920
      PedroRodrigues Hi gman5920 please consider that you just need to set your Plethora to "buffered bypass" to get Delay/reverb spill-over . Set it under : GLOBAL SETTINGS/PRODUKT SETTINGS/BYPASS TYPE) I hope this helps.
      • Apr 8
  • New
    Glonk
    Newcomer - Level 1
    2021-04-04

    Hi experts,

    I want to use my Yamaha FC9 as an expression pedal with my G-System. I have connected it to the expression pedal input on the control board using a stereo cable.

    When I calibrate the pedal, the LCD on the G-System displays 23 in the minimum position (heel down) and 63 in the maximum position. It actually displays 63 at about the middle position of the pedal. Moving the pedal further to the maximum position does not change this reading.

    Consequently, when using the pedal to control a Wah Wah effect, the sound changes quite strong near the mimium position. From the middle to the maximum position, you can observe no further sound change.

    The FC9 has a 50kOhm linear potentiometer. The end terminals are connected to sleeve and tip. The wiper connects to the ring.

    I checked the resistance of the FC-9 with a multimeter.
    Sleeve - Ring
    Minimum position: < 0,1 kOhm
    Middle position: ~25kOhm
    Maximum position: 48 kOhm

    Sleeve - Tip: Always 48 kOhm

    One more thing. When I connect the expression pedal to the GFX01 instead of the control board, the readings during calibration are 23 for the minimum and 85 for the maximum position (and like before it reads 85 from the middle to the maximum position of the pedal).

    Please advise. Could this be some electronic malfunction or defect of the G-System (displays 23 when the resistance is less than 0,1kOhm)? Or do I simply have to use an expression pedal with a 25kOhm linear pot in order to make use of the full mechanical range of the pedal?

    Hope somebody can comment on this. Thank you!

    read more...
    0 5
Go to page