Statistics

229,106 members
104,081 posts
  • savage120
    Contributor - Level 2
    2020-08-21

    After not using the G-system for a while my footcontroller seems to be dead.

    The unit works ok but I got no leds or display on the footcontroller, and the link led on the unit doesn't light up.

    Anyone knows a solution or settings to check?

    read more...
    0 34
    • savage120
      WilliamR Hello, The first thing I would check is your CAT 5 cable that connects your foot controller to the mounted rack. Try swapping it out for a new cable. If your unit is separated and put in a rack mount remotely, then make sure the replaced CAT 5 cable is no longer than 15 meters. Any longer and you may have issues.
      • August 21, 2020
    • savage120
      savage120 Hi William, thanks for commenting. I tried several cables but get no signal on the footcontroller. Is there anyway to check the input/output on the link connection?
      • August 22, 2020
      • G-system link to footpedal dead
        WilliamR Are you using CAT5 cables.? Double check to make sure you are not using not CAT5e or CAT6 cables.
        • August 24, 2020
      • G-system link to footpedal dead
        savage120 Yes I'm sure. I tested several CAT5 cables. (checked that it's not CAT5e or CAT6) The link LED blinks for a second on booting that only the power LED on the main unit stays on. I tried already contact spray on the connector on advice of another user but still nothing happens. It seems like the pedal gets no power at all. Is there any way I can test this (with a multimeter) Is there a layout of the connector pins available? Is it in anyway compatible with an Ethernet connection? (to test using a computer)
        • August 27, 2020
      • G-system link to footpedal dead
        WilliamR Hello,
        • August 28, 2020
      • G-system link to footpedal dead
        WilliamR Please create a care ticket from the support link and put attention to William Reichling.
        • August 28, 2020
  • Whip7
    Newcomer - Level 1
    2020-08-21

    Can anyone give me a suggestion? My Ditto X4 just quit while I was playing a loop.  Now all the ights are on as it initial startup but it will not click or setup to play or record any loops. 

    0 32
    • Whip7
      PedroRodrigues Hi Whip7 In this case you should summit an assistance request so we can support you on this matter. Please follow the link below to submit the request https://community.musictribe.com/pages/create-new-ticket Thank you
      • August 20, 2020
      • Help with Ditto X4 looper
        Whip7 Hey Pedro Thanks for that suggestion... While I was investigating I found a solution and it is working again
        • August 24, 2020
  • aiden1382
    Newcomer - Level 1
    2020-08-20

    I saw on you tube that some tone prints have different knob functionality. I've been trying for the past 2 days to find a drive tone print I like but to no avail. The closest one I like is the default drive but the dirt on the peda is to low.  Also, I'm trying to dial in an ampeg svt classic sound.

    Can someone familiar with this pedal tell me how to set the knbos using the default tone print setting to get close to an ampeg svt classic?  Or tell me how the knobs function in default mode?   Attached is a photo of my pedal and settings with the default drive tone print. 

    Thank you, 

    AJ

    read more...
    0 28
  • singularity6
    Newcomer - Level 1
    2020-08-11

    Anyone know why the Eyemaster is sold out everywhere?

    0 26
    • singularity6
      PedroRodrigues Hi singularity6 unfortunately we only sell our products via partners and resellers and we do not have access to any stock information from our partners, I would suggest to contact one of our partners and request information on the availability of this unit.
      • August 12, 2020
      • Eyemaster
        Ramireztxng32 I've just ordered the FANGS distortion pedal. A day later I received an email from zzsounds that the pedal was on backorder. ZZsounds claims they expect to receive more units of the pedals soon and will ship one to me as soon as this occurs. ***but wait there's more*** ZZsounds sent me a message saying they expect more pedals by 08/09/2020. Today is 08/12/2020. How bizarre.
        • August 12, 2020
  • warddoug
    Newcomer - Level 1
    2020-08-04

    10 band programable EQ would be fantastic. (With maybe 12db of boost) Like the Source Audio Programmable EQ or BOSS EQ-200.

    That way we can bring our own drive and still modify the sound on the fly with the Plethora for scoops and leads etc........ (Phonebooth sounds, who knows)

    Thank You

    Also...... Viscus Vibe and Phaser are much/much needed, please make them happen soon.

     

    read more...
    1 29
    • warddoug
      Nigel67 Hi warddoug, many thanks for your enhancement request. I will forward this on to the design team for future releases of firmware.
      • August 4, 2020
    • warddoug
      nadampski Definitely 100% certainly totally absolutely indubitably please please please YES to this!!!! My Chapman Stick has no tone-cut so this would be wúnderbar!
      • August 4, 2020
    • warddoug
      Nigel67 I have passed the information on, so can only wait and see what happens
      • August 5, 2020
  • warddoug
    Newcomer - Level 1
    2020-08-04

    Hello

    I own an X5 and was using it in stereo through 2 Quilter Labs Tone Block 200 amps.The MIMIQ when run after preamp pedal (ISP THETA Pre) in the loop, absulutely wrecks the tone of the original signal. Both Left and Right stereo are very harsh. Without MIMIQ still sounded great, clicked MIMIQ on and YIKES!!! Ear Splitter. (No matter what settings on MIMIQ) Before FX loop it still sounded OK (MIMIQ) But that kinda defeats the prupose of the MIMIQ sending different signals (Original and AI enhanced) left and right.

    This was one of the big reasons I chose the Plethora X5 in the first place.

    I used to use an actual MIMIQ pedal to stereo split my guitar and run into 2 amps. I absolutely love the double tracking AI as it doubles guitar nicely. So I understand how it's supposed to sound/work.

     

     

    read more...
    0 36
    • warddoug
      Nigel67 I will pass on your comments to the design team and ask them for some feedback. It is holiday time in Denmark so it may not be straight away. Please bear with me.
      • August 4, 2020
      • Plethora X5 MIMIQ Issues
        Nigel67 A colleague from the design team said that he would send you an e-mail regarding this
        • August 4, 2020
    • warddoug
      CarlBigsby It works fine for me. I run mine post distortion box (Himmelstrutz Fetto LaRocca) and then to two separate amps' inputs (mostly one Cornford and one Marshall) two emulate two guitarists. I use the PX5's harmonizer in the same way. Could it be that you at driving the PX5 into clipping by pushing it too hard?
      • August 10, 2020
  • stunotstew
    Newcomer - Level 2
    2020-08-02

    Has the possibility of a tone print fuzz been discussed for the plethora? As a fuzz lover, I'd love to have this ability.

    1 26
  • iacovitti
    Newcomer - Level 1
    2020-07-27

    Hello,

    is it possible to power the Spark Boost (4 knobs) with 12VDC supply without damaging the unit?

    I want to pair it with a preamp that is 12VDC powered and I would avoid to use two power supply.

     

    Thanks,

    Luigi

    read more...
    0 26
    • iacovitti
      WilliamR Hello, I don't recommend using anything Higher than DC 9 volt Negative tip. Anything higher could damage the pedal.
      • July 28, 2020
    • iacovitti
      TC-Scotty Hey, your Spark Booster will work at 12V but as previously stated, we don't recommend using anything above 9V.
      • July 29, 2020
  • CarlBigsby
    Regular Contributor - Level 3
    2020-07-24

    I am in a four piece band where the lead singer can't sing an play guitar at the same time, which means that he only plays guitar when he doesn't sing, e.g. during intros and when we play solos. Therefor I have been using harmonizers for a long time to emulate a second guitar player who is playing 3rd harmoncs when we do parts with guitar harmonies (like Thin Lizzy etc.) and other devices (incl Mimiq) to emulate doubling of rhythm guitars. 

    To control all this has been using a slightly complicated MIDI controlled switching system and my rig has developed into somehting you would associate with David Gilmour... and I have been looking for a multi effect unit to simlify my rig consierably but without compromizing too much on the sound. Unfortunatly I couldn't find anything good enough until Plethora X5 was released.

    There are tons of good advanced digital effects processors in the market, but what I think sets Plethora X5 apart is how well it can help you to emulate a second guitar player in the band, thanks to the quality of the Harmonizer and the Mimiq doubler, which is exactly what I need.

    But most people who use stereo guitars need to switch between stereo and just the main amp (i.e. one amp) for smaller mono sounds. In our case, that would be when the other guitar player plays, but also in songs which sounds better with just one guitar, or where Mimiq doesn't sound right.

    But unfortunatly there is no way of getting mono out of Plethoras ourputs when both outputs are connected, which makes everything really complicated for us who are using Plethora in stereo with two amps wide apart in the backline. This means that I can only use PX5 for stereo sounds and then I need to use my existing switch in my old mono effects (which I wanted to eliminate to reduce ths size of the rig) when playing in mono (i.e. with one amp).

    A simple additional mono summing stomp box in Plethora X5 with a stereo/mono switch and output level would solve all stereo/mono switching problems and would fit more player who use stereo out to double amps. That would be a good enough sollution even though stereo/mono setting on each stompbox would be more convenient. 

    Even players who don't emulate twin guitars sometimes need to switch from huges stereo sounds with modulation, reverb and delays to smaller mono sounds to create contrasts in a song. 

    Is there anyone else here who uses Plenthora X5 in stereo or am I the only one...?

    read more...
    1 32
  • theimageofall
    Newcomer - Level 1
    2020-07-19
    Hi. Enjoying the Plethora X5, but unsure on the best way to set up with a Diezel VH4-2 pedal which is going into the effects return (power amp) of my amp. The Diezel pedal has an output direct to amp input when the pedal is off. I’d like the Plethora delays/reverb etc to be after the Diezel so that it is affecting the distorted signal, but I’d also like to be able to use the tuner/modulation effects of the Diezel pedal is off. How would you best set up the Plethora with a distortion pedal in the effects loop (so going into effect loop return/power amp)?
    read more...
    0 32
    • theimageofall
      TC-Mike Hi,

      i haven't got the DIEZEL pedal to try it with, but from the inputs and outputs i'd try something like that:

      Guitar > X5 INPUT

      X5 SEND > DIEZEL INPUT

      DIEZEL CLEAN OUT > AMP INPUT

      DIEZEL DIRTY OUT > X5 RETURN

      X5 OUT > AMP RETURN


      The X5 effects before the diezel pedal can be used on both clean and distortion with this setup as they come before the VH4 input.

      Another alternative would be to use a Y cable with all MONO jacks from both of the VH4-2’s outputs to the X5 return and setup in normal 4CM (4 cable method)

      But you won’t get the clean preamp from the amp that way!

      Basically the VH4 is putting your amp’s preamp into it’s own loop and then A/B ing it with the pedal’s own high gain preamp.

      Try it and let us know how it works for you.

      Best regards from the TC guitar team,

      Mike

      P.s. we have soon a 1.2 firmware update Beta available. Let me know if you'd like to test-driv it prior to release.
      • July 20, 2020
      • Plethora X5 and Preamp pedal in FX Loop
        theimageofall Hi Mike.

        Great reply thanks. I’ll test it.

        Happy to beta test firmware as well.

        Cheers!
        • July 20, 2020
    • theimageofall
      TC-Mike since PM feature is not working yet and i cannot so your reg e-mail address, please write me a mail to [email protected] and i send you the beta firmware once available. if you'd like to use the TonePrint app on iOs or android please include your registered apple id/Google mail, so we can enlist you as a tester. Best regards from the Tc guitar team!
      • July 21, 2020
Go to page