Statistics

294,585 members
177,696 posts
  • New
    ZelKust246
    Newcomer - Level 1
    2022-05-29

    Hi there, I was looking to add a SPECTRADRIVE pedal to my bass setup, however, from what I can see this is now discontinued?? Does TC Electronic make an alternative/replacement pedal for this already - or is there one in the works?

    Greetings from New Zealand!

    Zel

    read more...
    0 19
    • ZelKust246
      PedroRodrigues Hi ZelKust246, thank you for your post, please consider that the Spectradrive is not discontinued. I would suggest to follow the link below to access our network of Resellers and Partners to request information on the Spectradrive availability. https://www.tcelectronic.com/buy.html I hope this helps . Thank you
      • May 31
  • New
    gary1952
    Newcomer - Level 1
    2022-05-28

    I am currently running firmware 1.2.18 and am unable to update to 1.3.11.  I am using a Macbook Pro and have followed the precautions recommended but am unable to update the firmware.  Any suggestiins ?  Do I need to update to 1.3.6 first and if so where can it be found ?

    read more...
    0 6
    • gary1952
      WilliamR Download the latest Plethora firmware .bin file from

      Download the PlethoraX5_1.3.11.bin firmware file and save it on your computer.

      Connect your Plethora X5 to your computer via the included USB cable. The Plethora will show up on your computer as a device.

      Now drag and drop the PlethoraX5_1.3.11.bin firmware file into the Plethora device folder on your computer.

      Once the file is copied to the device folder, disconnect the USB cable.

      Power cycle your Plethora and wait for the firmware upgrade to finish.

      All done – your Plethora X5 is now updated to the latest firmware.

      You can check the firmware version installed in your Plethora’s by accessing the SETTINGS / GLOBAL / ABOUT menu.
      • May 28
  • New
    nop10427
    Newcomer - Level 1
    2022-05-26

    Anybody tried the Plethora x5 with headphones? Any review about it? I guess its posible through the stereo output with cabsimulator. Am I right?

     

    0 18
    • nop10427
      WilliamR Hello, William from musictribe here. Although the output is labeled as stereo it does not act as a stereo jack by itself. The stereo jack when used in conjunction with the mono jack at the same time will act as the right output and the mono jack will act as the left output. Mono by itself will send a mono signal, stereo out by itself will not send a stereo signal to drive headphones.
      • May 26
  • New
    TC Electronic
    Triber Moderator
    2022-05-26

    PLETHORA X3
    https://www.tcelectronic.com/product.html?modelCode=P0EB4

    Learn More: https://youtu.be/lLFVbJVetGg

    Your flexible collection of up to 127 mini boards within your pedalboard – just like the original PLETHORA X5. Regardless of whether you prefer your signal to flow from left to right or vice versa, PLETHORA X3 can be set up to fit your logic.

    #TCElectronic #PLETHORAX3 #Guitar #Bass #Effects #Pedals

    read more...
    1 11
    • TC Electronic
      jvp21 Very cool - will this be coming with another firmware update as well?
      • May 27
    • TC Electronic
      tubedriver42 hi, can the Plethora X3 be manually loaded with acoustic IRs in the Cab Sim section?
      • Jun 24
      • TC Electronic New Product Release: PLETHORA X3
        PedroRodrigues Hi tubedriver42, thank you for your post, you can only use the IRs in the Cab Sim section although we will add new ones in the future. I hope this helps
        • Jul 16
  • New
    xav42
    Newcomer - Level 1
    2022-05-23

    I play the A string, then record a loop, then stop the loop after 2 seconds.

    I would expect a almost continuous sound. However there is some noise every time the loop is restarting (attached file is a recording showing the issue)


    View Attachment
    read more...
    0 15
    • xav42
      PedroRodrigues Hi xav42, thank you for your post, in this case, after analysing the file provided I would suggest to first confirm that you are using a 1/4 jack TS cables, and that you are using the correct PSU that must be a Standard 9V DC, Centre Negative >300mA.
      I would also advise you to confirm that your pedal is running the latest FW version that you can access by following the link below:
      https://www.tcelectronic.com/tcelectronic/product?modelCode=P0DE9
      If this does not resolve any of the issues reported, I would then suggest following the link below to submit an assistance request directly with our Tech Support Team, so we can analyse this matter with more tools.
      https://community.musictribe.com/pages/create-new-ticket?type=Technical%20Support&brand=TCElectronic

      I hope this helps

      Thank you
      • May 24
    • xav42
      xav42

      Hi,
      I'm using high quality cables and power supply. Everything is ok on this side.
      The looper is using the latest firmware 1.3.0.0. I even reinstalled the firmware and it changed nothing.
      The support has been contacted.

      Can anybody here having a Ditto (any model) could please try to reproduce the issue ? It only takes a few seconds... I would like to know if it affects all the pedals or just mine... Thanks !

      • May 24
    • xav42
      TC-Mike Hi Xav, this sounds as it could be a potential issue with the memory. Please try to do a factory reset of the pedal and let us know if this makes any difference? (to factory reset , press and hold the outer left Footswitch for around 13 seconds until you see the LEDs light up.) Do you get the "scratching noise" with every recording or only on certain Loop recordings? Do you use the Playback FX when this is happening?
      • May 24
    • xav42
      xav42

      Hi Mike, the factory reset did not solve the issue. I'm hearing the noise only if the same sound is played at the beginning and at the end (the idea is to make an infinite note, see 1st post). For "normal" loops, I do not hear abnormal noise. I did all my tests without effects.

      • May 26
      • Ditto X4 : noise / scratch when restarting a continuous note loop
        TC-Mike Hi Xav, thanks for the info.I'm afraid it is a hardware related issue then and needs some service. Please create a support ticket for that and include all info . (chat, serial numenber, putchase date etc)
        • 1
        • ·
        • Jun 1
  • New
    leond
    Newcomer - Level 1
    2022-05-22

    With my Plethora X5, a few of the foot switches are very stiff to press down.  What is approved method for lubricating the switches?

    Thank you.

    0 36
    • leond
      PedroRodrigues Hi leond, thank you for your post, please ponder that we do not advise any type of lubrification been applied to the Footswitches, in this case I would suggest to submit an assistance request directly to our Tech Support team via the link below so we can analyse this matter in more detail. https://community.musictribe.com/pages/create-new-ticket?type=Technical%20Support&brand=TCElectronic

      I hope this helps

      Thank you
      • May 24
      • Plethora X5 Foot Switches Stiff
        leond Thru a series of emails, I've ended up with the Service Repair Team. They've asked for some information including and Order Invoice. I'll gladly provide an Order Invoice except I don't know what that is. What is an Order Invoice?
        • 1
        • ·
        • May 26
  • New
    gigisteph
    Newcomer - Level 1
    2022-05-20

    Hello,

     

    I'm a really happy user of the Plethora, but I do have frustration with the auto-save function. Because my ableton live rig is sending program change and CC's to the Plethora, but the problem is that I would like to get back to the original board every time I do a new live show. 

    Program load for 1st song > some effects changing in the song > Program load song 2 >>> if the program 1 was saved, the next time I'll play the show, I will start the song 1 with the sound expected at the end of the song.

     

    There is no way to use programmed board change without disabling the auto-save on changing board function.

     

    Thank you considering this request!

    js

    read more...
    3 20
    • gigisteph
      CSurieux We requested this from the beginning, good luck ;)
      • May 20
    • gigisteph
      NicJonesMT Hi GigiSteph.
      I've forwarded this over to the development team.
      • May 21
    • gigisteph
      gigisteph

      Thank you for your answers (and the forwarding)

      • May 24
  • New
    LURKO
    Newcomer - Level 1
    2022-05-16

    My Flashback has a couple problems:

    • The rotary dial to select from available delay types is messed up. It is off sync with the labeling all of a sudden and it's like it's skipping one of the settings. So when switch points to DYN it's actually serving up MOD, etc. 

    • The input and output jacks short out if the cord is plugged too far in (you have to pull them out just slightly or the sound cuts out)

    Any ideas on fixing either issue or hopefully both?

    read more...
    0 8
    • LURKO
      PedroRodrigues Hi LURKO, thank you for your post, in your case I would suggest updating your pedal to the latest Firmware version, by following the link below and test it again.

      https://www.tcelectronic.com/product.html?modelCode=P0C80

      When testing your pedal please confirm that you are following the steps below to correctly transfer TonePrints to your pedal as you see below:

      – Launch the TonePrint app on your smartphone.

      – Find the TonePrint you want to use.

      You can browse TonePrints by Artist or Product (i.e.,pedal type). You will also find Featured TonePrints.

      – Plug your guitar or bass into your TonePrint pedal.

      – Turn your TonePrint pedal on.

      – Turn up the volume on your instrument and set the pickup selector to one pickup.

      – Hold the speaker of your smartphone next to the chosen pickup and touch “Beam to pedal”.


      Thank you
      • May 17
  • New
    skysharma
    Newcomer - Level 1
    2022-05-16

    I'm looking for a MIDI tap tempo pedal with a headphone out for an audio click to use with my Ditto X4. I'm pretty surprised that the only one that I've found so far that might fit my requirements is this Midinome from Ultra Palace:

    http://www.ultrapalace.com/midinome.html

    It would be great if it works but it seems really expensive and, again, I'm surprised there aren't more choices to fulfill what, I would think, is a very common need.

    I DON'T want percussion in my performances (hence I don't want something like a BeatBuddy).

    But I do want precise timing in my performances. Seems the right way to achieve this would be with a MIDI clock for the looper and an audio click for me. But I don't want the click to be audible to the audience for the same reason one wouldn't want the click track audible in a recording.

    I'm sure there are more choices like this one out there, right?

    read more...
    0 17
  • New
    yavuz
    Newcomer - Level 1
    2022-05-14

    Hi everyone, Infinite Sample Sustainer looks great. Are there any plans to port it to Plethora X5?

    1 39
    • yavuz
      PedroRodrigues Hi yavuz, thank you for your post, at the moment we cannot make any comment on future features and developments for the PLETHORA X5, nevertheless we can confirm that some exciting new development are on the way, please stay tuned. Thank you
      • May 17
      • Are there any plans to port infinite sample sustainer to plethora x5?
        CSurieux Let's pray ... the sooner the better.
        Any timeline ?
        • 1
        • ·
        • May 19
      • Are there any plans to port infinite sample sustainer to plethora x5?
        PedroRodrigues Hi CSurieux, thank you for your question, unfortunately at this time we cannot provide a time window for this. Thank you
        • May 20
Go to page