Statistics

250,609 members
127,789 posts
  • PaavoM
    Newcomer - Level 1
    2020-10-07

    Hi there,

    Few weeks ago at the rehearsals a crackling noise from speakers got my attention. Standby LED on my Trirec was blinking and before I managed to turn the amp off, all the LEDs went off and smell of burning electronics built up.

    I changed all faulty components and put new power valves. Everything was working, except the Infinium module. It didn´t do anything. Not blinking the monitoring or adjusting bias voltage.

    So, now after sending few spare part requests with no replies, I have a simple question. Is the TUBECTL3 available spare part or not?

    If it's available, I´d like to the cost. Otherwise I¨ll do my plan B and build the amp up titled Trirec Manfinium. I´ll lose the Varpower function and auto-biasing, but anyways it´s not a big paper weight.

     

    PM

    read more...
    0 111
    • PaavoM
      DavidKnighton Hi PM,
      Could you get me your first case number please? I'd be happy to look into it and get someone to email you back with some info.
      • October 7, 2020
    • PaavoM
      PaavoM Yes, the case number: CAS-139607-C7D6D8. Thank you.
      • October 7, 2020
      • Bugera Trirec Infinium TUBECTL3 blown, where to find a new one
        DavidKnighton Hello PM,
        I forwarded your case number to the appropriate team for immediate action. Apologies for the wait thus far. Someone should be addressing your ticket very soon. Please let me know otherwise.
        • October 8, 2020
    • PaavoM
      PaavoM Hi David, Thank you for your big help. I finally got the spare part, the Infinium module and now my Trirec is alive and rocking. There was still one faulty part cooking the voltage regulation and causing fuses to blow. It was lttle bit time consuming to track it without schematics, but it was done and fixed. Cheers, PM
      • October 26, 2020
  • dct170
    Newcomer - Level 1
    2020-10-02

    I just purchased a Bugera T5 and want to use my Bugera V55 as a speaker cabinet.  The T5 speaker connection is 4 ohms.  What ohms setting would I use on the back of my V55?

    0 73
    • dct170
      JasonB81 Hello David - can you give me more clarity here of what you want to do? You want to run a head to your combo amp's speaker ? Thanks in advance.
      • October 13, 2020
      • T5 and V55
        dct170 Yes that is correct!
        • October 13, 2020
  • GeorgeKlongland
    Newcomer - Level 1
    2020-09-29

    I bought the foot switch specified on the back of the amp and the connector is different.

    The amp has a big connector and the foot switch has a small connector.

    The part number is the exact part number called for. 

    So is there a replacement connector that I can wire in ? Or and adapter ?

    read more...
    0 180
    • GeorgeKlongland
      GeorgeKlongland
      • September 28, 2020
    • GeorgeKlongland
      GeorgeKlongland
      • September 28, 2020
    • GeorgeKlongland
      john0121 Sorry for the problem you've encountered here, can you please submit a technical support case via the "Support" button at the top of the page and we can get this looked into/resolved.
      • September 28, 2020
    • GeorgeKlongland
      GeorgeKlongland Can someone, anyone just get me a wiring diagram for the connector for the footswitch on the back of a 6262 infinium?
      • October 15, 2020
    • GeorgeKlongland
      GeorgeKlongland Can someone, anyone get me a wiring diagram for the footswitch connector on a 6262 infinium? I bought a new 5 pin din cable and need to know which pin is which to wire it .
      • October 15, 2020
      • Bugera 6262 Infinium
        JMaxfield77583 Google is your friend Bro! All of the Bugera schematics (except for the TriRec or the Magician - which never saw production) can be found online.
        • October 22, 2020
  • Bugera
    Triber Moderator
    2020-09-28
    Elmo Karjalainen reviews the Bugera V22 Infinium
     
    Check it out!
     
     

    read more...
    0 77
  • Reinier
    Newcomer - Level 1
    2020-09-12

    Hi, The output transformer in my Bugera G5 Infenium is damaged. Wher can I buy a new one.

    0 98
    • Reinier
      Nigel67 Hi, please go to the support tab at the top of the page and submit a ticket to the spares team. One of my colleagues will then be able to get back to you with pricing and availability.
      • September 13, 2020
    • Reinier
      JMaxfield77583 Parts team is slow, but they'll get you what you need as long as you have all of the part numbers in advance.
      • October 22, 2020
    • Reinier
      Hawke77 I'm still waiting for a transformer I tried to order August 15. No communication except for one letter that said: we will get back with you when the 300 they are being made get shipped to us. Might take a month, the letter said. No response to letters I've sent. I would really like to have a transformer or a realistic time estimate.
      • October 28, 2020
      • Bugera G5 Infenium
        Hawke77 Still waiting on a transformer or an ETA...
        • Dec 31
  • Fhuels
    Contributor - Level 1
    2020-09-02

    I own a Bugera T5 Infinium amp and I use my amp several times a week. Yesterday I powered up and after about 30 seconds the jewel light began flashing and the the tube monitor light on the back lit. I have two power and two preamp tubes so I swapped out preamp tube 1 with preamp tube 2, no change. I then swapped out power tube 1 with power tube 2, no change. I then swapped out preamp tube 2 with preamp tube 1, still no change. This seems to confirm the issue is not the tubes. If I set the output to 5 watt, turn volume and gain to 10 and engage the phat button I can hear the amp is sending a signal to the speaker cabinet, and it sounds fairly normal, just at a vey much reduced output level. This is true for both speaker cabinet and headphones out. Any advise, tricks, reset options, ... is greatly appreciated!

    read more...
    0 105
    • Fhuels
      JasonB81 Hey Fred - The amp MAY require service -please go to the support tab at the top of the page and submit a ticket to the support team. One of my colleagues will then be able to get back to you.
      • September 14, 2020
    • Fhuels
      Fhuels Hello Jason. I have contacted support and have shipped my amp to the service center for repairs. Thank you for your response.
      • September 14, 2020
  • lucastor4
    Newcomer - Level 1
    2020-08-13

    Hi, I´m from Brazil and I´m Electronic Engineer. I have a costumer with a Bugera 333XL Infinium which does not fit the BIAS to valve 2. I just change the tubes to new ones, two new quad sets (JJ and electroharmonix) but the led 2 of digital module turns on and the standby bulb light blinks. I have checked the grid voltages and to V1,V3 and V4 the voltage is -48V. To V2 the voltage is -25V but not stable, it changes between -25V and -24V. I have checked all cables, I removed the digital module and checked connections. I have changed the sockets of tubes but the problem persists. I have no ideia what do know, I suspect that infinium module is bad working. thank you for help.

    The ticket is: CAS-129532-V7J5J8

    read more...
    0 69
    • lucastor4
      Dale_M Hi lucastor4, sorry to hear of this issue, I will ask the USA team to look out for your ticket, it looks very much like a repair will be required.
      • August 14, 2020
  • ScatPack2020
    Newcomer - Level 1
    2020-08-12

    This is a pic of the head

    0 75
    • ScatPack2020
      DanielPaine wonderful - I like the cobwebs. Authentic
      • August 18, 2020
    • ScatPack2020
      ScatPack2020 Yea I just got it I’m trying to find replacement knobs or the actual pits for this amp head it was given to me
      • August 18, 2020
  • ScatPack2020
    Newcomer - Level 1
    2020-08-12

    I have a behringer V-ampire lx1200h amp head missing three knobs and I would like to fix them do you have a parts diagram with part number so that I may replace them I just got this head.

    0 282
    • ScatPack2020
      KyleJohnson Hi Scatpack2020. To order parts, please submit a spare parts ticket by clicking the Support button at the top of the page.
      • August 12, 2020
  • Abnersanchez
    Newcomer - Level 1
    2020-07-28

    Good day! So I own a Bugera G5 amp head and absolutely love it. A couple days ago it started losing power or something to that nature. My emulated output does work as well as the send/return. I've changed both tubes now... Not sure what to do at this point... The distortion, loss of power only happens at the amplifier output to the speaker. I've checked my speaker, cables and tired other guitars.  The infinium LED for the tubes sometimes lights up even at a low wattage and even though I've put in new tubes. I give up and need help. Please help!

     
    read more...
    0 77
    • Abnersanchez
      AlexLane Hi, could you please contact support using the "support" button at the top of the page? Technical support and fill out the required details. The amp may need a service
      • July 29, 2020
    • Abnersanchez
      Abnersanchez Thank you I have. Haven't heard back yet.
      • July 29, 2020
      • BUGERA G5 SOUNDS LIKE IT'S DYING
        AlexLane Please give them 24 hours to respond, if they don't within 24 hours pop me an email with your case number.

        [email protected]
        • July 30, 2020
Go to page