Statistics

254,203 members
131,863 posts
  • New
    Ryker5
    Newcomer - Level 1
    2021-09-23

    Hello,

    my KXD12 will nor power on.

    I have replaced the fuse and also the power cord.

    Any ideas or does it require a workshop visit?

    cheers

     

    0 8
    • Ryker5
      WilliamR Hello Ryker, It sounds like your KXD12 will need to be serviced. Please click on the support link above and create a service ticket so we can line this up for you.
      • Sep 23
  • New
    johnparker75
    Newcomer - Level 1
    2021-08-25

    When I use the fbq button on my new kxd12 the red LEDs come on and stay on, even with nothing plugged in. Any ideas on what's going on? So far I truly hate the sound of the amp.

    0 22
  • New
    Tonytequila
    Newcomer - Level 1
    2021-07-21

    Behringer  kxd 15 keyboard amp. fx noisy when turned on/up. Does not make noise when turned off or turned down.

    0 79
    • Tonytequila
      WilliamR Hello, William from musictribe here. Sorry about the issues you are having. Could you click on the support tab above and create a tech support case so that we can troubleshoot this for you. It would be helpful to send a video clip of this fault as well for us to review.
      • Jul 21
      • Problem with behringer keyboard amp kxd 15. Noise when fx are turnèd on
        Tonytequila hi, have done all that but have got no help back, contacted fixtronics and they have not replied back either, it's warranty has expired but between covid and everything the amp has n't been used in at least 17 months. i don't think it's looking good, I would n't be recommending them to anyone.
        • Jul 22
      • Problem with behringer keyboard amp kxd 15. Noise when fx are turnèd on
        WilliamR Hello Tony, I'm sorry for the delay. Do you have a case number?
        • Jul 22
  • New
    Tonytequila
    Newcomer - Level 1
    2021-07-14

    I don't use the effects section much on my kxd15 but still there is a loud noise coming from it when I turn it on/up. this happens evan though nothing is plugged into it. i can't really use the amp as the noise filters through the pa system which is annoying to everyone, it's a fairly new amp and has n't been used all that much.

    read more...
    0 35
    • Tonytequila
      DavidKnighton Hello Tonytequila,
      It sounds as though your effects module may be corrupt. I would suggest submitting a service request inquiry via the support tab so our team can get your item into a service center for evaluation.
      • Jul 14
  • New
    Benjamingreenwood1
    Newcomer - Level 1
    2021-03-29

    trying to source some spareparts.

    some of the keys have stopped working. i am after both pcb's aswell as the rubber keytops. im assuming the contacts have worn between the rubber and the pcb itself. have tried cleaning with no success and know that the board is faulty for the right hand side of the piano.. would like to order both so as to prevent happening on both sides in the future.

    read more...
    0 139
    • Benjamingreenwood1
      Nigel67 Hi Benjamin. Please contact our spares department and they will be able to quote you pricing and availability. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spares tab and submit a ticket. Many thanks
      • Mar 28