Statistics

298,621 members
182,253 posts
  • New
    Hutchball
    Contributor - Level 1
    2022-09-23

    Hi, is there a setting so that the harmoniser only activates when the pedal is depressed? (non latching)

    1 2
    • Hutchball
      kiskadar69 I don't think there is such a setting on H1. Maybe TC-Helicon will include it in a future firmware version.
      You can use the non-latching mode with these, for example:
      - TC-Helicon Harmony Singer (cons: fixed scales cannot be selected)
      - TC-Helicon Harmony Singer 2 (cons: fixed scales cannot be selected, pros: power input 9VDC =pedalboard friendly)
      - TC-Helicon VoiceLive Play plus Switch-3
      - TC-Helicon VoiceLive Play GTX plus Switch-3
      - TC-Helicon Play Acoustic plus Switch-3
      - TC-Helicon Play Electric plus Switch-3

      If you want to use the H1 anyway, here's a workaround:
      Step 1. Set the DRY/WET potentiometer of the H1 to full WET. This way only the harmony will appear on the XLR output. The H1 harmony function should always be On.
      Step 2. Plug your mic into some kind of splitter (active splitter, or a small mixer). The original vocal will be on one of the outputs of the splitter.
      Step 3. Connect the other output of the splitter to the XLR input of the H1, and enable this connection with a momentary switch.
      • Sep 23
  • New
    Agoldini
    Newcomer - Level 1
    2022-08-21

    I have a Mackie mixer with 4 microphones going in. I want to use the line level effects out loop of gthe mixerinto a Skysurfer to add reverb to the voices. Does the Skysurfer accept line level input into the 1/4 jack or just guitar level input?

    read more...
    0 6
    • Agoldini
      PedroRodrigues Hi Agoldini, thank you for your post, you are correct, the Skysurfer only accepts Guitar level on the input stage. As the typical line out connection offers an output impedance values from 100 to 600 Ω while the input stage of the Skysurfer must be used by a signal that offers a 350 KΩ via 1/4 JACK TS cable. In these cases I would suggest the use of a D.I. to allow to manage the impedance mismatch and avoid any issues.
      • Aug 23
  • New
    Cfishinbill
    Newcomer - Level 1
    2022-05-05

    Love my Play Acoustic pedal , however , there's a problem when I try to overdub . It does fine with one loop , but when I try to put more on the volume of the initial loop drops of to where it's barely audible . Any comments , ideas and especially solutions would be awesome .

     

    read more...
    0 10
    • Cfishinbill
      PedroRodrigues Hi Cfishinbill, thank you for your post, in this case I would first suggest to perform a firmware update to your unit following the guidance present on the link below : https://wsi.li/dl/TCkxbP8K9aQLPn2Tz/ Thank you
      • May 5
    • Cfishinbill
      Cfishinbill

      Thank you for the input . The firmware is current . I did a factory re-set , and that fixed it .

      • May 7
  • New
    geedays61
    Newcomer - Level 1
    2022-04-14

    Hello i just get the Mac beach ball spinning when i drag the plugins to a channel in studio one, do i need to download other software? Thanks

    0 9
    • geedays61
      WilliamR Hello, Please click on the support link above and create a technical support ticket. One of our agents will contact you ASAP.
      • Apr 14
  • New
    drthud80
    Newcomer - Level 1
    2022-04-13

    I am looking for a replacement for the large data entry knob on a rack mount TC Helicon Voiceworks.

    0 24
  • New
    Kingkeith
    Newcomer - Level 1
    2022-03-30

    I need two new foot buttons.   Where can I find them?

    0 9
  • New
    kiddz3
    Newcomer - Level 1
    2021-12-02

    Hello to all,

     

    My Voicelive 3 was once functioning but for some reason now I do not get output.  All cables are verified functioning and hooked up per the manual on dual mono. Also have input on the level meters but no output to the mixing board. I tried a factory reset but no luck. 

     

    Thanks for your feedback! 

    read more...
    0 22
    • kiddz3
      Nigel67 Hi kiddz3. If you have done a factory reset without success, then the unit is probably faulty and in need of repair. I would advise submitting a ticket to the Technical Team who may be able to advise further and also help with getting your unit repaired. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • December 4, 2021
  • New
    Landonwall1
    Newcomer - Level 1
    2021-11-18

    In the middle or my show, my harmonizer lighted rings go off and the buttons don't work unless I  turn it off and back on. It happens repeatedly. 

    0 18
    • Landonwall1
      Dale_M We would advise performing a firmware refresh and see if the condition clears, if you are still having problems after this go to the support tab and raise a Technical ticket.
      • November 19, 2021
  • New
    MarkBeauregard
    Newcomer - Level 1
    2021-09-07

    I've been searching for hours to see if I can use a "mic mechanic 2" with my mission engineering power supply but with no real answers, it has (two 500 mA outputs) & (six 300 mA outputs). I know the appropriate TC charger delivers 670 mA but exactly how critical is this?

    read more...
    0 37
    • MarkBeauregard
      WilliamR Hello Mark, It is important to run the mic mechanic 2 with at least 670mA. Any less won't damage it, but I cannot guarantee stable operation @ 500mA.
      • September 7, 2021
  • New
    NickPallisgaard
    Newcomer - Level 1
    2021-07-09

    I need a new powerplug for my voice solo fx150 it seems impossible to find. It should have 42,5 vdc 1.5 a.

     

    can anyone help

    0 58
    • NickPallisgaard
      DavidKnighton Hello NickPallisgaard,
      For spare parts, please submit a SUPPORT ticket using the tab at the top of the page. I'll also send you a DM with some info.
      • July 9, 2021
Go to page