Statistics

223,465 members
97,659 posts
  • New
    Olenga
    Newcomer - Level 2
    2021-04-09

    Hello. Is it possible to use X-touch Extender with X-touch One?

    1 4
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-07

    Hi just purchase xtouch ( 8 channel ). I have upgraded to the latest version of Cubase 11 pro and updated the firmware to the latest one on the website. 1.2.1.

     

    Alot of the buttons are not working.

    Click track button

    Had to program it using function keys.

    Utility save , undo

    marker track

    midi track, input, audio track, aux , busses, ouyputs, user buttons all not working

    solo button not working

    drop button not working

     

    Is there a new firmware update being created so this product will actually work with daw programs

     

     

    read more...
    0 11
    • AcrobatStar
      DaveMorrison Unless you have a Ryzen processor, there seems to be no reason to upgrade to 1.21. I haven't yet because all the posts on this forum have been negative regarding 1.21. Of course that means nothing and I really ought to try. I'm still sticking with 1.15 though. The X-touch is a clone of the Mackie Control and it works very well (at least in Logic Pro). However, all the functionality is provided by the host DAW. MCU mode generally has more support than HUI. I bet the Cubase forum will provide you more information on Mackie Control support than this site.
      • Wed at 8:24 PM
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-04

    Hi My Xtouch is not working .

    I upgraded to the latest firmware 1.21.   1.04

     

    Showing looking for i.p adresss.

    Is there a reset for this product

    0 7
    • AcrobatStar
      DaveMorrison Changing modes is a type of reset. It looks like your Xtouch is waiting for a IP address to be sent from a DHCP server. What mode are you in? Reloading 1.21 or Downgrading to 1.15 would be another option.
      • Apr 4
  • New
    RichSallnow
    Contributor - Level 2
    2021-04-04

    This is driving me nuts! Since yesterday whenever I press the record button on my X-Touch, it mutes the track on Logic Pro X. It seems like the record and mute buttons seem to have linked themselves!. I've tried unplugging all midi devices, rebooting the Mac, re-installing the 1.21 firmware, but it's still happending. Any ideas?

    read more...
    0 9
    • RichSallnow
      DaveMorrison If you haven't customized any of the buttons (or functions), go to the "Logic Pro": Control Surfaces : Setup... menu. Then delete the Mackie Control icon.
      • Apr 4
    • RichSallnow
      ChrisJanton Have you tried installing the 1.15 firmware again? From what I could see there's no reason to update to firmware 1.21.
      • Mon at 1:05 PM
  • New
    LittleSharkStudios
    Newcomer - Level 1
    2021-04-02

    Hello,

    I've got an X-Touch and an X-Touch Extender both in HUI mode.

    When I push the "PAN/SURROUND" button on the X-Touch, pans for stereo tracks of the X-Touch change their side (left to right or right to left) but NOT on the Extender! Everything else is getting the right commands (like when I solo a track on the X-Touch the other tracks go muted on the X-Touch and on the Extender as well, same for "FADER BANK" button the tracks are well routed on the X-Touch and the Extender channels), the only thing that doesn't work is the PAN/SURROUND button that doesn't send the command to the Extender. What am I missing?

    Thanks for the help.

    read more...
    0 7
  • New
    EmotiveSigns
    Newcomer - Level 1
    2021-03-30

    Hi - 

    I have been using logic pro for years. For musical input I use a MK-425C keyboard which has worked perfectly. Recently I bought a x-touch and since adding that when I press a key on the keyboard strange behaviour occurs, such as it triggers a different layout, rather than playing the notes. 

    Can anyone help explain this problem and possibly help me fix it?

    Thanks in advance,

    Charles

    read more...
    0 4
    • EmotiveSigns
      NicJonesMT Hi Charles. Ideally it would be easier to help if I could see how you have both devices setup and configured in Logic.
      Could you please submit a tech support ticket (Click support above) and provide some screen shots of your setup?
      • Mar 30
  • New
    EmotiveSigns
    Newcomer - Level 1
    2021-03-30

    Hi

    I've recently got an X-touch which i'm loving. This maybe my misunderstanding but I'm assuming the modify buttons work the same as the keys on the keyboard. However when I press and hold the option key, and click on a track I would assume it would allow me to drag and copy that section to another track. However it seems only to grag and move instead. I've played about with all the buttons and they don't seem to behaviour in that way. 

    Should I be able to use these buttons instead of the keys on the keyboard. If so what am I doing wrong?

    Any help would be gratefully appreciated,

    Thanks in advance,

    Charles

    read more...
    0 8
  • New
    BenH
    Newcomer - Level 1
    2021-03-16

    Hi,

    Can the X-Touch select which side the X-Touch Extender is on?

    It seems by default to cascade to the right.  Can it be switched so that the Extender flows from the left side, so that track 1 is on the Extender, and Track 9 is on the X-Touch, and plug-in parameters flow similarly?

     

    Thanks

    Ben

    read more...
    0 15
    • BenH
      NicJonesMT Hi Ben.
      It is dependent on how you setup your control surfaces in your DAW.
      So for example if you are using Cubase, you need to set the Extender as the 1st device.

      Some DAW's also have a "Channel Offset" Option which you can use aswell, but this is DAW dependent.

      What I would recommend is contacting the DAW developer to see if they can assist you with any additional settings.
      • Mar 16
  • New
    RichardJones
    Newcomer - Level 1
    2021-03-11

    Hi folks,

    Just got my X-Touch and was using Tracktion 7.

    Adding the X-Touch as a control surface (Mackie Control Universal) in Tracktion 7:

    • In / Out markers on F3 & F4 keys - works
    • Touch fader track select - doesn't work

     

    Waveform 11 (Mackie Control Universal)

    • In / Out markers don't seem to work
    • Touch fader track select - works

     

    I was thinking of creating a brand new mapping but am having the following problems:

    1. Moving a fader doesn't register as a controller change (I have to touch it with a cloth to stop the 'touch' grabbing the control!)

    2. I can't get the job wheel to function properly. It jogs forward, but goes back home when I jog backwards.

    Anyone else using this same setup would be great to hear from youi!

    Thanks!

    Richard

    read more...
    0 6
    • RichardJones
      RichardJones Have solved one of the original problems, Waveform gets confused when the mouse is over the track and shows another bar line in addition to the one that's positioned by the jog wheel. Solution - move the mouse out of the track area ...
      • Mar 11
  • New
    bobbyval
    Newcomer - Level 1
    2021-03-08

    THis control surface had been working seamlessly with Presonus Studio One 5 on my Macbook Pro running Mac Os Mojave. I recently purchased a Mac Mini 2018, which came with Mac Os Big Sur already installed. I have since reconnected all of my audio and midi hardware to the Mac Mini and come to find that the Xtouch Compact is no longer responding in Studio One 5. Presonus states that the issue is with Behringer and that many third party developers are having a challenging time with Big Sur compatiblity. Has anyone else seen this issue with the Xtouch Compact and Mac Os Big Sur?

    read more...
    0 18
    • bobbyval
      PedroRodrigues Hi bobbyval, please consider that when it comes to implement any of our units on MacOS11 / Big Sur, consider that, at this moment none of our units is compatible and when interfaced with this OSX version will lead to issues. and my not work.
      However, USB audio/MIDI function of our products is fully USB 2.0 compliant and should keep working under CoreAudio as before.
      • Mar 9
    • bobbyval
      bobbyval I have an update to this thread and issue! It is not a Behringer Xtouch problem and Big Sur, Mac Mini, etc! It is a Presonus Studio One 5 and their support of Big Sur issue, even though they have continued to deny it! Here is how I have come to this conclusion. In an attempt to reproduce the non-responsive Xtouch Compact on my system, I took the liberty of downloading Cubase 11 (which I already have a license for ) and installed it on this computer. After a few clicks in the studio setup dialog, the Xtouch Compact came to life with all faders and lights active! I wasted so much time with Presonus and them telling me quite convincingly that it was Behringer's problem.
      • Mar 23
Go to page