Statistics

250,908 members
128,127 posts
  • New
    swenerick
    Newcomer - Level 1
    2021-05-14

    Hi, it seems it's not possible to use the jog wheel to zoom (when zoom mode is activated).

    I wanted to know if there is a way to change this behavior or it is something that needs to be written in the firmware?

    (I'm working with Logic Pro)

    Thank you.

    read more...
    0 66
  • New
    RubenSt
    Newcomer - Level 1
    2021-05-11

    Hey heroes,

    Question; we're using Behringer XTouch compact in a big european show for Ableton and triggering all kinds of cool things (graphics, AR, screens, lighting, etc...) we<3MIDI

    And now we're wondering if there's a way to send all midi data that's sent to the USB port, simultaniously to the midi-out DIN port on the XTouch Compact.

    It switches between modes 'USB' and 'Stand-Alone'.
    In USB mode all data goes to USB only. 
    In Stand Alone mode all data goes to MIDI DIN out.

    For redundancy reasons we'd like to try and make them (USB and midiDIN out) work at the same time.
    Another solution would ofcourse be DIN out > THRU box and split from there.
    BUTTT
    If anyone knows how to make them spit out midi data simultaniously; hit me up!

    -Ruben

    read more...
    0 50
  • New
    eichy1
    Contributor - Level 2
    2021-05-10

    Hi everyone, 

    My band  just purchased an xtouch to be used as a daw controller,  (logic pro x) we are currently using the x32 as a controller but of course I have limited options , both have 8 faders Q:, can I use both together so I will have 16 faders for mixing, and if so do I have say to logic which one is the boss so to speak, or is it to complicated and just use 1 or the other. 

    Thanks in advance,

    Glenn 

    read more...
    0 56
  • New
    ebosseck
    Newcomer - Level 1
    2021-04-20

    Hi all,

    I noticed that it seems like there is no MIDI signal generated when changing layers using the layer buttons on the controler.
    Is there a way to either detect layer changes caused by the layer buttons on the controler (before another MIDI message unique to the new layer is send), or set feedback (like letting the LED of a button blink or setting the led ring behaviour) based on the active layer ?

    This would be useful in order to give visual feedback to the user on states of functions which might get changed externally (e.g. on another controler or in a GUI), if the same physical control has different functions (and therefore different states) on different layers of the controler.

    I am using firmware 1.12 (according to X-TOUCH Editor 1.21), using the factory preset for standard midi operation. I send and recieve MIDI messages using a python wrapper for rtmidi on Windows 10.

    Greetings,
    ebosseck

    read more...
    0 69
    • ebosseck
      PedroRodrigues Hi ebosseck to configure the button layers on the X-TOUCH have you tried to perform the following MIDI implementation :

      The Layer A and Layer B files assign the controls on the X-TOUCH to MIDI Commands
      Default layer files are provided on the product resources disk, or you can customize your own.

      Please note the layer files must match the map file that you load in DashBoard.
      Connect the X-TOUCH to the server.
      Launch the X-TOUCH Editor application that came with your controller.
      Click the GLOBAL tab.
      Click LOAD in the PRESETS ON COMPUTER area and click Yes.
      Select the X-TOUCH-LayerA####.bin file and click Open.
      Wait for the file to be loaded and click Close on the success dialog box.
      Click Dump A in the TO HARDWARE area.
      Click Yes to start the upload and Close on the success dialog box.
      Repeat these steps to load the X-TOUCH-LayerB####.bin file and click Dump B. In the case of this not working please submit an assistance request so we can assit you with more tools by following the link below :https://community.musictribe.com/pages/create-new-ticket?type=Technical%20Support&brand=Behringer . Thank you
      • Apr 21
  • New
    ebosseck
    Newcomer - Level 1
    2021-04-20

    Hello,

    While working on a programm in order to be able to use the Behringer X-Touch Compact remotely with OBS, I noticed that when remote controling the button LEDs, the LED will not turn on if I send the message [145, 0, 1] (Note On, Channel 1, Note no. 0, velocity 1), as it should according to the quick start guide. On the other hand, when I send [145, 0, 2] (Note On, Channel 1, Note no. 0, velocity 2), the LED turns on, as it should according to the manual for velocity = 1. I was able to witness the same off-by-one error for setting the LED to blink.

    Is there a off-by-one error in the user guide or am I missing something ?

    I am using firmware 1.12 (according to X-TOUCH Editor 1.21), using the factory preset for standard midi operation. I send MIDI messages using a python wrapper for rtmidi on Windows 10.

    Greetings,

    ebosseck

    read more...
    0 61
  • New
    jeremycables
    Newcomer - Level 1
    2021-04-16

    I have a X Touch and the Ethernet Port is not working to be able to connect to our XR18. I updated it to the newest firmware after we discovered that it wasn't working. The activity light blinks on for a brief second after plugging in a cable and then immediately turns back off.

     

    Any ideas?

    read more...
    0 53
    • jeremycables
      DavidKnighton Hello jeremycables,
      Please click on the SUPPORT tab and enter a TECH SUPPORT ticket into our system. This item may require service.
      • Apr 17
      • X Touch Ethernet not Working
        jeremycables I have done that. Waiting on a response.
        • Apr 19
  • New
    LittleBearNoise
    Newcomer - Level 2
    2021-04-14

    Hi, I have a couple of questions, I use Cubase Pro 10.5 and the full version of XTouch:

    1. Does the Xtouch editor work with XTouch or only X-touch One / compact etc? 

    2. How do I activate the use of the footswitch (1/4") to punch in/out? In other responses it has been noted that other units (one / compact) need to be placed into midi mode in order to work. This would remove the normal cubase compatibility functions under the MC protocol which I wish to retain. 

    3. When selecting a bank of 8 channels which are not displayed on-screen (if there are a large number of channels) using the fader bank function on the XTouch, the screen in Cubase does not follow the selection of the next bank without pressing the select button for the last channel in the new bank of 8. When it is pressed the next bank of 8 channels come in to view. Is there a way to edit the function of the XTouch so that the view in Cubase follows the selection of the new bank on the XTouch?

    4. When scrolling through the plug in list using the rotary encoder (plug-in button selected) the list jumps through plug-ins in groups of 4 or 5, this means that many plugins are not selectable from the XTouch plug in settings. Is there a way to make the encoder scroll through the plugins one by one?

    5. The Xtouch One has overlay templates showing the different button assignments for different DAWs is this available for the XTouch?

    Kind regards

     

    read more...
    0 59
    • LittleBearNoise
      DaveMorrison For Questions 1-4: The X-Touch is not programmable. It's a clone of a Mackie Control (plus a mode to connect to X/M mixers). The buttons and controls have fixed MIDI note/controller assignments and can't be changed. The DAW, in your cases Cubase, has to act on the information that it receives (and also sends). Everything is controlled/configured by Cubase. You'll probably have better luck by going to the Cubase forum and search for MCU.
      Question 5. Yes, templates have been made by third party suppliers. There are links to them somewhere in the bowels of this forum. I haven't had any luck searching for them (it's one of the many problems with this forum/site/disaster area ; ) ).
      • Apr 14
  • New
    caferrer
    Newcomer - Level 1
    2021-04-12

    I have a problem. Just got a brand new X-Touch with a brand new HP Envy completely updated and I cannot even see the X-Touch as a Midi input. Therefore, I could not update the firmware because it is not seen by the program. However, it is weird that I can see it in the Device manager under audio devices. Any help would be greatly appreciated.

    read more...
    0 57
    • caferrer
      gethindavies The same thing has happened to me. Bought brand new off of Thomman a few weeks back and the LCD won't show anything at all. There is nothing online to help. I'm completely stuck!
      • Apr 12
      • X-Touch with Windows 10 - not working
        caferrer Thank you for replying. I hope someone out here can help us.
        • Apr 12
    • caferrer
      caferrer Please, anyone help !! we are totally stuck. I will reward anyone who can get this problem solved.
      • May 8
    • caferrer
      ChrisEdwards1 Hi caferrer, I can see you have also submitted a case for this query which I have picked up and will respond to today. Please keep an eye on your spam/junk folders for my response. I will also go ahead and add any details for your post to your case I think may help.
      • May 8
  • New
    Olenga
    Newcomer - Level 2
    2021-04-09

    Hello. Is it possible to use X-touch Extender with X-touch One?

    1 65
    • Olenga
      PedroRodrigues Hi Olenga please consider that the X-TOUCH EXTENDER was designed to work and an extension of the X-TOUCH and the X-TOUCH ONE was designed to work as one fader control to offer a smaller solution to control your DAW, never the less it may be possible to implement both unit considering that you may have duplicated functionalities on each. To assist you on this matter please check this video guide present on the link below https://youtu.be/mQn0abPzrGk?t=76
      • Apr 26
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-07

    Hi just purchase xtouch ( 8 channel ). I have upgraded to the latest version of Cubase 11 pro and updated the firmware to the latest one on the website. 1.2.1.

     

    Alot of the buttons are not working.

    Click track button

    Had to program it using function keys.

    Utility save , undo

    marker track

    midi track, input, audio track, aux , busses, ouyputs, user buttons all not working

    solo button not working

    drop button not working

     

    Is there a new firmware update being created so this product will actually work with daw programs

     

     

    read more...
    0 75
    • AcrobatStar
      DaveMorrison Unless you have a Ryzen processor, there seems to be no reason to upgrade to 1.21. I haven't yet because all the posts on this forum have been negative regarding 1.21. Of course that means nothing and I really ought to try. I'm still sticking with 1.15 though. The X-touch is a clone of the Mackie Control and it works very well (at least in Logic Pro). However, all the functionality is provided by the host DAW. MCU mode generally has more support than HUI. I bet the Cubase forum will provide you more information on Mackie Control support than this site.
      • Apr 7
Go to page