Statistics

268,229 members
147,786 posts
  • New
    gilmourstrat
    Contributor - Level 3
    2022-01-18

    Hi,

    on the release notes of the 1.3.6 Firmware update it mentions faster board changing/loading. Is it fast enough to be used in a pratical way LIVE? Meaning midway thru a song, change to another board with gapless sound changing?

     

    Many thanks!

     

     

    read more...
    0 1
  • New
    BBgjkin
    Newcomer - Level 1
    2022-01-15

    My over 10 years old dcx2496 finally stopped working, because of power supply failure. 

    Is there any way to get the power supply replacement? It seems easy to replace it by few unscrewing and unplugging. And I am sure I could do it without problem. Please let me know where to get it. 

    read more...
    0 3
    • BBgjkin
      Nigel67 Hi BBgjkin. Please submit a spares ticket and someone will e-mail you back with pricing and availability. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. If we no longer have stock, then have you tried a local repair shop? It may be something as simple as the electrolytic capacitors drying out and in need of replacement. Many thanks
      • Jan 16
  • New
    patrikehlersson
    Newcomer - Level 1
    2022-01-13

    Hi!

    What kind of card should i by to my TC M3000.

    I think they stop making the PCMCIA.

     

    /Patrik

    0 0
  • New
    dhsierra1
    Newcomer - Level 1
    2022-01-10

    Hi All:

    just purchased a 2nd KT DN405 PEQ and this one does NOT have an output transformer.  I know this is a legacy product and was wondering if there are any suggestions for a currently manufacture output transformer.  The originals do show up used from time to time on eBay et al but wanted to just order something sooner rather than later that will work.  I'm assuming this is a British unit from the likes of Sowter or Partridge.  

     

    Thanks very much for your help.

     

     

    read more...
    0 14
    • dhsierra1
      Nigel67 Hi dhsierra1. Have you tried contacting our spares team to see if we have stock? This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. The transformers were a specific design for Klark Teknik products. I am sorry, but I do not remember who the manufacturer was but the spares people will be able to help you.
      • Jan 10
    • dhsierra1
      dhsierra1

      • Jan 10
    • dhsierra1
      dhsierra1

      Hi Nigel: thank you for the quick reply, I'll drop them a line and see if they can at least dig out the specs that were used, this is a 30 year old product after all!

      • Jan 10
      • Klark Teknik DN405 Output Transformer Replacement
        Nigel67 The output transformers were used in all Klark Teknik analogue equipment, so although the DN405 was made obsolete many years ago, there were still products using the output transformer such as the DN360 until maybe 5 years ago (possibly a little longer).
        • Jan 11
      • Klark Teknik DN405 Output Transformer Replacement
        Nigel67 Hi dhsierra1. I just checked with the spares team and we have no stock. I doubt that we will be getting any new stock either. I have however found that they were made by Nuvotem and their reference is 92257-P1S1. You could try contacting them and see what they can do for you.
        • Jan 11
      • Klark Teknik DN405 Output Transformer Replacement
        Nigel67 Also try checking the internet for TMR11-7404 as a few options to purchase do appear
        • Jan 11
  • New
    GaryWorsham
    Contributor - Level 2
    2022-01-07

    By now everyone must know that the G-Major was an OK unit for the time with the exception of the rotary encoders.  I had one ten years ago and it started to get flaky so I sold it.  For some really odd reason I decided I wanted one again and I would resolve myself to deal with the encoder issue one way or the other.

    I bought this on Reverb.  I asked the guy if the encoders worked OK.  "Everything works" he said.  Well, he lied.  But you know what?  I knew he was lying.  The probability of a G-Major with working encoders is just about zero at this point.

    First off, the G-Major has 4 encoders.  2 are ALPS "ring" encoders and two are regular pot style rotary encoders.

    I diassembled the unit, which isn't that hard, and took the front panel PCB off so I could work on it by itself.

    I clipped off the encoders when they soldered to the boards then used my soldering iron with a manual solder sucker to clear the holes.  I lifted a trace on one hole connecting to the pull up resistor.  Fortunately I noticed it and was able to fix it with a short bit of solid hookup wire.

    I got ten PCB mount encoders from Digi-Key for about $1.50 each before shipping and tax.

    Bourns part

     

    Then I cut a small piece of Vero board to mount the encoders to.  I ran wires through the existing holes for the center encoder and then slid the Vero down over those wires.  The encoders and wires solder to the top of the Vero.  I figured out where to run the wires so that the encoders adjust things the right way when you rotate CW and CCW.

    I had a weird short when I reassembled the first time.  I was checking the encoder behavior frequently but somehow one of the lines got shorted to ground.  I removed and replaced the encoder and it worked.

    Now, for sure it looks pretty bad compared to the original.  However, it actually works properly instead of flashing, doing nothing, skipping backwards, skipping over the setting you were trying to reach, etc. which is how it acted before this.

    I would describe this as a reasonably advanced electronics tech project.  For me the biggest challenge is seeing things.  I use a magnifier headband thing which helps a bit.

     

     

     

     

    read more...
    2 37
    • GaryWorsham
      GaryWorsham
      • Jan 7
    • GaryWorsham
      GaryWorsham
      • Jan 7
    • GaryWorsham
      GaryWorsham
      • Jan 7
    • GaryWorsham
      Paul_Vannatto That's a cool retro-fix project. Kudos. Now if you had a 3D printer, you could design and print the covers to make it a finished project.
      • Jan 8
      • Resurrecting the G-Major
        GaryWorsham Thanks. I did get a couple plastic knobs, sliced the skirts off with a dremel cutoff wheel, and they fit OK. Hopefully small rodents and insects will not take up residence inside the unit.
        • Jan 8
  • New
    ESharp
    Newcomer - Level 1
    2022-01-05

    I purchased the tc helicon talk box synth and the stomp switch stop working. What are my remedies for replacement or repair?

    0 10
    • ESharp
      Nigel67 Hi ESharp. The unit will require repair as replacement is usually only if the product fails within the first 30 days. First of all, please contact the seller and they should help you out. If there are any issues, please raise a Service Ticket and the Service Team will be able to help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Service tab and submit a ticket. Many thanks
      • Jan 5
  • New
    dukey1955
    Newcomer - Level 1
    2022-01-05

    Good afternoon,

     

    would appreciate some advise on connecting amp 800 to mixer

     

    gear:

    mixer      studiomaster 12XS+

    effect unit Lexicon MX300

    recorder Tascam SD20M

    headphone amp Beringer amp800 (aquired recently

     

    connected to mixer:

    Microphone, keyaboard, ch 5/6 & 7/8 (stereo)

    lexicon (for vocals only) aux out, return to ch. 11/12 (stereo)

    tascam from mains out to recorder in (XLR)

    amp 800 from mixer/recorder headphones out to input A (mono) with TRS

    CD/recorder on ch. 9/10, channel fader normally down to avoid feedback when recording

     

    when listening headphones when connected directly to mixer/recorder I can her everything as it will be recorded, when connectiog amp800 to headphones out on mixer or recorder vocals disappear and only signal from lexicon is heard. same when playback of CD. instruments are OK, vocals disappear (no effect chosen on ch. 09/10)

     

    what am I doing wrong - please advise

     

    Already emailed Dutch supplier (see below), awaiting their reply

    QUOTE

    Ter verduidelijking hierbij even mijn gear details:

    Mengtafel                Studiomaster club12+

    Effectunit                 Lexicon MX300

    Recorder                   Tascam SD20M

    Headphoneamp    Behringer AMP800 (recentelijk aangeschaft)

     

    Opstelling/aansluitingen

    Instrumenten         kanaal 1 t/m 8 (inputs; zang, drumcomputer en keyboards (stereo kan. 5/6 en 7/8)

    De Lexicon wordt via AUX out mono aangestuurd (wordt alleen voor de zang gebruikt) en komt stereo op kanaal 11/12 terug op de mengtafel. De AUX outs van de andere kanalen worden niet gebruikt, mocht er op de keyboards effect nodig zijn, gebeurt dat via de DSP met de interne effect processor

    De Tascam wordt via de Mains out (XLR) aangestuurd.

     

    Via de MON outs op de tafel stuur ik nog een stereo versterker en speakers aan. Vreemd genoeg wordt het volume van de versterker/speakers mede bepaald door zowel de volumeknop van de headphones als de Master volume schuif; hier kan ik echter wel mee leven.

     

    Normaliter kan ik op de koptelefoon uitgangen (zowel die op de tafel als die van de Lexicon) alles goed monitoren en wordt wat ik op de koptelefoon hoor ook correct op de SD kaart gezet.

     

    Na ontvangst van de AMP800 heb ik deze met de TRS kabel op de koptelefoon uitgang van de mixer met input A (de “mono” ingang) van de amp800 verbonden. Bij afluistering via de amp800 hoor ik echter alleen het signaal van de Lexicon terug (zit dus in een ontzettende galmbak). Het maakt niet uit of ik de amp800 direct met de mixer verbind of met de headphones out van de Tascam, het resultaat blijft hetzelfde. De amp800 is aangeschaft om met meerdere muzikanten op te nemen (home-studio). Kon uit de handleiding niet duidelijk opmaken wat dit veroorzaakt.

     

    Sluit ik e.e.a. verkeerd aan of moet ik beide inputs van de Amp800 middels TRS aansluiten (heb maar 1 stereo headphones aansluiting op de mixer).

    Zou het eventueel een optie zijn om de MON outs van de mixer met input a & b van de amp800 te verbinden?? Outs zijn echter wel mono. Opnemen doe ik sowieso alleen met de headphones.

     

    Ook als ik bijv. een CD afspeel valt de zang in de galm als ik via de amp800 terugluister. Bij directe aansluiting van de headphones op de mixer wordt alles correct weergegeven.

     

    Hoop dat jullie mij hiermee kunnen helpen, ben dit probleem de afgelopen 40 jaar nog niet tegengekomen.

    UNQUOTE

    Many thanks in advance for your, hopefully, soonest reply

    best regards

    Will Francois

    the Netherlands

     

     

    read more...
    0 2
  • New
    trucutru0323
    Newcomer - Level 1
    2022-01-05

    i cannot make te pitch shifter sound decent on my plethora x5, im trying to use it like a whammy with an expression pedal but when i pitch it up (or down to make a dive bomb) it sounds very awful, like if it was out of phase or something...

    Can someone share their settings???

    read more...
    0 8
  • New
    edoates
    Contributor - Level 2
    2022-01-02

    Tyring to start thread with user suggestions for the Plethora X5...

    1. Make the tone print loading process easier.

    ---it seems that you have to update the toneprints you find in the all toneprins list, and then SOME of them are now compatible with teh X5. TC should do those updates and place them in the X5 Toneprint list so we don't waste our time

    ---When many (most?) toneprints or just templates are loaded into the board itself, the various parameters don't stay fromt he template/toneprint, but are set to whatever the knobs are set to. SO swe have no idea what they are supposed to be. Example, I'm copied the parameters (at leas thte three I havd access to on the board) from the three band noise gate, and on two differnernt X5, the noise gate is completely different!!!! 

    2. Use the APP to allow storage of my own toneprints across differnet X5s

    ---I have two X5s for different rigs and I want many of my default boards and effects to be the same. Seems to be no good way todo this in the app

    ---ideally, I should be able to backup and ENTIRE Plethora X5 and save it save it in the app, then restore it to another X5 in case of failure, whatever. 

    3. Please write a compehensive manual, even if PDF only. Search wildly on Youtube to things you want to do is wasteful and almost never gives me what I want. See the Nove System and G-System comprehensive models for an example of useful manuals.

    4. Integreate NovaDrive as the GSystem has done: it uses Midi in / out / through and treats the NovaDrive as just another effect. To me, the NovaDrive is the ideal overdrive/distortion pedal for a system like the X5.

     

    read more...
    0 19
    • edoates
      CSurieux I don't think that there is still someone at TC working on this product, last firmware is quite 2 years old (even if they changed its file date, it is the same firmware).
      We have already requested many important fixes without any answer... good luck.
      • Jan 3
      • Plethora X5 Suggestions for TC
        CSurieux Incredible, the beast was not dead, new firmware 1.3.6 today, great features but still no global tempo or midi out RTM sync.
        • Jan 13
  • New
    Bentoto
    Newcomer - Level 1
    2021-12-31

    WTF!!! Just got a brand new mixing link...

    the sound cut everytime I press on the trigger!!!

    TC ?!? It use to be a great brand!!

    or my device is just broken?!?

    someone to help?! Is it normal ?!

    0 3
Go to page