Statistics

289,997 members
172,581 posts
  • New
    znus
    Newcomer - Level 1
    2022-07-02

    Hi!

    I recently bought a Reverb 4000 v 1.03 and would like to update it to 1.11. Could you please put the software up on your tc electronic download page? Everything else is there, except version 1.11

     

    Best regards from sweden!

    read more...
    0 2
    • znus
      NicJonesMT Hi Znus.
      Can you please click support at the top of the page and submit a technical support ticket
      • Jul 3
  • New
    efb18
    Contributor - Level 1
    2022-06-30

    Hi there, I just purchased a Flashback 2 mini and I'm trying to create a toneprint where the tap tempo is set to eighth notes. How do I do this?

    Thanks in advance!

    0 13
    • efb18
      NicJonesMT Hi EFB18.
      Can you please click support at the top of the page and submit a technical support ticket.
      From there we will be able to look into this and advise you further.
      • Jul 3
    • efb18
      TC-Mike you set the "Sub-division up" parameter for to "8th" notes in the TonePrint app and then store the TP to pedal. Now your Tap tempo values (quarter notes) are quantized to 8th note delay times. Alternativly, you can also map the Sub-div up parameter to one of the potentiometers, so you can select which Sub divisions are active
      • Mon at 3:24 AM
  • New
    amargaritp
    Newcomer - Level 1
    2022-06-29

    Hi all , 

    can Harmony singer 2 work without plugging a guitar ? Just with a microphone ? It works fine ?

    I want buy a mic control ; wich is best : sennheiser e835 fx or tc helicon mp 75 ?

     

    read more...
    0 1
    • amargaritp
      WilliamR The harmony singer 2 uses the chords on the guitar to create accurate Diatonic harmonies based on the chords and key you are in. So the harmonies will work but it may miss the occasional minor third or major third harmony if there is no chord information present. As far as mics go they will both work just the same, it all comes down to personal preference. I like the Sennheiser personally.
      • Jun 29
  • New
    TReese
    Newcomer - Level 1
    2022-06-29

    I have an Alter Ego X4 with a Subdivision selector Switch that will not move. I would like to get either a replacement switch or possibly the board it is attached to (Includes the Time and Feedback pots).

     

    Where can I get replacement parts from?

     

    Tim

    read more...
    0 8
    • TReese
      Nigel67 Hi TReese. Please contact one of our authorised service centres or if there is not one in the Country that you reside in, contact our local Super Partner. They can be found at this link. Select either Store or Service Center. https://www.tcelectronic.com/buy.html Many thanks.
      • Jun 28
    • TReese
      TReese

      I will say I am not happy that I cannot acquire replacement parts and do this myself. This is a pedal that is long out of warranty and the company I purchased it from has long gone out of business.

      • Jun 29
  • New
    Leonardo123
    Newcomer - Level 1
    2022-06-27

    Buongiorno.

    Ho comprato da pochi giorni la scheda audio 404HD, ho dei problemi non riesco a farla funzionare con la daw Cakewalk.

    cerco aiuto per poterla settare correttamente. Grazie 

    0 4
    • Leonardo123
      djtetei If you're running under Windows, be sure to check the sample rate setting on cakewalk and OS. Take into account not enabling other applications to take full control over the system. Ensure the latest Behringer drivers for windows are properly installed.
      • Jun 27
    • Leonardo123
      NicJonesMT Hi Leonardo123.
      As DJTeTei stated above, ensure your sample rate settings for the DAW and UMC match, and that you don't have exclusive mode on if you are running other software.
      If you are still having issues getting setup, please click support at the top of the page and submit a technical support ticket.
      • Jun 28
  • New
    Rodders45
    Newcomer - Level 1
    2022-06-17

    VoiceLive3 Extreme - Can anyone advise me as to a sensible setting for a gentle vocal correction when using the VL3X. I'm not the most accurate vocalist but not the worst..... I do have a Mic Mechanic 2 where the 'correction' procedure is fairly simple and straight forward. The control knob goes from 0 to 100% (I usually set it at about 30/40%). Looking for a similar kind of correction setting when using with the VoiceLive3 Extreme. Any help will be much appreciated. Thank you, Rod. X

    read more...
    0 2
  • New
    Blink180stu
    Contributor - Level 1
    2022-06-16

    Hello, 

    I work at a venue and we have a Lake LM-44 processor that was setup with the Lake Processor software but unfortunately I cannot remember the password I set within the software. Please tell me you can help!

    Stuart Badger 

    read more...
    0 5
    • Blink180stu
      NicJonesMT Hi Blink180Stu.
      Please click support at the top of the page and submit a technical support ticket. A member of the team will then advise you further.
      • Jun 17
  • New
    GiornoX
    Newcomer - Level 1
    2022-06-16

    Hi, just bought my plethora and after hours of testing I still can't figure out why my sound is muddy and lost lots of highs.

    I updated to the latest 1.3.11 version, tried every buffer types in settings, both 4 cable method and only in fx loop method, nothing changed. I heard a huge difference with the fx loop on/off. I'm not adding other pedals.

    My amp is Marshall JVM410H which works perfectly fine with my regular rig in the fx loop(some boss pedals+HOF2+ditto), so with the correct buffers and impedance that was alright.

    Someone here got the same problem? I really need a solution. Thanks!

    read more...
    0 3
    • GiornoX
      NicJonesMT Hi Giornox.
      Can you please click support at the top of the page and submit a technical support ticket.
      If you could provide a video of your setup and how the Plethora sounds we can then advise further.
      • Jun 17
  • New
    Pettycells
    Newcomer - Level 1
    2022-06-14

    Hello all! I just received my brand new X5 yesterday and was super excited until I did the firmware update, as directed. Now the unit is stuck in a place where, upon booting up, I'm presented with 3 options: DELETE BOARD, FACTORY RESET, or CONTINUE. None of these choices actually do anything - upon selection, the unit reboots and comes right back to this same screen.

    I originally tried updating on a Mac, to the latest firmware 1.3.11. Then I moved to a PC to avoid any Spotlight issues. I've attempted to downgrade to firmware 1.1.55, and back up to 1.3.11. Results are the same, although sometimes the second screen will display "Preparing Update," and it will stay stuck there. I've let it go for over an hour in this state (presumably long enough to prepare) but it never gets past it.

    I've seen many others here have had similar firmware update issues. I've seen "Wesendit" links to potential fixes, but those links don't work anymore. I filled out a support ticket yesterday, but haven't heard back yet. Any ideas??

    read more...
    0 5
  • New
    pennyprestige
    Newcomer - Level 1
    2022-06-11

    Just purchasd user ditto+ loop and am searching for user manual

    0 6
Go to page