305,633 members
189,953 posts
  • New
    Newcomer - Level 1

    FIR EQ can be imported from the PLM+,D SERIES amplifier to the xp module.
    However, most tuning is done in PEQ when recalling a manufacturer's preset.
    I want to create and use a FIR EQ through the FIR DESIGNER program, but
    I can't. It would be nice if there was a function to import FIR EQ from the manufacturer's preset module when updating later.

    0 1
  • New
    Newcomer - Level 1


    I need old version of lake controller (before v.5) to remotate an old  marvellous LAKE MESAeq that has an old firmware

    or alternatively

    the last firmware for that machine (but I'm afraid to upgrade if it crashes.. and no return)

    there is someone to help me?

    0 4
  • New
    Newcomer - Level 1


    I am currently using Lake Controller 7.0.8 but cannot get a Secondary Controller to run succesfully. I have L.C. running on my FOH PC (connected over Ethernet), controlling multiple LM44s and 26s. When I open L.C on my Tablet to run as a secondary controller the popup window to select Primary or Secondary apperars on the FOH PC, but selecting Primary does nothing, and on the Tablet L.C. just opens to a blank page. L.C. then crashes on the FOH PC. I can see the modules on the network from the Tablet, and drag them onto a page, so the Tablet is communicating with the processors.

    I have always used Secondary Controllers succesfully in the past, but this is the first time I have used version 7.0.8. Also this is the first time I have tried to use Lake Controller on a tablet running Windows 11 (the FOH PC is running Windows 10)

    Any ideas as to what I could try to get this working? One of the reasons I spec'd Lakes for this tour is because of the Secondary Controller funtionality, without it there are few advantages of using Lakes over other products.

    0 101
  • New
    Newcomer - Level 1

    Hi, I just received an LM26 for an old DAS system processing, I entered speakers parameters in Lake Controler and saved my config in a .csc file . I see this file on my desk but when I launch LM preset manager and try to send it to LM26 internal presets, I can't see any csc file at all. What's wrong ?

    0 7
    • olivier085
      NicJonesMT Hi Olivier085.
      Please click support at the top of the page and submit a technical support ticket.
      • Jul 26
  • New
    Contributor - Level 1


    I work at a venue and we have a Lake LM-44 processor that was setup with the Lake Processor software but unfortunately I cannot remember the password I set within the software. Please tell me you can help!

    Stuart Badger 

    0 9
    • Blink180stu
      NicJonesMT Hi Blink180Stu.
      Please click support at the top of the page and submit a technical support ticket. A member of the team will then advise you further.
      • Jun 17
  • New
    Newcomer - Level 1



    I have a problem with Lake Controller on my new laptop. All the text on the interface appers selected in yellow, making it difficult or impossible to read (see screenshot).


    I tried different display modes as well as deactivating hardware acceleration. I also tried setting Windows to execute Lake Controller on the dedicated nVidia Card, but the programm still only runs on the integrated graphics.


    Any ideas as how to solve this?

    0 283
    • BasilM
      NicJonesMT Hi BasilM
      Can you please click support at the top of the page and submit a technical support ticket.
      Please provide the full build specs of your machine, and the Windows Version and Build (Found in About your PC) and we can then forward this on to the development team.
      • May 25
    • BasilM

      That's what I tried in the first place, but there is no support category for the Lake controller software. When I choose Lake as brand, I have to choose either the LM26 or LM44 and provide a serial number, which I don't have. It's a pity how bad support has become since these brands were bought by Behringer.

      • May 25
    • BasilM

      Hi, Any news? same problem here and massive crash when I tried to EQ

      • Oct 26
    • BasilM

      I have exactly the same problem. Any news?

      • Nov 24
  • New
    Newcomer - Level 1

    I have an issue with one lm 44 and suspect another too

    i have been looking at this over the last week. the pattern i am seeing is that on first LM44 power on either through the switch or direct cat 5 to the tablet it does not appear on the network, (i have been using the Lake Update app to check its status) every subquent power cycle after that it shows up on the network. when you come to it cold the pattern repeats.
    anyone else expericence this?
    Tom Tunney
    0 13
  • New
    Newcomer - Level 1

    Hello I'm struggling to setup my lake lm44. I understand how to set it up but maybe what I'm looking to do isn't possible. I want to make my first two inputs(analog) go straight through. Basically Eq only. Input 3(analog) I want to have a cross over on it. Then nothing in 4. Is this possible? It seems I can either have a mesa Eq setup or a countour cross over?

    0 9
  • New
    Newcomer - Level 1

    May i know UDP listen port and reply port for extron ipcp 555 to control volume, mute and etc

    0 15
    • Jclai
      Nigel67 Hi Jclai. This is going to require an answer from our Technical Support Department. Please send them a ticket. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • Feb 27
  • New
    Newcomer - Level 1


    Where can I find Lake training in NYC? 


    - J 

    0 32
    • DC48Volts
      Dale_M Hi there, it may be best to address this on a pre sales ticket from the support tab above,
      • October 3, 2021
Go to page