Statistics

216,312 members
89,521 posts
  • New
    tonyg0508
    Newcomer - Level 1
    2021-01-06

    I have downloaded the latest firmware update for the X5. The new pedals, looper etc have all appeared as expected. However the triple tap to activate the tuner and the board up/down controls appear to no longer work even though they are selected in the global settings. Anyone else have this problem and found a solution?

    read more...
    0 36
    • tonyg0508
      WilliamR Hello Tony, With the latest firmware update, you have to go into your global settings and turn that feature back on. This is bypassed in the new update.
      • Jan 6
    • tonyg0508
      tonyg0508 Hi William. Thanks for the reply. I had the feature turned on in settings but still no luck after re-installing the update. I have created a support ticket and sent a video showing the problem. Thanks again
      • Jan 8
    • tonyg0508
      WilliamR Have you tried doing a factory reset after the update yet? I just tested it out on mines and it is working.
      • Jan 8
    • tonyg0508
      tonyg0508 Hi William. Thanks again for the suggestion. I just tried a factory reset but unfortunately it didn't solve the problem so I then tried cycling the power after the reset but still no luck.
      • Jan 8
    • tonyg0508
      tonyg0508 Hi William. I seem to have solved this by accident. The speed of the triple tap seems to be the issue. You need to triple tap VERY quickly (difficult to do with your foot). Even a very slightly slower tap and it does not work. Thanks very much for your suggestions. Best wishes. Tony
      • Jan 11
  • New
    Hoodrio
    Newcomer - Level 1
    2020-12-28

    No problems beaming toneprints from my new iPad, but when I tried to create my own it was a disaster.  I used the cable that came with the pedal, connected to my iMac, and then after I tried sending a toneprint, the pedal was all screwy.  The slot I was on had no signal at all, the two other slots were all crazy, and the stock delays were all blank.  I unplugged the unit and plugged it back in, seemed to be back to normal, so I tried again with the computer hookup, and the same thing happened.  It's like it fried the pedal.  

    Now I'm afraid it's permanently damaged.

     

    Thoughts?

    read more...
    0 17
    • Hoodrio
      TC-Marcus Howdy Herman!
      Sorry to hear that.
      I suggest making sure that your pedal runs the latest FW. Currently that is version 1.2.00.

      You can get it here https://www.tcelectronic.com/tcelectronic/product?modelCode=P0CKR and instructions on how to update can be found under "Documentation" -> "Flashback 2 1.2.00 Firmware Upgrade Guide English"

      Also, make sure that you run the latest version of the TonePrint app, currently that should be 4.4.3 which you can get here or in your app store
      https://www.tcelectronic.com/product.html?modelCode=P0CLC

      Then try again. Let me know how that turns out.
      • December 28, 2020
    • Hoodrio
      Hoodrio Pedal seems to be working normally again after unplugging everything and plugging back into my chain (not the USB). Frankly, after that experience I don't think I'll ever be risking connecting this pedal to anything via USB again. Thanks for your response!
      • December 28, 2020
    • Hoodrio
      TC-Mike Hi Herman, the app/editor should work fine. Please remember that after storing your custom Toneprint to one of the 3 TP slots and disconnect from editor the settings you hear are the Potmeter settings on the pedal and not the parameter values you added last in the editor .
      • Jan 4
    • Hoodrio
      Hoodrio So, the pedal is definitely fried - it goes from working normally to having literally nothing on the factory settings. In other words, you can be getting a normally DYN delay, switch to Tape, and get ZERO Delay, knobs do nothing.
      • Jan 11
      • Flashback 2 Trouble
        Hoodrio Is there a way to do a factory reset? If not, who repairs these?
        • Jan 11
  • New
    ChristianMonhei
    Newcomer - Level 1
    2020-12-27

    Hello, I have my Plethora for 5 days now and I enjoy it a lot. The new update is great.

    But I miss 2 things : be able to see the values when using the Hot Knobz, maybe it is possible to show the 3 values for the Knobz as

    soon as you tweak them.

                                  be able to sync the tempo via midiclock.

    Thank you for your work.

    Cheers from Belgium

    read more...
    1 18
    • ChristianMonhei
      TC-Mike HI Christian, thanks for the feedback . "Midi clock sync" is already on the feature request list for 1.3 update and has currently a lot of votes. the HOT KNOBZ parameter display feature is also already logged as a feature request and has been noted by other customers as well ranking on 3rd place for UI improvment feature requests..
      • Jan 4
  • New
    tangozebra
    Newcomer - Level 2
    2020-12-25

    The 1.2 upgrade is overall pretty awesome and it's very cool that feateures continue to be added. I have pretty basic Looper needs so was hoping the Plethora looper would be able to replace a separate looper pedal; however there seems to be no way send a midi command for it to STOP, similar to double tapping the Plethora Looper itself. To be clear, I'm trying ot go from recording a loop to having it paused for future playback. If you send a PAUSE command to the Looper while recording, it starts playing immediatly and I've tried various other midi command sequences to get it to STOP with no luck.

    Is there a way to do this or can I request it for the next release?

    Thanks so much for continueing to improve the product.

    read more...
    1 20
    • tangozebra
      lyounkins I second this request. The function of the Pause CC command could be changed (and perhaps renamed to Stop) to terminate the loop and stop playback if recording or simply stop playback if playing. Right now, there's no way to stop a loop while recording without playing it back. Another nice feature to have would be a playback fade as is implemented in the Ditto X4 looper.
      • December 26, 2020
      • Plethora X5 Looper STOP Midi Command
        TC-Mike thx, we have this already logged as a feature request and i agree it is a bit misleading as the "pause" function resets playback to Loop start.
        • 1
        • ·
        • Jan 4
  • New
    davenov41
    Newcomer - Level 1
    2020-12-21

    Help! I've owned the TC Flashback II for a few months now and am loving it. Earlier this year I updated the firmware to use the tap tempo function and that was working fine. I came back to my pedal after a month off or so, and now for some reason, when engaged, I can only hear the delay output, and not the attack of the note itself. What I've done so far to troubleshoot: 

     

    - Pulled the pedal off the pedal board and isolated it as the only pedal in the signal chain between the guitar and the amp

    - Tried multiple different amps

    - Tried multiple different guitars

    - Verified that input is going into the pedal through MONO and exiting through MONO

    - Verified that true bypass and kill/dry dipswitches are set correctly (set to true bypass and off respectively, both oriented left)

    What are suggestions for next steps? Thank you!

    Dave

    read more...
    1 70
    • davenov41
      NicJonesMT Hi Dave.
      I'm Nic from the UK tech support team.
      Just to let you know I have picked up your Tech Support ticket and will be contacting you shortly.
      • December 23, 2020
      • TC Flashback II- only hearing delay, no dry?
        davenov41 Hi Nic- thanks so much for your reply. I received your email regarding my support ticket... I wasn't able to find a way to reply to the ticket from within the care portal, so I simply replied to the email. Please let me know if there's a better way to contact you! Thanks again for your help. Dave
        • December 23, 2020
    • davenov41
      TC-Mike Please check that the Kill dry switch is not set to "ON" . the dip switches can be reached by removing the back cover and more info on the positions /settings can be found in the manual. the second dip switch switches between "true-and buffered bypass" -Buffered bypass will retain the Delay repeats when pedal is bypassed
      • Jan 4
  • New
    ekbannan
    Contributor - Level 1
    2020-12-21

    How do you delete unwanted/unused Toneprints from the X5 to limit the length of the list to scroll throgh?

    I would like to limit the options to about 10 for each FX.

    update: I found out you can delete them 1 at a time by pressing and holding the toneprint knob.  How about the ability to manage the toneprints on the X5 from the editior?  You can upload them but I don't see a way to manage them from the app. The ability to select and delete in batches and have the master toneprint files used/wanted on the X5 by pedal would be a nice feature.

    Thanks,

    Ed

     

     

     
    read more...
    1 28
    • ekbannan
      TC-Mike Yuu just select the Toneprint you want to delete in the on-board TP library (screen 5) and press and hold the TONEPRINT encoder to access DELETE function
      • Jan 4
  • New
    Zoobiedood
    Contributor - Level 2
    2020-12-20
    I currently use a Ditto X4, as it is possible to have 2 completely independent loops. Now, the new update to the Plethora has several more loops at once that are completely independent. Wonderful!
     
    Is there a 'fade' parameter that affects all of the loops (like on the Ditto X4)? This fades out any loops playing over 10 seconds or so.
     
    read more...
    0 26
    • Zoobiedood
      TC-Mike Please note that the Plethora's loopers can neither be synced nor have any save or undo/redo features !, so please check if this will work for you.
      • Jan 4
    • Zoobiedood
      Zoobiedood Well, I was hoping they were completely independent. Do they have a master fade for all of the loops? Maybe something to add later?
      • Jan 4
  • New
    ruezz
    Contributor - Level 1
    2020-12-18

    Just wanted to say thank you for releasing the update. It looks fantastic and I am seriously thinking about leaving work early to head home and install it.

    What are the chances of being able to add external tap tempo through the exp jack in the next update?

    I might ask once a day till we can make this happen. :)

    Thanks again for the update. Looks great!!!

    Zack

    read more...
    2 25
  • New
    ouzoman
    Newcomer - Level 1
    2020-12-18

    A big thank you to TC Electronic for releasing the new firmware - looking forward to exploring the new features.

    One issue though - The v1.2 Release Notes state:

    "Please note that in order to use the new effects, you will need the latest version of the Toneprint app 4.4 that can be found in the app store,. . . "

    All I can see online is 4.3.02 - please enlighten us.

    Best,

    John

    read more...
    0 70
  • New
    Jimharris
    Newcomer - Level 1
    2020-12-15

    Expression pedal for G system

    I am looking to add a expression pedal to my G system what specs do I need for it what brand or model expression pedal works with G system 

    0 9
Go to page