Statistics

289,923 members
172,497 posts
  • RGWINEDWARDS
    Newcomer - Level 1
    2020-07-10
    Trying to download new firmware so I can connect to my new DM8000. Website says the following (below) everytime i go to page (regardles s of whether i am logged in or not!!!!!!! Error 477 Suspended CDN resource Unfortunately, this CDN resource has been suspended. REALLY NEED to get this going today! Someone please help. my email is [email protected]
    read more...
    0 183
    • RGWINEDWARDS
      Paul_Vannatto I read in another thread that they have switched over to new servers for all of their websites and have run into some glitches. Yesterday I tried to get a file from the Turbosound iQ site and got the same error, unfortunately.
      • July 10, 2020
      • DM8000 firmware download not working
        RGWINEDWARDS Just heard the server change was 2 weeks ago!. My rep was just on a nationwide rep call and NO ONE in US has access to firmware at the moment. AND the Europe offices don't seem to answer any calls or support emails. I won't be using this product again.
        • July 13, 2020
      • DM8000 firmware download not working
        DavidBradshaw I just sent you a couple of emails with the firmware (and DM Designer software) attached
        • 2
        • ·
        • July 13, 2020
  • AhmadAk
    Newcomer - Level 1
    2020-07-10
    Hey there! Can anyone help me to know what is the last update for tc electronic system 6000 the black one not MKII?
    0 115
    • AhmadAk
      WilliamR The MKII Upgrade is recommended for all SYSTEM 6000 users as software release 5 will be the last for the original platform. System 6000 software, including system upgrades and new algorithms will only apply to SYSTEM 6000 MKII moving forward
      • July 16, 2020
    • AhmadAk
      WilliamR https://www.tcelectronic.com/tcelectronic/product?modelCode=P0CJW
      • July 16, 2020
  • calumduncan
    Newcomer - Level 1
    2020-07-09
    Hi there, I;m having an issue with my Ditto X4 whereby once I apply any effects to a loop, a unpleasant digital whining noise is added to the loop and can't be gotten rid of. This is particularly a problem when applying the Half & Double speed settings and is extremely difficult when it comes to recording. I was wondering if this is something that might be fixed by a firmware update or if this is something you have encountered before? Many thanks, Calum
    read more...
    0 132
    • calumduncan
      WilliamR Hello Calum, Usually issues like this can be resolved by reinstalling the firmware. I've attached a photo with instructions on how to do this so that it's a little easier to read.
      • July 9, 2020
    • calumduncan
      WilliamR Here's the link to the firmware file. https://www.tcelectronic.com/tcelectronic/product?modelCode=P0DE9
      • July 9, 2020
    • calumduncan
      TC-Mike Hi Callum,before reinstalling firmware , you can also try a factory reset to clear the memory by holding the left footswitch for 13 seconds until you see the LED blink. this might do the trick, but since it is the processing and not the playback of the recorded Loop, it might be a different issue. Let us know, how it works out.
      • July 9, 2020
    • calumduncan
      calumduncan Thanks for the suggestions folks, unfortunately neither of these things seem to have fixed the problem. I might have another go at resinstalling the firmware just to be sure but it's not looking good...
      • July 17, 2020
    • calumduncan
      AlfonsoDeA Hello! I'm having the same problem with a -straigh out of the box- pedal and was wondering if you were able to fix this?
      • July 3, 2021
  • maceman
    Contributor - Level 2
    2020-07-08
    HI, I have had the first Flashback X4 for years on my pedalboard with a 300 mA, 9V connector (Voodoo pedal power), no problems. I dropped in the new Flashback2 X4 and it will not run properly. It sounds all crazy distorted and a hot mess. When I power the Flashback2 with the supplied 9V adapter it works well. So, what is the actual mA requirement for this Flashback2 X4? Is it more than the Gen1 X4? Is there something I'm missing here in my set-up? It seems odd that this pedal would now require more than the standard Voodoo would provide. Thanks.
    read more...
    0 71
    • maceman
      TC-Mike Allthough the Flashback 2 X4 has 4 times the DSP power of the old version it should run with 300mA according to manual. Are you using all outputs of your Pedal Power? You can also check the sticker on the FB2X4 PSU to see how much mA it delivers... i have a feeling that it might be considerably more and the manual could be wrong. i'll check it back in the office where i have a Fb2 x4 and pedal power digital
      • July 9, 2020
  • whydavewhy
    Newcomer - Level 1
    2020-07-08
    Can the VoiceLive Rack be used in a mixing board’s Effects Loop to double vocals on multiple channels? (So the mics would be in different channels of the board, with varied send amounts on each channel, going to the VoiceLive Rack. Then the Lead Mute would be turned OFF on the unit. (Or does that only affect the lead vocal when a mic is plugged in directly to the VoiceLive Rack?)
    read more...
    0 143
    • whydavewhy
      kiskadar69 Would only the Double effect be turned on in the VoiceLive Rack? I think it would work. Lead Mute should be turned On.
      • July 9, 2020
    • whydavewhy
      Francois43912 I would love to learn if it is possible to get an inbound stereo signal into that loop?
      • July 23, 2020
    • whydavewhy
      kiskadar69 @Paul Francois: IMO it isn't possible. The mixers first mix the stereo channels into mono and send them to the mixer's Aux output. The TC-Helicon VoiceLive Rack also has a mono input.
      • July 24, 2020
  • DobaCaesar
    Newcomer - Level 1
    2020-07-07
    Hello
    0 55
    • DobaCaesar
      leah Hey DobaCaesar - What questions do you have about the VoiceLive 3 Extreme?
      • July 8, 2020
      • I need help with my VL3X
        DobaCaesar Yes I have the VoiceLive 3 Extreme.
        • July 18, 2020
    • DobaCaesar
      DobaCaesar Thanks! I figured it out
      • July 8, 2020
    • DobaCaesar
      DobaCaesar Hello Leah! I want to know if there is a new update for the VL3X? Because on the manual I saw on the preset number 10 is amazing grace but on mine is something else.Thanks for your help
      • July 17, 2020
  • BRymes
    Contributor - Level 2
    2020-07-07
    I'm learning to play Rage Against The Machine's "Killing In The Name Of", and I need to set up a phaser effect for the intro. I assume its in the uMOD parameters but I feel like I'm going in circles to attain a decent sound. Here's a link to Tom Marello discussing the intro part at 20:33. https://youtu.be/aJXzY9vhqZg I would appreciate any help that you can give me. Thank you.
    read more...
    0 107
  • soundmanstevo
    Newcomer - Level 2
    2020-07-07
    What is the best way to insert outboard processing equipment? I want to insert an outboard digital EQ & processor on my L, R, & S. Those outputs are feed via my digital snake out of my DL32. I found YouTube videos online but I am worried about not being able to feed my outputs via my digital snake. I am worried if I feed my outboard gear at FOH via the Aux In/outs I will not be able to send my L, R, S signal down the digital snake. On a normal console, I would just use the Insert connector located on the back of the console. Is it possible to use an insert cable out of the Aux Out port o the outboard gear?
    read more...
    0 151
    • soundmanstevo
      DanielPaine In short, Yes you can. You can use the Aux Jack sockets on the rear of the console. You can use a maximum of 6 Inserts. To assign, simply select the channel (i.e. Master), Then, in Home or config you can turn the insert on. In the config tab select the insert assignment (normal defaulted to internal effects). Scroll down to find Aux 1-6 and select accordingly. Stereo channels will map consecutively i.e. 1 = 1&2.
      • August 4, 2020
  • DennisDubeau
    Regular Contributor - Level 1
    2020-07-07
    Hello Craig? Whatever happened to your corner? Did they get you locked in China's behringer city?
    0 137
    • DennisDubeau
      Paul_Vannatto I heard that Craig is no longer with TC
      • July 7, 2020
      • I wonder is Craig is still alive and employee of TC Helicon... I know that Tom Lang is still active but Craig seems lost somewhere!!
        DennisDubeau That'd be sad... the guy knew the voicelive well...
        • July 7, 2020
      • I wonder is Craig is still alive and employee of TC Helicon... I know that Tom Lang is still active but Craig seems lost somewhere!!
        leah Hey Dennis! Craig wasn't the only one who knew the VoiceLive well! If you have any specific questions, let us know by creating a Care Ticket at the Support link above. Thanks!
        • July 8, 2020
  • AlexNL
    Contributor - Level 1
    2020-07-07
    Hi, Anyone using the DN735 solid state recorder. I can buy one but i am curious if it can operate without a timecode, just as a simple sample? Plz let me know. regards, Alex
    0 172
    • AlexNL
      Nigel67 Hi Alex, I am unable to get on to our server at the moment to access the operators manual. As soon as I can(hopefully in the morning) I will get an answer to you.
      • July 8, 2020
Go to page