Statistics

290,109 members
172,703 posts
  • Vkpiii
    Contributor - Level 1
    2020-06-06

    Hi, 

     I'm having trouble uploading the new firmware upgrade into my plethora x5. Any help on the matter would be appreciated. 

    1 618
    • Vkpiii
      NolaBass I need help with this as well!
      • June 13, 2020
    • Vkpiii
      Nigel67 Hi, have you both managed to upgrade your Plethora X5 firmware or are you still having issues. If you could tell me where you get to using the upgrade instructions and I will be able to help you further. It may also be easier if you submitted support tickets using the tab at the top of the page, but I will leave this option to yourselves.
      • June 23, 2020
      • Plethora x5 firmware update trouble shooting
        NolaBass I have downloaded the latest firmware for my Plethora but it will not open on my Mac. I have the Macbook Air with the 10.15.5 Catalina OS. I click on the zip file and it just makes a copy. I was really hoping to have the updated version that includes a tuner and several others. Further later this year, I'm hoping to have the next update to include the looper. I'm enjoying the pedal but very discouraged about the firmware not unzipping and install. I hope I don't have to return it and look elsewhere. I followed the instructions exactlly but it did not update when I dragged the zip file to the Plethora. Very frustrated.
        • July 6, 2020
      • Plethora x5 firmware update trouble shooting
        Nigel67 Hi NolaBass, I am not sure where in the instructions you are reading about unzipping a file? You should have downloaded a .bin file (version 1.1.52) which you drag and drop. If you go to this link https://mediadl.musictribe.com/download/software/tcelectronic/Plethora%20X5%201.1.52%20firmware%20release%20notes.docx then the upgrade instructions will be downloaded for you. They are also on the TC Electronic website.
        • July 6, 2020
      • Plethora x5 firmware update trouble shooting
        NolaBass Whenever I download it a warning comes up saying"It cannot expand Plethora It is an unsupported format"
        • July 9, 2020
      • Plethora x5 firmware update trouble shooting
        Nigel67 When you download the word document in my link? Is that when you get the warning? Can you write down the exact process that you are using to upgrade your Plethora, or probably the easiest way would be for you to submit a ticket using the support tab above and then attach a short video or pictures of what you are doing when trying to upgrade the unit which I can then look at. Let me know the case number and I will pick it up.
        • July 9, 2020
      • Plethora x5 firmware update trouble shooting
        Nigel67 This is what is in the link. Sorry, should have thought about copying and pasting before
        Plethora X5 1.1.52 firmware update release notes

        Dear customer,
        the new 1.1.52 firmware version adds Midi CC control options for PLETHORA’s 5 footswitches
        What’s new?
        The foot switches of your Plethora can now be remote controlled via Midi using CCs 102 (slot1) to 106 (slot 5)

        Midi CCs 102- 106 toggle the foot switches: <64 OFF >64 ON [Bypass ON = dry signal/ FX OFF - Bypass OFF = FX ON]



        Improvements/bug fixes :
        • Tuner not working on empty board in true bypass mode - fixed
        • Protect board load if a Toneprint is corrupt
        • Toneprint audition data gets cleaned on startup
        • Ensure correct formatting on USB disk
        • Ensure BT operation after reset/restart
        • Ensure mobile app connection is possible after reset/restart




        How to update your Plethora firmware to version 1.1.52?

        To update your Plethora to the latest firmware, just download the “plethoraX5_1_1_52.bin” firmware file and drag and drop it your explorer/finder’s PLETHORAX5 icon that will appear once you connected your pedal via USB to your computer.

        Now disconnect the USB cable and power cycle your device for the firmware to be uploaded.
        Wait until the procedure has finished and the pedal has rebooted.

        Congratulations your Plethora is now updated to the latest firmware.

        You can check the firmware version in your PX5 under SETTINGS/GLOBAL/SERVICE/FIRMWARE
        • July 9, 2020
    • Vkpiii
      NolaBass Whenever I download it a warning comes up saying"It cannot expand Plethora It is an unsupported format"
      • July 9, 2020
    • Vkpiii
      Soarkplug36

      I have just purchased 9ne and dragged and dropped the new firmware but its not updating getting really frustrated

      • September 25, 2021
    • Vkpiii
      Acevictor

      I got my Plethora yesterday. Build 1.1.55. I tried installing 1.2.18.bin on my Macbook 10.12.6. After dropping the .bin file on the device and ejecting, unplugging USB and power cycling the Plethora, it doesn't update. I tried restarting the Mac, emptying the trash and its no go. Am I missing something?

      • October 30, 2021
  • SteveSalamone
    Contributor - Level 2
    2020-06-04
    0 76
    • SteveSalamone
      SteveSalamone

      I need some help with a basic setup. I have not used my Voice Live 3 in a long time. All I want to do is hook up my Korg Keyboard's midi's output to the VL3 Midi in. Use a footpedal to turn the harmony one above to turn on when I press it. For some reason I can not get the VL3 to follow my Keyboard chords. I am not sure what I am doing wrong.


      Would someone please walk me through a simple preset and what changes I need to make to the VL3 to make this work?


      Thank you in advance.

      • June 4, 2020
  • ILYICH
    Contributor - Level 1
    2020-06-01

    Hello dear all, 

    I am looking for the ways to separate dry and wet microphone signals on VL3X in order to have only-wet and only-dry signals coming out separately. I also wonder whether one could do it via the expression pedal? Basically have a dry signal and add all the effects into the mix via expression pedal.

    Also I know one can separate dry and wet signals via mono, yet I still hear the dry sound of my voice in the Right/Effects channel. Are these the remains of what is not being covered by the effects? Even on the hard-tune-harmonizer I still hear the base sound of my voice though...

    Curious whether there is something one could do?

    Many thanks in advance!

    ILYICH

    read more...
    0 151
  • dubbeljoe
    Newcomer - Level 2
    2020-05-27

    Hi all,

    I just got a TCE M350 dual effect processor and it is lovely.

    Only problem I have is the software.

    How do I get a serial number for this free downloadable software?

    And why can I download it from the TCE website and there is no instruction how to get it working?

    Any ideas?

    thanks,

    William

    read more...
    1 131
  • B_Villa
    Contributor - Level 2
    2020-05-25

    The Behringer Xenyx 302 USB Mixer only supplies 15V instead of 48V of phantom power. Would that be enough to power the Mic Booster CT1? 

    0 139
  • Raato666
    Contributor - Level 1
    2020-05-21

    Need Help

    First, can't update  DN32-WSG firmware true Soungrid studio. In Multirack it finds soundgrid as a audio device and I can choose channels put audio does not go trough. In mixer routing is in Card, local and in input it is Card. Console have a latest firmaware. All the waves apps are updated.

     

    Screenshot 2020-05-18 at 14.13.48.png
    read more...
    0 495
    • Raato666
      Nigel67

      Hi @Raato666 ,


      Please could you advise how you are connecting to the DN32-WSG from your MAC?  What is the OS version.  Looking at your picture, it appears that you are using a USB device possibly.  Maybe a USB to LAN Port converter?  Did you run Waves Central and install and activate, and then Soundgrid Studio which installs the latest software.  Can you take a look at the excellent video below as see if you have missed a step.  It also shows how to patch the X32.  What are the LEDs doing around the RJ45 connector on the card.  They should be lit or flashing.  Do you have a Windows computer by any chance or an older MAC with a lan pot built in that you can test the set up?  In the top right hand corner of the X32, where it shows devices connected, are there two small green boxes one above the other.  The top box showing that the clock is good and the bottom showing the waves connection is good?  If neither of those are green then you have a connection issue. Unfortunately if it is a problem with computer / software set up, then you will need to contact Waves Support.  Did you also put in a support ticket to us as I answered a very similar question earlier this morning?


      https://www.youtube.com/watch?v=HXsU-4BRadU&t=245s


      There are also a number of other videos by the same person regarding the waves card which may be worth taking a look at as they also include how to patch audio.

      • May 21, 2020
    • Raato666
      Raato666

      Hi Nigel67



       


      I did everything what video say until updating that card


       


      I use usb-lan adapter, it’s a brand new and support 1Gb speed. Cable is 3m cat6.


       


      Heres ome images that I tookScreenshot 2020-05-18 at 14.11.52.pngScreenshot 2020-05-18 at 14.12.13.pngScreenshot 2020-05-18 at 14.13.31.pngScreenshot 2020-05-18 at 14.13.40.pngScreenshot 2020-05-18 at 14.13.48.pngScreenshot 2020-05-22 at 14.23.44.pngScreenshot 2020-05-29 at 16.01.59.pngScreenshot 2020-05-29 at 16.04.50.pngScreenshot 2020-06-04 at 14.22.09.pngScreenshot 2020-06-04 at 14.26.14.pngScreenshot 2020-06-04 at 14.48.08.png
      • June 3, 2020
    • Raato666
      Raato666

      I activate card on web site but in Waves Central, my product it doesn’t show. I have installed it to my MacBook.


      And in waves central I search the card it shows installed not activated. In first time that I installed the  DN32-WSG card in waves central it didn’t give me a option to activate also. 
      • June 3, 2020
  • Maximilain
    Contributor - Level 1
    2020-05-19

    Hi! I need to get a new battery for my M2000.

    Can tc send me one?

    0 39
    • Maximilain
      TC-Claus

      Hi Maximilain,


      We can't send You one but this is the battery You need: Renata CR2032RV


      All the best and stay safe from


      Claus

      • May 19, 2020
  • jonhollis
    Contributor - Level 3
    2020-05-10

    Hi - so it looks like the user on the mac osx app is different to the one on my iphone and indeed the one on my ipad. isnt there a way to log in and have one user on all devices. there doesnt seem to be a way to log in. just a tab called user.....

    read more...
    1 91
  • bearaby
    Contributor - Level 3
    2020-05-07

    Can I connect the Perform V to my Allen & Heath mixer's Stereo input to add the Perform V as my effects processor for all mics instead of just one mic? The way I understand it, the Stereo Channel 4 on my mixer is designed to add an external effects processor into my effects channel for control; I guess you could have the mixer internal and external effects both being used. Is there some type of XLR output to Stereo channel cable that can do this?

    read more...
    0 57
  • AndrewHamilton
    Contributor - Level 1
    2020-04-22

    Ok, found this very strange. Just got my TC Helicon Acoustic Play and I LOVE it however I can very loudly hear myself pressing and off the pedals through I don't even know what. When I'm hitting my SPDNE Kick I can the sound of me kicking it through the helicon almost as much as I hear the stomp box itself. I think it might be coming through both the guitar and the microphone. As you can see in my set up it's not close to where I hit the pedals or anything, or I didn't think it was anyways but maybe that is it. 

    Has anyone ever had any issues like this themselves?

     

    Thanks 

    read more...
    0 107
    • AndrewHamilton
      AndrewHamilton

      So unfortunately I've singled it out and it seems to be a problem with the Guitar DI box within the Acoustic Play pedal. I'm just wondering has anyone ever experienced anything like this with this pedal or even any other pedal before??


      Thanks.

      • April 22, 2020
Go to page