290,109 members
172,703 posts
  • New
    Newcomer - Level 1

    When restarting my DAW audio project the plugin LM2N is loaded but always with the Right channel selected. I use the plug in with a right channel displayed and in the next slot with a left channel displayed. Please update the plugin so the chosen channelsetting keeps as set on saving.

    0 88
  • New
    Newcomer - Level 1


    I would like to ask about Clarity M Stereo's compatibility with macOS 10.7.5. I cannot install the latest software and I think the problem is that the latest software is not compatible with an old version of macOS).

    Is there any way to download the old version of the ‘Clarity M Stereo Plug-in macOS Mac’ like 1.0.x which is compatible with macOS 10.7(Lion)?



    0 118
    • JMJMJM
      PedroRodrigues Hi JMJMJM please consider that you are referring to a OSX released in 2011 so I would not advise your to interface the unit is that OSX version and use at least version macOS 10.13 High Sierra. Thank you
      • March 16, 2021
  • New
    Newcomer - Level 1

    Hello there,

    The headphone jack [ upper/switching ] is broken. Could you please help me locate the correct part so my technician can have it installed.

    Link to a site selling the part would be appreciated. Ideally I'd like to order directly from your parts department.

    From a picture [ ]   it looks like this is a double stacked (2units) stereo, switching, through hole ,1/4" jack

    Your prompt help would be much appreciated.


    Le Mix Production
    Professional Audio Services
    [email protected]
    Andrew St.George_416 503 3350


    0 105
    • lemix
      RexBeckett Hi, you can request parts by raising a Care ticket.

      At the top of this page, click Support then scroll down the new page and select Parts. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • February 7, 2021
    • lemix
      PedroRodrigues Hi lemix sorry I just came cross your case , please consider that this unit is discontinued for some time now and we do not have much parts available might also be useful to contact our partners for any faulty unit they might have and you will be able to extract some useful parts.
      • February 24, 2021
  • New
    Newcomer - Level 1

    I have a brand new out of the box unit that will not boot past the "clarity m" logo. Everything is still boxed from factory... I am beyond disappointed. Is there any hard resets? Or anything I can try on my end? Or a hardware repair? What's the warranty on these things? :(

    0 143
    • Wellroundedproductions
      Nigel67 Hi, i am sorry to hear that you are experiencing issues on your product straight out of the box. If it is still under 30 days old, then I would advise contacting the shop that you purchased the unit from and ask for DOA replacement. If it is over 30 days old, then please click on the support tab at the top of the page. In the new page that opens, scroll down and click on the Service tab and submit a ticket. I would not advise opening the unit in any way as this will void your warranty. Have you tried connecting the unit to a computer and seeing if you can upgrade the software? Please check this link for upgrading. There are also instructions in the user manual.
      • February 1, 2021
      • “Clarity M Stereo”
        Wellroundedproductions Unfortunately it won’t boot to the point where I can put it in usb mode. Yes this is a bran new item. Unfortunately it sat in the box unopened for more than 30 days really bummed. I submitted a ticket but this suckssss
        • 1
        • ·
        • February 2, 2021
      • “Clarity M Stereo”
        Nigel67 I can only apologise again. One of my colleagues will take care of the repair details for you. This is definitely not to the standards that we strive to meet.
        • February 2, 2021
    • Wellroundedproductions
      GoosesGaggle123 i am having the same issue, any advice?
      • April 8, 2021
  • New
    Newcomer - Level 1

    Where can I find presets and installers for my Clarity M? Are there any recent updates like a Netflix preset?

    I vaguely remember an option to get additional presets but I cannot find anything online and anything out there is well over 2 years old.

    With the loudness war coming back around again as we mix music for streaming and film for Netflix a lot of us Clarity users are praying for new presets while we use the current metering plugins that are all up to date. I hope TC doesnt forget us.

    0 97
    • derekbrin
      PedroRodrigues Hi, derekbrin they can be downloaded from the product page on
      Please note that Factory presets 1-5, which normally cannot be altered from Clarity M but can be edited, moved or deleted when connected to a computer.
      • January 27, 2021
  • New
    Newcomer - Level 1


    Having some trouble making this work.

    Clarity M >>>stock cable d sub fanout #1 cable to BNC to XLR adapter (as stated in manual)>>>connected to 1. mackie dl32r AES out, and 2. Aphex Compellor AES out. Signal present at outputs but not apparent at Clarity meter. (I have not confirmed signal is at the AES output but assume it would be on both devices)

    I see metering at about 20-30db less than expected. (It may be just noise? I do not have a way to monitor the AES outputs of the mackie and compellor) Peaks around -35db. Although Im running a -12LUFS signal out the analog outputs of both devices. (mackie and compellor)

    > On the mackie I was not able to get lock when I adjusted input to AES1 on the clarity. Never locked.

    > on the Compellor, lock didnt happen for a while, although I was new to connecting to AES and it may have been user error in selecting AES1 in the sys prefs.)

    I am using the adapter stated in the manual. I am using the stock fan out cable. Nothing else is connected other than power to the clarity. I have used this unit with Optical sp/dif and toslink with success. (analog RCA to AD converter to clarity). I have also tried AES out of a x32 without success. Pls comment if you have ANY troubleshooting ideas!!! Thank you!!!!!!

    Any help apreciated!!!


    Brad P

    thank you!

    0 206
    • bradp015
      PedroRodrigues Hi Brad have you tried specific AES 50 cables on the case of the Mackie as the AES50 is transmitter at higher frequencies than the one supported via a XLR cable? Are you using the Neutrik NA2FBNC adapter to bridge the BNC connection with XLR connection present on the Sub D cable? Have you selected the digital input source for AES on the Clarity M?
      • January 15, 2021
    • bradp015
      bradp015 -- I'm using the cable provided by TC electronics.
      -- I am using the Neutrik adapter to bridge the BNC connection with XLR connection present on the D sub cable That is provided in the clarity box. The fan out cable.
      -- I have selected the AES one, AES two, AES three, and optical choices on the clarity.
      Thank you for your ideas
      • January 15, 2021
    • bradp015
      bradp015 Any other things you think I might try???
      • January 16, 2021
      • Clarity M running in stereo via AES XLR adapter connector not working
        PedroRodrigues Hi bradp015 can you confirm that when you select the digital input, you are selecting the correct channels? The options are AES 1, 2, 3, 1-3 (5.1 surround).
        • January 18, 2021
    • bradp015
      bradp015 thank you Pedro!!!
      When i select the dig channels i can see on the display AES1, AES2,AES3 etc....
      How long does it take for the clarity to lock to the digital input?
      Does it auto select the sample rate/bit depth?
      The manual isnt very specific about it all..
      thank you for your help!!!
      • January 18, 2021
      • Clarity M running in stereo via AES XLR adapter connector not working
        PedroRodrigues It should not take long to lock on to the input signal. Can you please provide details on the signal inputting on the Clarity M? Thank you
        • January 19, 2021
    • bradp015
      bradp015 The device is a Aphex Compellor with AES out. The XLR to BNC adapter to the tc elec included cable assembly fan out with D sub is connected to the clarity. Signal is a commercial song playing thru the mackie dl32R going to the compellor. The analog outs of the comopellor is routed to a tricaster video switcher.
      • January 19, 2021
      • Clarity M running in stereo via AES XLR adapter connector not working
        PedroRodrigues Hi bradp015 can you confirm if the signal outputting form the tricaster is AES3?
        • January 20, 2021
  • New
    Newcomer - Level 1

    Dear TC Electronic Team, 

    I' recently bought the clarity m stereo and I really like it so far. Nevertheless the spectrum analyzer is too compressed in my opinion. For me, the spectrum is the the most important tool in production/mixing phase. Is there any consideration for an future update on "optional" expanding of the analyzer? This would definetely fulfill my dream and I believe a lot of users or potential buyers would love this feature. Otherwise I'm gonna have to consider if I really need this device on long term. 

    Also a tilt setting for the spectrum analyzer and an optional RMS and crest factor readout would be amazing! 

    Best wishes Johannes 

    0 92
    • JohannesPla
      PedroRodrigues Hi Johannes, please be aware that any updates on the unit and the respective plug in is present on the products page that you can access by following the link below: Please also consider that regarding the RTA, this tool allows a individual band zoom that allows you to pinpoint exact frequencies allowing any frequencies to be easily identified and adjusted, I understand its not a full screen or even a more expanded view but still allows a detail working environment. In Regard to RMS and crest factor please consider that the Clarity M is a Loudness Meter and offers the most used Loudness meters, therefor when it comes to the RMS meters and the crest factor, these are based respectively on PEAK meters and RMS meters and are effectively outside the operating scope of the Clarity M, that is exclusively a Loudness Meter. Thank you
      • January 7, 2021
  • New
    Newcomer - Level 1

    Hello my Logic Pro X doesnt want to open because of Clarity M when I open it since I did the Big Sur update.
    All the other plugins are fine, this is the only plugin which doesn't work.
    I need to desintall it for Logic Pro X to open.
    Can you help ?


    1 360
    • Estebanmerlin
      KyleJohnson Hi Esteban, Kyle here with Music Tribe. First, make sure your Clarity M Plugin and Firmware are both fully updated. If you are still having issues, please contact us by submitting a Technical Support ticket through the Support link at the top of the page.
      • December 7, 2020
    • Estebanmerlin
      Oldman Привет! Столкнулся с такой же проблемой, в как точно описано все ( Не могу найти решение. Если оно уже есть, пожалуйста, сообщите, что делать? PS: Apple Apple Mac Pro (2013 2013 года), OS Big Sur.
      • January 2, 2021
      • Clarity M - Mac OS Big Sur
        KyleJohnson Hi Aleksei, please make sure that USB mode is set to "Plug in". Then please also confirm that you have updated your firmware and the plugin software to the most recent versions. If you are still experiencing problems please submit a case through the support link at the top of the page.
        • January 4, 2021
      • Clarity M - Mac OS Big Sur
        Oldman Hello Kyle!

        Unfortunately, the problem with the plugin was not solved (although almost 2 weeks were devoted to correspondence with technical support)... Plugin Clarity M still crushed Logic Pro 10.6.1. Again, if disabled and disconnected device Clarity M USB active as plug-in Clarity M in the project, the plugin does not allow to load the project and Logic Pro crashed. Mac Pro 2013 macOS Big Sur workstation. Before switching to the new OS, there were no problems with working via USB Mode: Plug-in. On the MacBook Pro 2019 Intel there are no problems and everything works fine (connect via USB-C HUB 3.0).

        And one more detail: the clarity_m_v2_0_1_mac.dmg installer does not deliver *. component,*. v stand *. vst3 files in their own directories.

        If someone on the forum faced such a problem, tell me in what direction to look for a solution?
        • January 14, 2021
      • Clarity M - Mac OS Big Sur
        Estebanmerlin Same problem !
        Can you please do something about it ??
        • January 29, 2021
    • Estebanmerlin
      Estebanmerlin Still nothing guys ?
      • January 29, 2021
      • Clarity M - Mac OS Big Sur
        KyleJohnson Hello, we have tested the Clarity M on multiple Big Sur machines without issue, so it is not an incompatibility problem. I have one sitting on my desk, right now, working with Big Sur on an iMac. If you are having issues, please submit a technical support ticket through the Support link at the top of the page. Always make sure you are on the latest firmware and plugin versions, and make sure you are connecting directly to a USB port on the computer, bypassing any hubs for best results.
        • January 29, 2021
    • Estebanmerlin
      syntaction Hello there!

      Unfortunately I have the same issue like the thread starter. Since MacOS Big Sur and Logic Pro 10.6 the Clarity-M Plugin crashes the DAW even on startup.

      My configuration is:
      Clarity-M Plugin: v2.0.1
      Clarity-M Firmware: v2.0.3
      Direct USB Connection
      USB Mode set to Plugin
      macOS Big Sur 11.2.1
      Intel Mac (i7, Late 2015, 32GB RAM)
      Logic Pro 10.6.1

      I noticed the following things when I tried to fix the problem (for example by reinstalling the Plugin etc.)

      - Crash also happens if Clarity-M is switched off, so the Plugin itself crashes. If you clear the AU Cache it also crashes when Logic tries to rescan the Plugin

      - If you reinstall the Plugin again it sometimes works again in the DAW but as soon you reboot your machine completely it crashes again

      - The VST2 Version of the Plugin seems to work (VST2 Host, so maybe a Logic/AU exclusive Problem?)

      - The Plugin has to be part of a project you open when you start logic to make it crash

      I really hope this helps you to reproduce the error and update the AU Plugin. I really love to use the device via Plugin because that saves me a complicated audio route and on my mobile setup it's also much more flexible via plugin.

      The setup worked by the way on the same computer with the same plugin environment on the previous macOS & Logic Pro version, so Big Sur or Logic 10.6 was the issue here I guess.

      When reinstalling the Plugin I also tried to remove it entirely first and cleaned the AU Cache, so there should not be an issue with maybe old or corrupted drivers (or better plugin files) here. It only does not crash Logic with a lot of luck then.

      - Chris

      PS: While I'm here I also have a little feature request: It would be really cool if you could integrate Clarity-M Support via Plugin Like Connection to the tc electronic Finalizer Software. Would really be a handy addition! :)
      • February 17, 2021
      • Clarity M - Mac OS Big Sur
        KyleJohnson Hello, Thank you for this report Chris. Can you please submit all of this information as a Technical Support case through the Support link at the top of the page?
        • 1
        • ·
        • February 17, 2021
      • Clarity M - Mac OS Big Sur
        syntaction Thank you for the fast reply, Kyle! No problem, I will submit the infos via the Support system.
        • February 17, 2021
    • Estebanmerlin
      jansolo Hello, I have the same problem… If the clarity M module is on off, Logic crash…: Process: Logic Pro X [3109]
      Path: /Applications/Logic Pro Pro X
      Version: 10.6.3 (5458)
      Build Info: MALogic-5458000000000000~3 (10U159)
      App Item ID: 634148309
      App External ID: 841990097
      Code Type: X86-64 (Native)
      Parent Process: ??? [1]
      Responsible: Logic Pro X [3109]
      User ID: 501

      PlugIn Path: /Library/Audio/Plug-Ins/Components/Clarity M.component/Contents/MacOS/Clarity M
      PlugIn Identifier: com.tcelectronic.audiounit.ClarityM
      PlugIn Version: 2.0.1 (63)

      Date/Time: 2021-08-17 10:40:09.738 +0200
      OS Version: macOS 11.2.3 (20D91)
      Report Version: 12
      Anonymous UUID: B0E040BE-12F8-6997-5CFD-32CD8527ECC3

      Time Awake Since Boot: 2400 seconds

      System Integrity Protection: enabled

      Crashed Thread: 111

      Exception Type: EXC_BAD_ACCESS (SIGSEGV)
      Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
      Exception Note: EXC_CORPSE_NOTIFY

      Termination Signal: Segmentation fault: 11
      Termination Reason: Namespace SIGNAL, Code 0xb
      Terminating Process: exc handler [3109]
      • August 17, 2021
  • SebastianRobertson
    Newcomer - Level 1

    Hello - My level pilot creates a lot of static when i turn it now. What product should I use to alleviate? 

    0 102
    • SebastianRobertson
      WilliamR Hello Sebastion, I would recommend taking it to a service technician and have them spray the potentiometer with some contact cleaner. This should clear up any build-up that may be causing the static when you physically turn the knob.
      • October 2, 2020
  • tomkeene
    Newcomer - Level 2

    where is a definitive xtouch-x touch compact logic manual/video/tutorial

    0 87
Go to page