Statistics

298,480 members
182,087 posts
  • New
    rickeyboards
    Newcomer - Level 1
    2022-09-20

    I get a load, high pitch squealing noise when I run the monitor signal from my JBL Eon One through any channel of my Behringer X18 mixer.  The monitor signal works fine through other analog mixers.  The squealing occurs with different power amps, different DIs and different cables.  I also get the squealing with the line-out from a Carvin bass amp.  Other line-outs work fine.  I have my my bus 6 signal routed to USB output for live streaming. 

    read more...
    0 1
    • rickeyboards
      NicJonesMT Hi RickeyBoards.
      Please click support at the top of the page and submit a technical support ticket.
      • Thu at 3:42 AM
  • New
    HazelMears
    Contributor - Level 1
    2022-09-04

    Hi, we use the XR18 connected into our Macbook Air for our livestream (into OBS) however the Mac has stopped recognising the XR18 as a sound input. Its listed as a device but doesn't show as active.

    I've changed cables, even tried it on a different Macbook which didn't even detect it as being there. We're currently on 1.18 for the firmware, could this be the issue?

    Has anyone else had this issue and/or does anywhere know where I can get the earlier firmware versions from? I have seen in other forums that the mac os stopped recognising the XR18 but they got it going using an earlier firmware. I'd rather not downgrade it but if that would get it working again I'll do it! Thanks.

    read more...
    0 4
    • HazelMears
      Nigel67 Hi HazelMears. This seems more hardware related than firmware. However, you can find older versions of firmware at this link - https://www.behringer.com/downloads.html. Select XR18 in the Product column and Software in the Type column. You will then need to tick the box labelled 'Show all Versions' and the older versions of firmware will appear. Have you tried a factory reset on the unit. This sometimes works.

      Any show / presets that you have on the unit will be deleted.  With the unit powered, locate the hole in the front panel by the access point logo.  There is a switch behind the hole.  Push something through the hole gently until you feel a click as the switch activates.  Hold the switch in for 12 seconds and when you release, the unit will reset.  Set up the connection again and see if you can connect back up to the USB port.

      If this does not work, I would suggest filling out a Technical Support ticket and we will be able to advise further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket.
      • Sep 5