Statistics

254,454 members
132,141 posts
  • New
    Midas
    Newcomer - Level 1
    2021-10-20

    HERITAGE-D Series
    bit.ly/Midas-HERITAGE-D-Series

    Live Digital Console Centres, Stage Boxes with Multiple Microphone Preamplifiers and Accessories
    The Midas HERITAGE-D Series Digital Mixers and I/O Interfaces are designed to serve our Tour Sound and Installed Sound Customers.

    From: $37,500

    #Midas #HD9624CCIP #HD9624CCTP #HERITAGEDSeries #Mixers #Digital

    read more...
    1 26
  • New
    andyp13
    Contributor - Level 3
    2021-10-04

    Have a sound problem with the DP48. My Dp48 would make my solo guitar sound like Im playing under water..I discovered that the problem is with the Compressor..once it was off the sound was OK, However my drummer now has the same problem but all compression etc is off? He has to turn the guitar off in his mix? Anyone else suffer from this problem?

     

    Sorry forgot to mention, if anyone can help please email me as I will probably never find this post again.

    [email protected]

    read more...
    0 6
  • New
    andyp13
    Contributor - Level 3
    2021-10-04

    Have a sound problem with the DP48. My Dp48 would make my solo guitar sound like Im playing under water..I discovered that the problem is with the Compressor..once it was off the sound was OK, However my drummer now has the same problem but all compression etc is off? He has to turn the guitar off in his mix? Anyone else suffer from this problem? 

    read more...
    0 2
  • aftermid
    Contributor - Level 2
    2021-10-02

    Hi Paul,

      Here's the attachment of the scene set up.  Let me know if that helps.


    View Attachment
    0 6
  • New
    Albertvinzenz01
    Newcomer - Level 1
    2021-10-12

     

    Hallo 

    Midas bootet nicht mehr hoch.

    Nach dem Einschalten gibt es eine Schleife. Hochfahren bis zu einem gewissen Punkt

    Dann wieder down - wieder hoch usw... Schleife.

     

    Wer kann helfen ?

     

    Albertvinzenz01

    read more...
    0 15
    • Albertvinzenz01
      KyleJohnson Hello, Kyle here with Music Tribe. It sounds like it could be a failure, please contact us directly by clicking on Support and then Care/Service.
      • Oct 12
  • New
    DeanRinehart
    Newcomer - Level 1
    2021-10-12

    This is a legacy product that's pretty hard to ship around for repairs...when will Midas support right to repair and release schematics?

    0 8
    • DeanRinehart
      Dale_M Thanks for your post this is not currently on offer to users however we do have Midas approved repair centres globally who have access to service information, if you need a non warranty repair please go to the Support tab above and select Service.
      • Oct 13
  • New
    avbarr
    Newcomer - Level 1
    2021-10-11

    Is it possible to order new jelly type buttons and replace old black ones on midas m32?

    I own midas m32 with old buttons (hard to see) and new Midas m32R Live with jelly buttons and I like them more.

    So it would be great if I could replace them..

     

    Thank you!

    read more...
    0 6
    • avbarr
      Nigel67 Hi avbarr. Yes, this shouldn't be a problem. Please contact the spares department and they will be able to advise you part numbers and pricing. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. Many thanks. Just a word of caution, if you are the first owner and purchased the console on or after 1st September 2014, then you have a 10 year warranty which will be voided if you open the console to fit the switch caps. It would have to be done at a local service centre to you to keep the warranty active. If you decide to go this route, then as well as a spares ticket, you will need to send in a Service Ticket so the Team can arrange the warranty service. Many thanks
      • Oct 11
  • New
    chadf9942
    Newcomer - Level 1
    2021-10-08

    I am looking for a pro 6 power supply. 
    one of mine isn't working

     

    0 6
    • chadf9942
      Nigel67 HI chadf9942. Is your Midas PRO6 still under warranty? Its 10 years from 1st Sept 2014 if you are the first owner. If so, please send in a Technical Support ticket and we will be able to help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. If the PRO6 is out of warranty, then you can purchase a new power supply through our Spares team.
      Please send in a spares request ticket. This can be done from the same page that the Technical Support ticket can be found, just select the Spare Parts tab instead. Many thanks
      • Oct 9
  • New
    Craig71
    Newcomer - Level 1
    2021-10-03

    G'day

    have an interesting issue with my M32R Live at church. Somehow the mixbuses have ended up patched to DCA 1&2 ,also the mixbuses 1 through to 4 which i use for my foldbacks are not controlling master volume on the bus and the only way to adjust mix volume through the mixbuses is individual channel level.All this has come to pass since we upgraded the snake to a DL 16,any thoughts?

    Cheers Craig

    read more...
    0 6
    • Craig71
      Paul_Vannatto Hi Craig, that sounds like a routing issue. The best way to troubleshoot it is to export your scene to a file using either the Utility button on the console or using M32-Edit. Then upload that file to the cloud (Google Drive, Dropbox, etc.) and post a shareable link. That way we can have a look at your setup and better advise.
      • Oct 3
    • Craig71
      Craig71

      Thanks Pal will do

      • Oct 4
    • Craig71
      Craig71 Hi Paul, everything is fairly well sorted now.It was a routing issue and I worked my way through the signal paths.Will be updating the desk to latest software also . thanks for the heads up on looking at routing.
      • Oct 9
  • New
    kylegbenson
    Newcomer - Level 1
    2021-09-28

    I'm currently getting inconsistent performance on a couple of inputs on the DL16 Stage Box. Specifically, the overall gain levels drastically vary from week to week as it's used primarly on Sundays at church. To clarify, the parameters themselves don't vary, but rather I encounter significantly decreased input signal. I've ruled out mics and cables..i.e. input 1 causes trouble so I move it to input 9 and it's fine. Do you think a firmware update will solve this problem? My m32 console is current.

    read more...
    0 8
Go to page