Statistics

227,993 members
102,796 posts
  • New
    GainBear
    Newcomer - Level 1
    2021-05-07

    As we all get ready to get back out and play, like everyone else I'm auditioning gear.

     

    I continue to be impressed with the X5, but really guys it needs a real EQ functionality if it's going to compete with the Line6 products.

     

    Something parametric like the Earthquaker Devices Tonejob is fine.  It doesn't need to be too sophisticated. Just something to sculpt a little bit at the pedal board vs. messing around with the back line.

     

    I know you hear this all the time, but just my 2 cents.

     

    Thanks for listening.

    read more...
    0 0
  • TC Electronic
    Triber Moderator
    2021-05-07

    
Classic High Gain Distortion Pedal with Fat Mids, Treble Filter Control and 3 Clipping Modes
     
    

List Price: $59


     
    #TCElectronic #MAGUSPRO #GuitarLove #GuitarGear #Pedals
    read more...
    0 2
  • New
    TC Electronic
    Triber Moderator
    2021-04-23
     
     
    Your perfect beach buddy. Designed around superb studio-grade algorithms, SKYSURFER MINI REVERB provides all the lush, transparent reverb sounds you could ever dream of – without compromising your original tone.
     
    List Price: $39

    #TCElectronic #SKYSURFERMINIREVERB #GuitarLove #Knowyourtone #GuitarGear #Pedals #ToneHeaven
    read more...
    2 11
  • New
    Olags91
    Newcomer - Level 1
    2021-05-07

    So, I recently bought the quintessence second hand and thought it was reallt great. Everything worked exactly as it should. Then one day suddenly it started giving the wrong harmonies. For example when I put it in aeolian mode with a 3rd up it gives me a major third from the root instead of a minor. Also with a 5th up I can clearly hear that something is not right according to the scale I've chosen. There are anomalies on all the modes and all the scales. I have tried updating the firmware but with no luck. I tried taking it out of the pedal chain and running it separately from Everything. No luck. Does anyone know what might be the issue here or if it's possible to restore factory settings to see if that fixes the problem? 

    read more...
    0 1
    • Olags91
      NicJonesMT Hi Olags.
      I think your best option would be to open a tech support ticket. We can then go through some trouble shooting with you to try and find the cause.
      If you click support at the top and scroll down you can then submit a ticket.
      • Fri at 5:13 AM
  • New
    dankerschen
    Newcomer - Level 1
    2021-05-06

    Hello! 

    I'm really happy with my ditto+ but would like to reset it to factory defaults. Could you please provide instructions?

    Alternatively could you tell my where to fund the complete manual, not the quickstart manual?

    Thanks 

    read more...
    0 3
  • New
    calumduncan
    Newcomer - Level 1
    2021-05-05

    Hi there,

    I've been using a Ditto X4 extensively live and in the studio for 4 or 5 years now, but unfortunately over the last couple of years I've been struggling with digital noise being added to loops that can't be removed. I tried updating the firmware last year, as well as doing a factory reset, but unfortunately it didn't fix the problem.

    It's now got to the point where I need to replace the unit as the noise really interferes with my practise. Ultimately, I would love to buy another X4 as I love the functionality of the pedal and I find it a really creative tool. However, having encountered such a wealth of similar issues with other users online, it's hard not to be nervous about getting another one.

    I was wondering if these problems are something that you guys have managed to fix in recent times with firmware updates or if these bugs are still a common occurence? 

    As I say, I love this pedal and would really like to continue using it.

    Many thanks,

    Calum

    read more...
    0 4
  • New
    pierreayel
    Newcomer - Level 1
    2021-05-02

    Hi all,

    i just purchased a Plethora for my bass, I tried it in a drop D tuning and it seems the tuner on the plethora does not recognise the D# on the E string (starts working on the E note).

    is it normal or is there a setting to change ?

    read more...
    0 5
    • pierreayel
      Dale_M The tuner in Plethora is optimized for efficient DSP use and guitars + doesn't cover full piano range like PolyTune, so this is expected behavior. As a workaround you can tune your lowest bass string 1 octave up the fretboard
      • Tue at 11:33 PM
  • New
    Bliggick
    Newcomer - Level 1
    2021-05-02

    When I read the manual that was included with my new TU300 Chromatic Tuner it seemed to be missing page 2 which would have included the "Operations" chapter that would explain how the Mode and Stream/Cent buttons work. So when I looked on the official Behringer web site the .pdf file for the manual has the same missing content. After searching with Google I finally found a complete manual that looked different graphically like it was the old TU100 manual ported over but I finally learned how to use those buttons properly. Come on, Behringer, get it together. 

    read more...
    0 5
    • Bliggick
      ChrisEdwards1 Hi Bliggick, we are sorry for any inconvenience this may have caused but thank you for bringing this to our attention. I will look into this further and have the manual ammended.
      • May 1
  • New
    jaslan
    Contributor - Level 2
    2021-05-01

    Hi,

    I am not sure where to post requests for pedals to be added to the Plethora X5.

    I would really like the Spark booster in there.  I realize it is not a Toneprint pedal and maybe not even a digital pedal but it is a great booster and would make a great addition to the plethora.

     

    read more...
    0 6
  • New
    deltron0
    Newcomer - Level 1
    2021-05-01

    Hey!

    I really enjoy the "Tape" built in setting on my Flashback II. The Mash control is crazy!

    Is it possible to download the same setting on my flashback II mini? I found a setting called "TC electronic Tape" on the editor, but the mash function is totally different!

    I don't understand very well how the mash settings are working on the editor. Could you please help me?

    Thanks

     

    read more...
    0 6
Go to page