Statistics

241,170 members
117,421 posts
  • New
    marvinholdman
    Contributor - Level 1
    2021-07-26

    I have one of the first TC Helicon Play Acoustic you could get in the USA. So new, in fact, they didn't even label the buttons correctly! That said, it hit the ground running with me and has made this working musician thousands of dollars. I've loved it's simplicity (I ditchted the mixing board for it!). I don't use nearly all the features. In fact, I only use it to route and sweeten me and my guitar. It has been a workhorse and has never let me down. Lately though, towards the end of the night, I swear it starts adding a bit of far off background vocals to the signal. At first, I thought it was patrons singing along, then I notice no one is singing. I've had a few folks ask me about it and frankly I am a bit puzzled. See, I don't use any of the harmony capabilities of this unit. Just straight up guitar, with some body rez and a little reverb on the voice. That is all. So... I wondered if anyone else has ever noticed any mysterious "voices" in the output of their Acoustic Play? It is very subtle. Just enough to make me question my sanity. Anyone?

    read more...
    0 0
  • New
    BHShooter1
    Newcomer - Level 1
    2021-07-02

    I bought a TC Helicon Harmony G-XT a few months ago.  During my last recording sessions it worked fine.  After writing new songs to record I hooked up the rig and now signal from the microhone to the mixer.  I thought it might be the guitar needed to be hooked up to activate the mic.  The guitar plays through to the mixer, but still no mic. 

     

    Is there some setting that I am missing that is keeping the mic from working?  Does the mic input just stop working?  I have replaced both XLR cables with new ones and still no signal to the mixer.  What am I missing?

    read more...
    0 19
    • BHShooter1
      NicJonesMT Hi BHShooter1.
      Sorry to hear you are having issues.
      I think the best option would be to submit a tech support ticket and a member of the team will be able to advise you further.
      If you could provide the following information in your Ticket it would help to Speed things along.

      • Can you please detail any other devices that are being used in conjunction and exactly how these are connected to your device? This includes Microphones, Mixers, Computers ETC.
      • Can you please detail how parameters on the device are set?
      • What firmware are you using and have you tried reflashing?
      • Have you tested the device using an alternative audio source?
      • Do you have access to alternative cables?
      • Have you tested the device with an alternative power source?
      • Can you confirm the specifications of the power cable you are using?
      • Are any LED’s or lights on the device lit up or behaving erratically?
      • Do you have a similar device that you can compare the behaviours of?
      • Can you please provide me with a detailed description of how the device is behaving and any other trouble shooting steps that you have undertaken?
      • Is the Issue Intermittent or constant? If it is intermittent is there a specific setting that needs to be used to cause the issue?
      • Jul 3
  • New
    SCDamon
    Newcomer - Level 1
    2021-06-29

    I desperately need to turn global key off. I have cycled through the setup menu without finding it. My first day with this unit, all presets are locked on C major. Help!

    0 22