Statistics

294,766 members
177,895 posts
  • New
    Antoinedanse123
    Newcomer - Level 1
    2021-11-12

     

    Hello

     

    I am taking the time to write to you here, as it is not clear on your website where to send my problem to.I try everywhere 

     

    I introduce myself, Antoine Caron, technical director of La Maison pour la Danse de Québec. We are an organization that supports professional contemporary dance artists by providing studios and creative boxes in the dance community.

     

    When building the place, I decided to choose TurboSound Brand to equip all of our workspaces. I chose your brand for its reputation and the fact that models chosen would allow me to do acoustic control right out of the speaker, such as equalization,compression and limiting. At the time of purchase, the products had a 10-year warranty.

     

    To do this I made the purchase on March 30, 2017 of:

    12- NuQ102-an wh

    4- Nuq102-an

    8- IQ10

    4- IQ12

    2- IQ18b

     

    From January 2019, I started having problems with my NUQ102, 12 saw their amplifier fell out of function, I had to send them back to your Canadian distributor Intellimix, it took several months to have a complete repair of my speakers without having any replacement speaker during repairs. It is now September 2021 and here I have another 9 NUQ102-an speakers that are or need to be returned for repair. For this new shipment for repair, Intellimix started by telling me that it was no longer guaranteed and that the speakers had 3 years of warranty, I had to demonstrate using a screenshot of your website and PDF data sheet taken when purchasing that the products were guaranteed for 10 years. Moreover, shortly after the website was modified to no longer indicate the 10 year warranty on the products, which is a bit odd. My products have been under repair for almost 3 months now and I have no scheduled repair date and no replacement, let's say my confidence is taking a hit.

     

    Intellimix, asked me to check several aspects on my site and I even had an electrician come to check, but be aware that the building is new since 2017 and that all audio equipment has its own electrical network with isolated ground and everything is in order according to this professional.

     

    So I question the quality of the NUQ102 product! During all this time, none of my IQ10-IQ12-IQ18b products failed, yet subject to the same conditions as NUQ products. I see on the site that the NUQ 102 products are discontinued, but not the IQ products. I also notice that on the warranty pages for the NUQ102 product, the 10 year warranty legal notices have strangely disappeared and that I have to fight to honor a warranty that was present at my purchase.

     

    I am requesting feedback from TurboSound to find a solution to my problem and act as a responsible company for a product (NUQ102) that does not live up to our expectations. Intellimix will surely fix my speakers again, but how long will it last? Should I be fighting again in 18 @ 24 months to claim my warranty again when the same problem occurs again? Should I still deprive the La Maison pour la danse creative spaces of their sound quality by losing my speakers for months?

     

    Please contact me and take the time to analyze my problem and ideally find a solution.

     

    Thank you

    Antoine Caron

    [email protected]

    1-418-265-5826

    read more...
    1 9
    • Antoinedanse123
      Nigel67 Hi Antoinedanse123. I am sorry to hear of the various issues you have been experiencing with your Turbosound speakers. I see that you have submitted a Service Ticket on Case CAS-502131-W3P8G4 so I will let the Service Team reply to you from there.
      • November 14, 2021
  • New
    daEa
    Newcomer - Level 1
    2021-11-07

    Hello everybody, A little about myself.. I’m a working musician, my bread & butter is on the road. I have a studio with drum room 

    control room. Have some decent microphones/ outboard gear. I run PT w/ Universal Audio for my I/O’s tons of guitars, drums, basses etc.

    Hope this is the right place to post this question:

     

     

    I finally got my 2600 and having lots of fun with it. Vary happy. I hooked up the midi and was on my way. 

    I have a Moog Mother 32 and a Arturia Microbrute and really want to start using the sequencer in both pieces of gear.

    I know with the Arturia it has something to do with patching gate out into the sampler & hold clock & the pitch out. 

    I have not been successful with running the sequencer on my Arturia or may Mother 32.. Was thinking it might be the drop pins 

    on the back of my 2600 or firmware that needs to be installed.  Any help would be received gratefully.

     

    read more...
    0 6
  • New
    djandyaustin
    Newcomer - Level 1
    2021-10-28

    Hello,

     

    This amp has four separate inputs on the back; does any one know if you only use Input 1 if it will be be the same music for all four inputs?

    0 17
  • New
    olejazzer
    Newcomer - Level 1
    2021-10-21

    I've tried several links to reload this package on my VLX3 but they have all exprired. Is there a current one that someone it wiling to share. Thanks. This is a great product. I'm enjoying it a lot. I'm fond of single boxes that do a lot. 

    0 13
  • New
    Emorgadoj
    Newcomer - Level 1
    2021-10-15

    Can I get any replacement for this sub?

     

    0 7
    • Emorgadoj
      KyleJohnson Hello, Kyle here with Music Tribe. For spare parts inquiries please click on Support and then Spare Parts to submit a ticket.
      • October 17, 2021
  • New
    adamharkin1
    Newcomer - Level 1
    2021-09-20

    hi

    i need a RMA number for ampman to carry out a warrenty reopair to a lab gruppen amp.

    how do i get one of these?

    Brand: Lab.gruppen
    Model: c28 4
    Serial: 00373799 V24/14

    0 22
    • adamharkin1
      KyleJohnson Hello, Kyle here with Music tribe. Please click on Support and then on Service to submit a service request for an RMA.
      • September 20, 2021
  • New
    Phlex
    Newcomer - Level 1
    2021-09-12

    At work we have a full size 32 channel X32 and when I am moblie I use my X32 rack along with an SD16 so I can untilize the full 32 channels- My question is- Is it possible to import scenes from the Fullsize X32 to my Rack- I have tried it to imported from X32 fullsize  to X32 Rack but does not read my stored scenes on my flashdrive when incerted on my x32 Rack...

    read more...
    0 79
    • Phlex
      KyleJohnson Hello, Kyle here with Music Tribe. You can transfer scenes between any X32/M32 models. Make sure they are on the same firmware version and that you are using a Fat32 formatted 32GB USB stick.
      • September 12, 2021
    • Phlex
      Phlex

      • September 12, 2021
    • Phlex
      Phlex

      Yes Thank you-- This is what I did to have the file transferred- I took my USB and transferred the file to my pc than to another USB and it worked- guessing the USB was not formatted- Thank You

      • September 12, 2021
  • New
    MCCAZ
    Newcomer - Level 1
    2021-08-12

    Hello.  Got a Behringer X-DANTE 32-Channel AD Expansion Card for the X32 Producer and in addition to this, got the Dante Controller configured with X32 Producer.  Transmitters and receivers are seen in Dante Controller and everything has a valid subscription.  I've got a simple test rig here with a mic and speakers.  Sound is clear and crisp.  The problem is that none of our faders work anymore - main and individual faders don't work. 

    Can't adjust volume or mute.  It's all or nothing.  (Nothing, meaning I have to use the hardware switch on the handheld mic itself to mute it.) I do get the green meters on the X32 above the fader so it looks like theres a connection somewhere.

    Main and all the mic faders work again if I revert the hardware back to the stock USB card.  Maybe I misread the directions but it said under Routing menu to route to the Card (the Dante Card right?)

    Looking at this article
    https://community.musictribe.com/pages/kba?articleId=13d79f26-25ee-ea11-a815-000d3ac693d8&brand=Behringer

    Is it as simple as this?   Thanks.

    read more...
    0 165
    • MCCAZ
      Nigel67 Hi MCCAZ. In the Card Tab, are you routing the Local 1-8, 9-16, 17-24 and 25-32. If so, then this is taking the audio straight off the pre-amps and sending it to the card. This is why EQ, Mutes, Faders are not working in the feed to the Dante. The faders, Mutes, etc should still be working though if you assign the inputs to the Main Mix. If you want to send post fader signal from each input to the Dante, then in the Out 1-16 tab, you will assign the first 16 Direct Outs to the 16 Outs (and adjust the tap points as you require). For the inputs 17-32, you then go into the Ultranet tab and assign Direct Outs 17-32 to Out 1-16 again with the tap point you require. Once done, go to the Card tab and assign OUT 1-8, 9-16 to Outputs 1-8, 9-16, and then assign Ultranet 1-8 to Outputs 17-24 and Ultranet 9-16 to Outputs 25-32. Hope this answers your question.
      • August 13, 2021
    • MCCAZ
      MCCAZ

      @Nigel67 Thanks! Followed your steps and got mostly everything routed. So this worked perfectly. Mutes and faders for individual mics are working as expected. I guess the Main/Master Fader is on a different layer as it's mute/hardware still don't respond.

      However, if I'm controlling it from software side it seems to reflect on the production computer and it can be muted/controlled within that environment. (Headphones on) Not from the board though. Have to mute all mics instead of just pressing mute on Main/Master. Any ideas for this one?

      • August 19, 2021
    • MCCAZ
      MCCAZ @Nigel67 Took a bit of a hiatus from troubleshooting here. I'm hoping you or another can look into my pending question from August 2021. I switched off of Dante and back to Analog but I'm looking to boot this conversation up again. You asked for Card, OUT 1-16 and Ultranet. Let me know if anything makes more sense. Pictures attached.
      • Feb 3
    • MCCAZ
      MCCAZ Ultranet
      • Feb 3
  • New
    BenMerc
    Newcomer - Level 1
    2021-08-06

    Hi,The problem is that my device is unrecognizable in Synthtribe & Ableton/fl etc,TheBehringer site has the 1.3.5 firmware update but won't work (Recognize Device) I did noticed that the firmware they offered was Window 8 (Latest) & not Windows 10 as that is my operating system.

    read more...
    0 31
  • New
    David20k
    Newcomer - Level 1
    2021-07-23

    greetings guys, i just acquired the flow 8 recently but am finding it difficult updating it. the SimplyPUT (MAC) Update-Tool is not installing on my mac. this is what its showing on my screen. please help

    read more...
    0 61
Go to page