Statistics

254,794 members
132,525 posts
  • Nicolas
    Contributor - Level 2
    2008-03-11
    I just wanted to report that I experienced a minor problem when I upgraded my G-System to version 3.0 (on PC, Windows Xp).

    The upgrade tool worked flawless, everything went fine until the message on the G-System read "Turn power off". I unplugged the cable, waited 5 seconds, then restored power to the G. the display went green, but nothing was being displayed... I waited a few minutes (not cutting the power yet), then turned it off again. Again, I plugged in the cable and the same happened, green with no text.

    The third time around, the "AVR BOOT" text finally appeared and did its thing. the G-System booted to version 3 after that and I could play around with the editor.

    Everything seems fine (but I havent tested everything yet). Is there a way to verify the upgrade?
    read more...
    0 10,453
    • Nicolas
      shredtheater it will say which version you have when you boot up. I assume if it says 3.0 everything is fine and dandy
      • March 10, 2008
    • Nicolas
      ren-lex yeah the same happened to me, but its all right now
      • March 10, 2008
    • Nicolas
      markno999 Happened to me too. It should immediately come up with the AVR Boot stuff. If you get the blank green screen on power up, shut the G off, unplug the USB Cable, turn the power back and the G-System and it will start right up and run though the final steps of the firmware update. After that, no problem leaving the USB cable plugged in.



      Regards
      • March 11, 2008
    • Nicolas
      Nicolas Yes, I think I unplugged the USB cable after my 2nd power off too, ... and then it worked.

      thanks for the comments
      • March 11, 2008
    • Nicolas
      wsot Yes, but it sure scared the bejesus out of me yesterday!
      • March 11, 2008
  • harmonicator
    Contributor - Level 1
    2008-03-04
    I have a Suhr Badger and I want to get the nova delay and reverb to put in the loop. I want to use Suhr's minimix in the loop to preserve the tone of the amp/guitar. The minimix only works with "line level processors", not "instrument level processors".

    Does anyone know if the nova pedals are line level or instrument signal level processors????
    read more...
    0 4,291
    • harmonicator
      wvh I just read a (rather positive) review of the delay pedal here:

      http://www.rig-talk.com/forum/viewtopic.php?f=3&t=27210



      "When I hooked it up I had the first positive surprise: It does Studio/Line or Instrument levels. [...]"



      So it seems you can choose. I don't own it myself, so I can't confirm or deny it.
      • March 11, 2008
    • harmonicator
      hunga_buk Hello everyone, I just bought a nova system and would like to have the option of selecting either the preset banks of the nova itself that use an expression pedal to increase or decrease the audio volume



      What do you advise me to buy?
      • July 29, 2014
  • kmj2307
    Contributor - Level 1
    2007-12-31
    Hi!

    Does anyone know where i can download the editor for G- system?


    Is it true that they have made one?
    0 17,278
    • kmj2307
      mfergel hehehe........it's true that they said one would be available......when it shows up is any ones guess at this point.
      • December 31, 2007
    • kmj2307
      TC-Mike the editor for the G-system can be downloaded here:



      http://www.tcelectronic.com/g-systemsoftware.asp
      • April 15, 2012
    • kmj2307
      guillespiers TC, please!! We need upgrades for this editor!! Vyzor has many bugs, it crashes almost all the time. I have the latest version, running it through Windows 7 64 Bits.
      • April 15, 2012
    • kmj2307
      flaps45 I totally second this. It would be nice to get an upgrade, this version is obsolete. If user requests are accepted at the moment I would make 2:



      1 - make it RTAS compatible (not only VsT)

      2 - peek at the line 6 stuff, their UI is pretty friendly.



      A good software/editor will increase the value of our and your gear... come on TC!
      • April 16, 2012
    • kmj2307
      guillespiers UPGRADE PLEASE!!
      • May 10, 2012
  • dvx135
    Contributor - Level 1
    2007-12-28
    I've tried following the instructions to set a button on my midi controller to mute the G Major for tuning, and have not been able to get it to work. I'd also like to setup a button for full bypass.

    I'm using an ADA MXC midi controller. It works fine for all the presets I have setup, just not for the tune mute. I'm probably missing something, but I can't figure it out.

    Any suggestions would be appreciated.
    read more...
    0 5,807
    • dvx135
      idiedtony Hey!



      What you could do, & it's what I do myself, is....



      Tuner: Set up a patch with no effects @ all & turn the level on that patch all the way to -100. Therefore muting the output completely so you can tune silently.



      Bypass: What I do for that is the same as the patch for the tuner, no effects @ all, except with the level even'd out with all of my other patches.



      Hope that helps! =D
      • January 11, 2008
    • dvx135
      dvx135 Thanks for the reply, I will try your suggestion.

      The manual (p.17) describes a way to do this with a specific built-in system. However, I've followed it step-by-step and haven't been able to get it to work. It's possible that I just missed something in the instructions. I've found parts of the manual that didn't have complete instructions for various functions, which may be due to not getting it translated exactly as it was originally written.

      Anyway, thanks for your suggestion, I'll use that!
      • January 12, 2008
    • dvx135
      redgee34 Thanks for the tip. You're right, there isn't anything wrong but I have to figure things out myself as I am new to rack mount gear. I got my G-Minor to work but in a strange way. For me to activate the change in program on the G-Major from the G-Minor, I have to program the desired setting from Factory to User. Did you have to do that in your FCB1010?
      • March 8, 2015
  • 7DyingTrees
    Contributor - Level 2
    2007-12-24
    First off, any time you work with mains voltages or can come into contact with them, well, be carefull, really, this stuff can kill. But it isn't hard, if you are really nervous, then make sure the unit is unplugged, and touch a radiator or anything grounded to discharge any static electricity you have built up (walking on carpets etc) so as not to damage the IC chips with static discharge

    Right, all credit goes to my friend ryan, who had the same problem as me, but decided to see if there was anything obvious wrong, and found this out.

    First off, my problem started with the the G-Major freezing during a gig. i thought it was broken, but then it started working again, and then one day it just would not start. The screen lit up, but nothing happened, like a completely dead unit.

    Well, Ryan had the same problem, so he took his apart and discovered that there's two chips in sockets that can be replaced. Now either of these can come loose, so if your g-Major is hanging, then take it apart, and find these two chips:

    On the main board, easy to get to:


    On the front panel, less easy, and you'll need to have something to undo the security hex bolts. Anyway, remove the two inner dials, then pull the panel forwards and slide off to the left or the right, and find the following chip (which was slightly loose on mine)


    Simply see if these are properly in (give them a slight push, then try the unit on again, just don't touch the innards as they'll be exposed)

    Anyway, if this is the problem, then this should sort it out!

    I am well pleased, as I bought a replacement g-major, but now I have two, one for each amp setup!

    James
    read more...
    0 141,177
    • 7DyingTrees
      iacntspell By hanging, you're talking about not fully powering up or freezing, right?



      That is, this is different than the other guy's post about the knobs not scrolling through the menus correctly? I'm having that problem and wasn't planning on having to do any surgery this extensive
      • December 24, 2007
    • 7DyingTrees
      7DyingTrees It's the hanging yes, not powering up fully and freezing, where the freezing eventually leads to the not powering up as in my case



      THe not scrolling correctly could be related, as the chip on the front panel looks to me like the chip that tkaes the knobs/wheels/etc and tells the mainboard what to do, so it may be worth checking in that case as well!



      The surgery isn't too bad for this, it's just undoing the case, pushing two chips in, and then reassembling
      • December 24, 2007
    • 7DyingTrees
      iacntspell Excellent. Thanks for the tip.
      • December 24, 2007
    • 7DyingTrees
      xcpointx So happy I found this!! (Still waitin for TCE support to get back to me)



      I've been having this exact issue.



      I bought the unit on Ebay, shipped across the states, then brought over to South Africa by plane. Pretty sure things got jangled loose in all that moving right?



      I found that the age old remedy of giving the unit a few bangs helped get it working, which made me think something was loose. This thread confirmed it and now I'm opening it up to sort it out!!



      Thanks so much for posting this.
      • January 10, 2008
    • 7DyingTrees
      7DyingTrees No problem man Glad to be of help!
      • January 21, 2008
  • aksman
    Contributor - Level 2
    2007-11-18
    Post your T.C. Electronic GSystem rig here...

    I'll start it out with my current one and a couple others I found online!
    0 1,119,685
    • aksman
      aksman My setup:








      (missing from the pic are a HotPlate, a Gibson ES 135ltd, and a Line 6 DL4-for looping- that get used in my current guitar setup)
      • November 18, 2007
    • aksman
      aksman Steve Vai (obviously)




      • November 18, 2007
    • aksman
      aksman Porcupine Tree:









      • November 18, 2007
    • aksman
      aksman Brad Whitford (Aerosmith):









      • November 18, 2007
    • aksman
      digitalkettle



      Under the bonnet:





      No amps in play here...just two Sansamps going direct. There are actually two separate chains:

      A) The G-System and the pedals 'under the bonnet'

      B) The top row of stomps...mostly home made BYOCs



      The silver unit to the right is a StepABout: a dual-mono preamp/routing matrix...so a dual output instrument (such as a Parker Fly or a Chapman Stick) can be routed separately through chain A or chain B...or both combined...or none at all.



      Still waiting for X1/V1 pedals!



      Sorry about the bad lighting ;-(
      • November 18, 2007
  • kselbee
    Contributor - Level 1
    2007-11-17
    I'm trying to set a patch for 1/2 step flat instead of tuning down. Anyone have the settings for this? I tried detune but still get a lot of the dry signal mixed in. Thanks...
    0 5,770
    • kselbee
      dirkpispers Use the pitch shifter Voice1 -100 and Mix 100%.

      The 100% Mix of course only works in serial effect loop. In an parallel loop there will always be some direct signal.

      But even if it works, it will sound artificial and will be no alternativ for tuning down.



      Dirk
      • November 18, 2007
    • kselbee
      Insideout I agree. Pitch shif seems to only work on single notes. It freaks out if you try to play chords. Even with single notes, it doesn't sound as good as tuning your guitar differently. It's a great effect for adding a subtle harmony.
      • November 22, 2007
    • kselbee
      wileamson7 I wouldn't immediately assume anything's faulty though. Have you checked to see that the G-major is set up to accept the right midi channel? I put mine on Omni since I don't use any other midi equipment with my rig. Is the G-major getting any signal from the minor?
      • April 8, 2015
  • tore
    Contributor - Level 2
    2007-11-16
    There's been a number of feature requests in various threads and while we obviously can't promise that a suggestion will make to a firmware release and I figured it would be a good idea to gather them all in one spot. To start it off, I've copied some great suggestions gbtommasi posted in the "What Routing Are You Using?" thread:

    "... it would be great to decide wether you have mod before or after delay, say, or even after reverb for those 'landscape' ambient guitar sounds.
    Even without going that complex, it would also be very useful if i could assign a % of reverb to delayrepeats when using parallel or semi parallel mode, so that they could 'sit' more nicely in reverb's ambience. It would sound more 'natural'.
    read more...
    0 668,232
    • tore
      scottkahn Feature requests:



      1. It would be great to be able to see the tuner while playing, like with the G-Major and G-Force. I miss this from my other TC gear...



      2. MODULATION DELAY. It would be great to be able to set a chorus rate and depth to just the repeat notes of a delay signal.



      Scott
      • November 16, 2007
    • tore
      ny10547 Any chance of synth sounds similar to the Axe FX? They have some sounds where you get the guitar as well as string type swells.

      Also a little better tuner for the bass. Not a hi priority on that one though.

      One more, would it be possible to have the volume and expression pedals control parameters on not only the G but also on preamps? Right now the G only controls program changes. That one would be real nice.
      • November 16, 2007
    • tore
      gbtommasi ha! this is a very dangerous thread Tore, you know musicians' fantasy is unlimited!

      • November 16, 2007
    • tore
      dirkpispers I don't have a G-System yet, but I will buy one in the next weeks and I studied the manual a little.

      I think a parameter patch/global in the menu for setting up and customize the footswitches will make the G-System even more flexible.

      For example, if Loop4 on/off or Delay on/off will be set to global, the setting will not change when I change between patches.



      Dirk
      • November 16, 2007
    • tore
      sheguitarplayer +1 on the routing so you can put the mod after the delay, or having a modulated delay to get those U2 sounds nailed. Our engineer has the D two in his rack and the chorused delay on that is unbelievable!

      I would also like to see the facility to send more than one cc message with one pedal press.

      Would it be possible, within a preset to toggle between say two different modulation effects. I like to use the gsystem like a glorified stomp box and this would be very useful. It can be done on the Boss GTpro. Obviously you wouldnt be able to use both fx at once (too much processing) but if the patch can 'recall' settings on say a flanger and a chorus effect then it should be easy enough to switch between the two?
      • November 16, 2007
  • kevin_jazz
    Contributor - Level 2
    2007-11-14
    It's great to see the TC Forums up and running. I hope that this forum will eventually replace the one on the gear page.

    Just to kick things off:

    Has anyone been making patches for more etheral, ambient guitar sounds, i.e., Robert Fripp type effects? If so, how are you doing it??

    Looking forward to the editor where we can actually send patches to each other. I have a few that others might be interested in but it's tedious to type in all of the parameters....
    read more...
    0 9,454
    • kevin_jazz
      gbtommasi I did it:



      now i have not got parameters values here, but basically it is how it works for me:



      - serial routing

      - intelligent pitch shifting, an octave up, then you could add a fifth, or a fourth up for a more complex harmony. No dry signal (100% wet, that is, only harmony out);

      - dual delays, with feedback controlled by expression pedal and no dry signal out (100% wet);

      - long hall reverb, with no dry signal (100% wet);



      then, you control how long the sound will last with expression pedal (more delay feedback). And of course you sweep effect in and out with volume pedal (placed in the 'in' position)



      caution, then, because setting hi feedback levels, especially on 100% wet chain, will cause signal clipping very easily and unwanted 'infinite' feedback which will destroy your hears



      it works pretty nice, though is not comparable with those famous eventide crystal effect.



      hope this helps
      • November 14, 2007
    • kevin_jazz
      ny10547 Any chance you could at least post some dual delay settings for your ambient sound. That is the delay I have a lot of trouble with. I think I can muddle through the rest.



      I hope TC can do some updates that will give more ambient sounds like the Eventide and the AxeFX. Not sure if it is possible....just a dream.



      Thanks for the post.
      • November 14, 2007
    • kevin_jazz
      gbtommasi yep i will write delay parameters down next time i go to my rehersal studio, where the g-system lies



      today or tomorrow.



      Of course, you may find there are better ways to do this, and also maybe improve my settings.



      In this case, please let us all know
      • November 15, 2007
    • kevin_jazz
      aksman Throwing a volume swell into a loop helps a lot.
      • November 15, 2007
    • kevin_jazz
      gbtommasi well delays are just set in a very random way, it's about 1100 ms on right channel and 800 on left. But you can really experiemet what suits you better..
      • November 18, 2007
  • jelyfinger
    Contributor - Level 2
    2007-11-14
    Long overdue software update to correct issues is what we NEED!
    0 15,284
    • jelyfinger
      digitalkettle If you're keeping a list then add the V1 and X1 pedals
      • November 14, 2007
    • jelyfinger
      gbtommasi agreed
      • November 14, 2007
    • jelyfinger
      jhbpa I'd be a happy camper just to get a patch for the effects pedal latency.
      • November 14, 2007
    • jelyfinger
      digitalkettle

      jhbpa wrote:

      I'd be a happy camper just to get a patch for the effects pedal latency.


      That's probably all ya gettin'



      We've been waiting so long that folks started imagining that they were going to get extra effects such as Rotary and Volume Swell...but apparently not.
      • November 14, 2007
    • jelyfinger
      billy11 I want an editor, first, and it is long overdue!



      Billy11
      • November 15, 2007
Go to page