Statistics

260,923 members
139,576 posts
  • New
    underdog
    Newcomer - Level 1
    2021-11-30

    I AM LOOKING FOR A KNOB FOR THIS AMP. CAN ANYONE KNOW WHERE TO GET THEM. THANKS

    0 2
    • underdog
      Nigel67 Hi underdog. Please submit a ticket to our spares team and they will get back to you with pricing and availability. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. Many thanks
      • Sat at 11:39 PM
  • New
    mpmiller73
    Newcomer - Level 1
    2021-11-10

    I am trying to buy the fsb 104 footswitch that goes with the bugera 333 amp head i bought used. There are no stores in the US that carry these. Without the switch the app is worthless to me. 

    0 7
    • mpmiller73
      NicJonesMT Hi MpMiller73.
      You can find a full list of our international retailers at the following link:

      https://www.bugera-amps.com/buy.html

      Alternatively you can click "Support" at the top of the page and submit a spare parts ticket, as they may be able to advise you further on this.

      I do think that this pedal is actually discontinued though, so it may also be worth checking the second hand market.
      • Nov 10
    • mpmiller73
      mpmiller73

      I have checked retailers. Sad, guess I'll just have to sell and go back to my marshall valvestate. Lol

      • Nov 10
  • New
    marcicamp
    Newcomer - Level 1
    2021-11-05

    Hello! Need to connect a combo amp with external speaker output (labeled as parallel) to a bugera 212TS... The problem is that the internal speaker of the combo is 8ohm and the mono input of the Bugera 212ts could be 4ohm (internal parallel, i suppose) and 16ohm (series)... I wonder to know if I can in this configuration use only one speker of the 212TS, setting the stereo mode and connecting ONLY one jack... Is this connection possible and safe or in stereo mode I MUST connect both the input jack?

    Thanks

    read more...
    0 3
    • marcicamp
      Nigel67 Hi marcicamp. Please can you submit a Technical Support ticket for this question and one of the Team will get back to you with an answer. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket.
      • Nov 9
  • New
    Iamgloop
    Newcomer - Level 1
    2021-10-21

    Hi all, I'm having a real hard time with my burgera 333 head. The issue is with switching in between chanells on the head or foot switch. It will only stay on clean and won't switch to crunch/lead. It also intermittently switches the boost on and off from time to time. I had taken it to a tech who thought it was the relays and he changed these out. He then said it was tbe pcb board (PCB 722000REV) and would need replacing. He said it would be a simple install, however getting that part He said "seems impossible". Can anyone help me here? Many thanks

    read more...
    0 8
    • Iamgloop
      Dale_M Hi there for official support in this matter we would advise you go to the support tab above and open a Technical ticket so we can assist you.
      • Oct 22
  • New
    khodari
    Newcomer - Level 1
    2021-10-20

    Where can I buy the footswitch model # FSB104A  BUGERA to use on muy Amp model 6262-212

    0 16
  • New
    Chronox2
    Newcomer - Level 1
    2021-10-08

    Hello, I would like to know where could I buy the front plate from a 6262? Thanks in advance.

    0 8
    • Chronox2
      Nigel67 Hi Chronox2. Please contact our Spares team and they will be able to help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. Many thanks
      • Oct 8
  • New
    Ccotter74
    Newcomer - Level 1
    2021-10-01

    Hello, I just purchased a G5 infinium. It was working fine when all of a sudden it didn't. Now I have almost no volume, I have to really bang the strings of my guitar with the volume up all the way to get any sound. The sound that comes through is very fuzzy and pops a lot. I already tried new tubes and the problem persists. It's my first tube amp and it's made a bad first impression of bugera. 

    read more...
    0 16
    • Ccotter74
      ChrisEdwards1 Hi Ccotter74, before replacing the tubes was the TUBE Life monitoring LED flashing at all? Is it flashing after you have replaced them?
      Are any of the lights on the front panel also flashing? If so could you please confirm for me which ones?

      Would you also be able to provide any further details on any other equipment you may have connected to the amp? For example pedals.
      • Oct 1
      • Bugera G5 infinium
        Ccotter74 And yes I've tried different cables, different guitars
        • Oct 2
    • Ccotter74
      Ccotter74 Just the guitar no pedals. Brand new tubes, infinium light flashes 2 or 3 times seemingly randomly. Standby switch works, reverb works. Almost no sound at all on clean channel
      • Oct 2
  • New
    Beo1960
    Newcomer - Level 1
    2021-09-26

    Hello,

     

    Can I run my T5 Infinium without a speaker cabinet attached, using the headphone jack into a mixer, or do I need to attach either a cabinet or a load box to the speaker output first?  I have no problem either way, but I'd like to use this thing at practice, but I'd rather not lug along a speaker cab with it as well...defeats the whole purpose for me.

     

    Thanks in advance.

    read more...
    0 13
    • Beo1960
      PedroRodrigues Hi Beo1960, please consider that you should not use the Headphones output to feed the signal to a Mixer, ,you can only use the main output to feed the signal to a 4 OHM to a Speaker.
      • Sep 26
  • New
    Ymel
    Newcomer - Level 1
    2021-09-22

    Dear All, 

    I just wanted to write a letter to Bugera but I found myself in a serious registration process in case of reach you. So I am a guitarist who usually plays alone or with a singer in a duet. I'm Hungarian but I live in Vietnam. I've been always searching for the best compact combo amp, a kinda Swiss knife. Through the years I had Marshall50 acoustic, Roland AC60, Fishman Mini - among the 3 it was the best so far. But it only was. Because once I connected a distortion pedal and I blew away the tweeter. 
    And recently I ve found the Bugera AC60 which seems to be the closest to my dreams. It does not sport a tweeter to burn it down but has a loop where I can connect my electric guitar with amp/cab simulation without damaging the speaker - of course not using full gains.
    My dream combo that no company has ever made yet would be:
    - sporting 3 channels + 6.3mm aux in (guitar, mic, my electric pedal kick drum)
    - able to handle acoustic/hollow body and electric guitars all
    - switchable tweeter or frequency selector: full range for the mic and acoustic guitar, middle and bass for other guitars
    - tuner, reverb onboard
    - line out 
    - loop circuit
    - 60 Watt output

    The makers think that all gigging guitarists (street, small bar, etc.) play with acoustic guitars when they sing. No one thinks of electric guitar users who need a mic channel either. There is no such amp at the market which offers a compact solution for this above. Now I m planning to buy the Bugera AC60, and I hope I will not blow the double cone speaker away. 
    Thank you for your attention

    read more...
    0 13
    • Ymel
      Dale_M Many thanks for your suggestion I will pass your comments over to the design team. We cannot make any promise of their inclusion but they will be reviewed.
      • Sep 22
    • Ymel
      Ymel

      Oh, in me first letter I was not clear. So I owned a Marshall AS 50D - that amp is a bulky failure. The Roland AC60 is a rip-off: way too expensive and cheats the amateurs: it is only a 2x30 Watt, very weak amp, it is only 30W, not 60, plus colors the guitar sound, the Fishman Mini is the only good one among the 3 I had. I read in reviews, it gives a better microphone sound than the Bugera but I think I can live with the Bugera's mic channel well.

      • Sep 22
  • New
    amado57
    Newcomer - Level 1
    2021-09-21

    Hello people,

    My V55 is making these horrendous popping, thunderous sounds when some volume is applied. Also I can not get any reverb out of it, as well as noticed the Bass, Mid and Treble have very little or no effect. Replaced the Tubes, re-seated the tubes several times, checked for cold solder joints, I have tested both the +15 and +5 Vdc out of the 7815 and 7805 Regulators OK. The amp plays my guitar OK, nice and clean, when it is not going crazy with the horrible popping sounds. I am thinking that maybe my main board has gone bad?  Or could it be the smaller daughter card that runs the reverb, that has gone bad. Any ideas?  I also tested that the problem is there in both Triode and pentode mode. I am going to try to remove, one by one the pre-amp tube, stages to see if the problem appears to be stop. Maybe get lucky and a resistor or cap in that area has gone bad. But at this point I am really stuck. I have opened a ticket with support, but they must be very busy. (have not heard back from anyone yet) My support case # is CAS-488499-W9D1K4. I also am trying to find out the cost of both the main board, an also the smaller daughter card that is attached if it is not included.


    View Attachment
    read more...
    0 11
Go to page