Statistics

224,445 members
98,781 posts
  • New
    jeremycables
    Newcomer - Level 1
    2021-04-16

    I have a X Touch and the Ethernet Port is not working to be able to connect to our XR18. I updated it to the newest firmware after we discovered that it wasn't working. The activity light blinks on for a brief second after plugging in a cable and then immediately turns back off.

     

    Any ideas?

    read more...
    0 4
  • New
    LittleBearNoise
    Newcomer - Level 2
    2021-04-14

    Hi, I have a couple of questions, I use Cubase Pro 10.5 and the full version of XTouch:

    1. Does the Xtouch editor work with XTouch or only X-touch One / compact etc? 

    2. How do I activate the use of the footswitch (1/4") to punch in/out? In other responses it has been noted that other units (one / compact) need to be placed into midi mode in order to work. This would remove the normal cubase compatibility functions under the MC protocol which I wish to retain. 

    3. When selecting a bank of 8 channels which are not displayed on-screen (if there are a large number of channels) using the fader bank function on the XTouch, the screen in Cubase does not follow the selection of the next bank without pressing the select button for the last channel in the new bank of 8. When it is pressed the next bank of 8 channels come in to view. Is there a way to edit the function of the XTouch so that the view in Cubase follows the selection of the new bank on the XTouch?

    4. When scrolling through the plug in list using the rotary encoder (plug-in button selected) the list jumps through plug-ins in groups of 4 or 5, this means that many plugins are not selectable from the XTouch plug in settings. Is there a way to make the encoder scroll through the plugins one by one?

    5. The Xtouch One has overlay templates showing the different button assignments for different DAWs is this available for the XTouch?

    Kind regards

     

    read more...
    0 7
    • LittleBearNoise
      DaveMorrison For Questions 1-4: The X-Touch is not programmable. It's a clone of a Mackie Control (plus a mode to connect to X/M mixers). The buttons and controls have fixed MIDI note/controller assignments and can't be changed. The DAW, in your cases Cubase, has to act on the information that it receives (and also sends). Everything is controlled/configured by Cubase. You'll probably have better luck by going to the Cubase forum and search for MCU.
      Question 5. Yes, templates have been made by third party suppliers. There are links to them somewhere in the bowels of this forum. I haven't had any luck searching for them (it's one of the many problems with this forum/site/disaster area ; ) ).
      • Wed at 10:33 AM
  • New
    caferrer
    Newcomer - Level 1
    2021-04-12

    I have a problem. Just got a brand new X-Touch with a brand new HP Envy completely updated and I cannot even see the X-Touch as a Midi input. Therefore, I could not update the firmware because it is not seen by the program. However, it is weird that I can see it in the Device manager under audio devices. Any help would be greatly appreciated.

    read more...
    0 9
    • caferrer
      gethindavies The same thing has happened to me. Bought brand new off of Thomman a few weeks back and the LCD won't show anything at all. There is nothing online to help. I'm completely stuck!
      • Mon at 9:00 AM
      • X-Touch with Windows 10 - not working
        caferrer Thank you for replying. I hope someone out here can help us.
        • Mon at 9:38 AM
  • New
    Olenga
    Newcomer - Level 2
    2021-04-09

    Hello. Is it possible to use X-touch Extender with X-touch One?

    1 5
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-07

    Hi just purchase xtouch ( 8 channel ). I have upgraded to the latest version of Cubase 11 pro and updated the firmware to the latest one on the website. 1.2.1.

     

    Alot of the buttons are not working.

    Click track button

    Had to program it using function keys.

    Utility save , undo

    marker track

    midi track, input, audio track, aux , busses, ouyputs, user buttons all not working

    solo button not working

    drop button not working

     

    Is there a new firmware update being created so this product will actually work with daw programs

     

     

    read more...
    0 14
    • AcrobatStar
      DaveMorrison Unless you have a Ryzen processor, there seems to be no reason to upgrade to 1.21. I haven't yet because all the posts on this forum have been negative regarding 1.21. Of course that means nothing and I really ought to try. I'm still sticking with 1.15 though. The X-touch is a clone of the Mackie Control and it works very well (at least in Logic Pro). However, all the functionality is provided by the host DAW. MCU mode generally has more support than HUI. I bet the Cubase forum will provide you more information on Mackie Control support than this site.
      • Apr 7
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-04

    Hi My Xtouch is not working .

    I upgraded to the latest firmware 1.21.   1.04

     

    Showing looking for i.p adresss.

    Is there a reset for this product

    0 7
    • AcrobatStar
      DaveMorrison Changing modes is a type of reset. It looks like your Xtouch is waiting for a IP address to be sent from a DHCP server. What mode are you in? Reloading 1.21 or Downgrading to 1.15 would be another option.
      • Apr 4
  • New
    RichSallnow
    Contributor - Level 2
    2021-04-04

    This is driving me nuts! Since yesterday whenever I press the record button on my X-Touch, it mutes the track on Logic Pro X. It seems like the record and mute buttons seem to have linked themselves!. I've tried unplugging all midi devices, rebooting the Mac, re-installing the 1.21 firmware, but it's still happending. Any ideas?

    read more...
    0 9
    • RichSallnow
      DaveMorrison If you haven't customized any of the buttons (or functions), go to the "Logic Pro": Control Surfaces : Setup... menu. Then delete the Mackie Control icon.
      • Apr 4
    • RichSallnow
      ChrisJanton Have you tried installing the 1.15 firmware again? From what I could see there's no reason to update to firmware 1.21.
      • Apr 5
  • New
    LittleSharkStudios
    Newcomer - Level 1
    2021-04-02

    Hello,

    I've got an X-Touch and an X-Touch Extender both in HUI mode.

    When I push the "PAN/SURROUND" button on the X-Touch, pans for stereo tracks of the X-Touch change their side (left to right or right to left) but NOT on the Extender! Everything else is getting the right commands (like when I solo a track on the X-Touch the other tracks go muted on the X-Touch and on the Extender as well, same for "FADER BANK" button the tracks are well routed on the X-Touch and the Extender channels), the only thing that doesn't work is the PAN/SURROUND button that doesn't send the command to the Extender. What am I missing?

    Thanks for the help.

    read more...
    0 7
  • New
    djcraiggunn
    Newcomer - Level 1
    2021-04-02

    Straight out of the box - midi to USB into the laptop.

    In Logic Midi Preferences 'TD3' does not appear.

    Have tried the (Write/Next - 3 aka USB) to get it to recognise.

    I shoudn't need software for the Mac to recognise this  - or do I need OLD style midi cables to recognise it?

     

     

    read more...
    0 5
    • djcraiggunn
      Dale_M MIDI to USB cables should work, can you try connecting it to either another computer or another DAW to see if the problem follows it? Maybe also try another cable.
      • Apr 3
  • New
    EmotiveSigns
    Newcomer - Level 1
    2021-03-30

    Hi - 

    I have been using logic pro for years. For musical input I use a MK-425C keyboard which has worked perfectly. Recently I bought a x-touch and since adding that when I press a key on the keyboard strange behaviour occurs, such as it triggers a different layout, rather than playing the notes. 

    Can anyone help explain this problem and possibly help me fix it?

    Thanks in advance,

    Charles

    read more...
    0 6
    • EmotiveSigns
      NicJonesMT Hi Charles. Ideally it would be easier to help if I could see how you have both devices setup and configured in Logic.
      Could you please submit a tech support ticket (Click support above) and provide some screen shots of your setup?
      • Mar 30
Go to page