Statistics

250,737 members
127,933 posts
  • New
    martinw
    Newcomer - Level 1
    2021-09-26

    Hi all

    I've got an X-Touch One for Cubase on my Windows 10 PC, running on a Ryzen processor. Which I understand is the reason it won't show up on that machine.

    So I tested it on a friend's Mac laptop and it appears immediately and works.

    What I'm having trouble with is updating the firmware to overcome the Ryzen problem.

     

    On the Mac I'm using SysEx Librarian to update the firmware. However, when I put the X-Touch One into Update mode, and run SysEx, selecteding the X-Touch within, nothing happens. The controller, stays at the firmware number it had when I first turned it on. No numbers show up as rising on the X-Touch as SysEx is doing it's thing.

    Any ideas as to why this might be happening or how to resolve?

     

    read more...
    0 4
  • New
    JusRoc1
    Newcomer - Level 1
    2021-09-22

    hello

    just like to say that i have been fault finding over the past week or so 

    in order to try and work out why the new x touch i have just brought for

    controlling cubase 11 pro, doesn't always work as it should

     

    what happens when it malfunctions is that the faders appear to work

    more like (digital inputs) toggle buttons than (analogue inputs) rotary encoders 

     

    from what i can work out, i think that it is a USB related problem

    perhaps power related 

     

    i can't say. but thought i would surrender my thoughts in hope of helping

    hope it helps behringer (and other users)

     

    read more...
    0 5
  • New
    barcslay
    Newcomer - Level 1
    2021-09-18

    Hey guys! I recently added an x-touch compact to my setup for Logic Pro X - I've had success using it, but I'd really like to be able to use rotary encoders 9-16 when in in plugin control mode. Is there a way I can do this? In the manual it says that turn is not assigned - so is there a way to activate and assign them? 

    read more...
    0 2
  • New
    ClayMorrow
    Contributor - Level 1
    2021-09-16

    I'm having an issue with my BCF2000 controller where two buttons have suddenly started behaiving very strangley. The buttons in question are buttons #47 and #51. Button #47 now thinks it is button #46. When I try to edit button #47 the BCF2000 selects button #46. And for button #51 something even stranger happens. Pressing button #51 once does nothing, pressing it a second time puts the BCF2000 in Edit mode for button #49, and pressing it a third time it puts the BCF2000 in USB Edit mode! 

    This happeded when I was recording a MIDI track in Live. I should mention, I use a custom sequencer in Live that comunicates with the BCF2000 via MIDI and I am wondering if somehow a MIDI loop was created while recording and perhaps that may have somehow caused this problem?  

    I have tried resetting the Presets and reinstalling the factory firmware but neither has fixed the issue. Otherwise the BCF2000 seems to work fine as long as I don't use those buttons but I would very much like to fix this issue if possible. Anyone here ever experince this issue? Any suggestions would be greatly apprecated.  

    read more...
    0 9
    • ClayMorrow
      WilliamR Hello, WIlliam from musictribe here. Please contact us by submitting a Care Ticket. Click on the Support link at the top of this page. On the Support page, scroll down to the bottom and click on Technical Support to get started.
      • Sep 17
  • New
    Soph123
    Newcomer - Level 1
    2021-09-16

    Behringer : X touch one 

    DAW : Ableton 10

     

    Wondering how to use the faders with automation rather than just volume on projects ? 

    csnt seem to find anything online is there a link you could direct me to for mapping this template ?

    read more...
    0 5
    • Soph123
      NicJonesMT Hi Soph123.
      You may need to direct this question to the Ableton team, as you would be better of using a MIDI learn function in the DAW. You can then assign the functions to the fader to record your automation, just ensure you remove these learn settings before proceeding with your mix.
      • Sep 17
  • New
    JusRoc1
    Newcomer - Level 1
    2021-09-13

    Hello 

    just a quick help link for anyone who gets puzzled when plugging in a controller like the x touch. into cubase and then has the controller's faders trigger midi note on information when a virtual instrument is selected to monitor (by illuminating the little speaker icon next to the rec button under a virtual instruments name)

    anyway cubase has this cool feature that allows multi-midi / multi audio instrument simultaneous record cubase's preferences is automatically sent to allow midi thru 

    if you have a control surface connected however, you will have to make sure that each midi instrument's midi-input is set to a particular midi input device which is not the hardware DAW controller

    otherwise your DAW controller will also send note on / off messages to the virtual instruments that are all set to midi input to all midi inputs (as the DAW also is capable of sending midi data).

    If you leave the virtual instrument's input to All midi, and then go to record a midi track say from a midi piano like controller, if you or someone else touch's the x touch faders at the same time, you will get lots of unwanted midi note on / off messages on top of your awesome midi keyboard performance ... which would suck

    I also have a problem with the x touch's faders sometimes not working, and i am not entirely sure what that is. but hey ho. i guess i have only had the controller for a few days. 

    so.....well see..... at least i am not at the stage of sending it back or smashing it up, through frustration.... any one has any ideas as to why the controller's faders don't work during these times. would be interested in listening to your opinion / help.

    thanks

     

     

     

     

    read more...
    0 4
    • JusRoc1
      PedroRodrigues Hi JusRoc1 if you wish to gather more information on the implementation of your unit I would suggest to follow the link below and submit an assistance request directly to your Tech Support Team so we can help you on this matter. https://community.musictribe.com/pages/create-new-ticket?type=Technical%20Support&brand=Behringer Thank you
      • Sep 13
    • JusRoc1
      JusRoc1 thanks Mr Rodrigues, I think i will do this, as the x touch i have is still not "plug and playing".... doh!!....
      • Sep 15
    • JusRoc1
      JusRoc1

      Hey. After a little experimenting, I realised that the reason why the x-touch sometimes did not work with cubase, is because i had booted up cubase too soon after the pc booting up, before the software that runs the audio card that i have (which is UAD) had time to load up. This for some reason caused problems with cubase seeing x touch. Now when i boot up, i leave the pc for a few mins so that UAD console and driver can boot up, before turning x touch on and then booting up cubase. This solves the issue with the x touch! yippee! no need to send back. Just wish they had provided a decent manual like in the old days....

      • Sep 19
    • JusRoc1
      JusRoc1

      Hey. After a little experimenting, I realised that the reason why the x-touch sometimes did not work with cubase, is because i had booted up cubase too soon after the pc booting up, before the software that runs the audio card that i have (which is UAD) had time to load up. This for some reason caused problems with cubase seeing x touch. Now when i boot up, i leave the pc for a few mins so that UAD console and driver can boot up, before turning x touch on and then booting up cubase. This solves the issue with the x touch! yippee! no need to send back. Just wish they had provided a decent manual like in the old days....

      • Sep 19
  • New
    ruimiguelaires
    Newcomer - Level 1
    2021-08-28

    Hi,

     

    I've purchased a Beringher X-TOUCH in August 2021 and it has firmware 1.14

    I've tried to upload v1.21 using SysEx App but, after connecting USB and the App detects the X-TOUCH and shows the "UPDATE" device, its starts sending the data but the display on the X-TOUCH shows no percentage progress (as it should) and the update never gets done :-(

    read more...
    0 21
    • ruimiguelaires
      NicJonesMT Hi there.
      Could you please click "SUPPORT" at the top of the page and submit a technical support ticket. We can then advise you further.
      Could you also please confirm the OS version you are using and ensure that you are connecting directly to your Mac, and not to any external hubs or using adapters.
      • Aug 28
    • ruimiguelaires
      ruimiguelaires

      Well, I managed to upgrade the firmware using Windows so, it must be a problem with my Mac. Strange because the SysEx App was the latest version for the Mac M1. But it's all ok now ;-)

      • Aug 28
  • New
    AyobamiIsrael
    Newcomer - Level 1
    2021-08-18

    Hi guys, I worked on my XTouch with Daw (Magic Samplitude) some weeks ago, everything was fine. But I wanted to start a mix now and discovered that the scribble scrip, channel meter, timer (SMPTE) screen not working. Faders and other buttons worked.... every means of getting it working failed. What could have been the problem and likely solution pls?

    read more...
    0 30
    • AyobamiIsrael
      Dale_M Can you advise if the scribble strip works in normal operation outside of the DAW? Are you saying this is a hardware fault?
      • Aug 18
  • New
    RobertKelly
    Contributor - Level 1
    2021-08-17

    I would like to use my x touch mini to control my x32 Rack via the x air edit software. Specifically I'd like to use it in a live setting to have individual output volumes asigned to the rotary knobs. Thanks!

     

    Rob

    0 30
    • RobertKelly
      Paul_Vannatto X-Air Edit will only work with the X-Air and M-Air consoles. You need the X32-Edit to control an X32-Rack.
      • Aug 17
  • New
    putahslim
    Newcomer - Level 1
    2021-08-10

    I am using an X-Touch Mini with Pure Data, receiving and sending MIDI data to and from it. Mostly, it works very well, but it has one behavior that keeps it from being truly useful for my music.

    The LEDs in the buttons can be controlled by sending the appropriate MIDI notes and velocity values, but only if their layer (A or B) is currently selected. E.g. I can send a MIDI note-on of 1, velocity 1, and the first button will light up, *if layer A is selected*. Now, if I switch to layer B and send the same note-on (1, velocity 1), I would not expect the first button to light up, because the first button of layer B is controlled by note-on 25, but I would expect the *state* of the first button in layer A to be updated to 'on' so that when I switch back to layer A, it is lit up. This is not the case, however. Apparently, the note-on is ignored if it is not in the currently selected layer.

    Because of this, it is not practical to use the two layers consistently.

    Is it feasible to fix this?

     

    Thank you,

     

    Phil

    read more...
    0 22
Go to page