Statistics

260,025 members
138,483 posts
  • New
    DougBGT6
    Newcomer - Level 1
    2021-11-29

    I love this thing! I've been playing with it for a week it's great. I've updated the firmware and I've been down loading Toneprints from the app.  I look forward to updates, but for the moment I'm happy. Except, the flashing light on the Flashback, I know what I've set the delay to, I can hear what I've set the delay to, I don't need a light strobing at me. On the news they warn you if a report with flashing lights is coming up. Have I missed something? Can I turn this off? Otherwise it's a plaster over the light.

    Doug

    read more...
    0 2
  • New
    MilanRadjen
    Newcomer - Level 1
    2021-11-26

    How can i get further from trying to connect to Pay Pal?? Is it TC problem or what?

    1 9
    • MilanRadjen
      ChrisEdwards1 Hi MilanRadjen, Is it possible to expand further on the issue you have encountered as it is currently not fully clear? If you can provide any screenshots that may be of great help.
      • Nov 26
    • MilanRadjen
      PedroRodrigues Hi MilanRadjen, please check you case as I have replied to your assistance request as well as on your original post above. Thank you
      • Nov 28
  • New
    yann_
    Regular Contributor - Level 1
    2021-11-25

    Signature presets, for the Midas peq3000, dyn3000, Brickwall HD, Master X HD... 

    more presets for all of them please... Curious what other can get out of it. 

     

    0 12
  • New
    yann_
    Regular Contributor - Level 1
    2021-11-25

    why why why does this have to happen to me Again 

    bought the Brickwall Hd seems like instead of the ceil profile button my tool has the Gain Rel Twice 

    Check the picture... 

    Are these hand made? 

     

    0 8
    • yann_
      yann_ I bought all the Icon series and it's kind of messed up that i don't have a proper stand for em when u turn 1 knob :D the other controllers move and you have to allign em back, i'm not so fond of the Icon dock since it cannot hold all the controllers... Any1 agrees with that??? Please make a proper dock thnx...
      • Nov 25
  • New
    markovi
    Newcomer - Level 1
    2021-11-24

      Hi,

    i have few prodacts of TC ...i have from afterglow and prophet to hall of fame,flashback and play acoustics from helicon ...i'm really satisfied how they work ...i also brought this days wiretap riff ...pedal is nice ...not best ...but ok ...thing is i'm gonna send it back to the web-shop from where i brought it as unstable prodact ...because situation by app and bluetooth is not on level that should be ...its unstable and its cracking ...its working,but very very not fluid and cracking after some time ...they say that they are first going to try in servise ...point is ...they will try in few minutes and say it works ...ok,it works but in long time its cracking and bracking ...maybe its an app,maybe my mobile,maybe the bluetooth ...i dont know and it doesnt matter ...i would like from Tc company if they say everything is fine to step on my side i tell them to money-back or something else but not to send me back that article.because it will work but not on the level of Tc prodacts really are ...i have every respect you as company and your prodacts are very good in my opinion ...but this one via bluetooth is not working well ...i really hope you can help,not to solve the problem of pedal but to help me to get money ...thnx,have a nice day.Marko

     

    read more...
    0 1
  • New
    Welshdeko
    Newcomer - Level 1
    2021-11-24

    Hi all I am in difficulty with my old but brilliant M6000 mk1. Does anyone have or can point me to suitable floppy's or ideally a PCMCIA card for it? Also I had a crash and lost my licence data for mastering MD4 etc.. I have sent a request with the code for restore but heard nothing back??

    read more...
    0 5
    • Welshdeko
      Nigel67 Hi Welshdeko, what was your case number please and I will check to see why it hasn't been answered yet. I can only apologise for the delay. Many thanks
      • Nov 24
      • Need PCMCIA sram card type 1or Floppy M6000
        Nigel67 I see that a colleague was in touch with you yesterday and you have replied to him. I am sure he will be back to you today with a reply.
        • Nov 24
    • Welshdeko
      Welshdeko Thanks so much Nigel, my M6000 has been so reliable all these years but when it doesn't work or as is now the case I have a bit of a wobbler. I am going to change the cmos battery first (which I have done previously but didn't last so long this time). I am going to retrofit a battery holder instead so it is a simple job changing the battery. Best Wishes Derek
      • Nov 25
  • New
    Mikey2021
    Newcomer - Level 1
    2021-11-23

    I have an older M6000. Yesterday it stopped routing correctly. No matter which routing preset I use, I only get signal in. No signal comes out. The meters on the output side in routing show no signal while the input side works fine. I generally use one engine and a single stereo track. So signal on input 1&2 and nothing on 1&2 out.

    read more...
    0 6
  • New
    John-PierreConq
    Contributor - Level 2
    2021-11-15

    I can't even begin to express my huge disappointment for what should have been a very promising product. The Plethora X5 SHOULD have been a great product, and when it was first released it seemed like TC's engineers were hard at work on implementing improvements and features in frequent firmware updates.

    Now - nothing.

    No new firmware updates in over a year.

    No responses to my emails.

    Radio silence on every Plethora thread on the forum.

    No MIDI clock.

    No standalone tap tempo.

    No improvements to subpar Corona Chorus, Viscous Vibe and Flashback Delay sounds.

    At this point the Plethora seems to be abandonware. I'm not expecting we will see any more updates to this product, and that's a real shame.

    read more...
    3 147
    • John-PierreConq
      PedroRodrigues Hi John-PierreConq, thank you for your post, please follow the link below to access the latest FW version 1.2 released on the 16 Sept 2021
      https://www.tcelectronic.com/tcelectronic/product?modelCode=P0D9M .
      Please provide the case numbers where you did not receive any reply so we can analyse what happened.
      Regarding the Plethora X5 or even any other unit we have released over the years, we always kept working hard and depositing the same commitment, the same love and enthusiasm since day one and we will keep developing more tools for all our active units. For last we continuously analyse all the functions request and tools suggested by our customer and after a viability analysis we always try to include them on future updates.
      Thank you
      • Nov 16
    • John-PierreConq
      CSurieux PedroRodrigues thanks but the 16 Sept 2021 is only a 'cosmetic' update on a version that was lasting from 18 Dec 2020. The Release notes of this Sept version curiously contains no information on what has been changed, or I can't find it, all concerns the Dec 2020 version !!!
      Sorry but we were expecting more than just a new date on the file and a new subversion.
      • Nov 16
    • John-PierreConq
      PedroRodrigues Hi John and CSurieux

      I completely understand what you mean but worry not, we haven’t abandoned the Plethora X5 and we have a new update currently in the works which we hope to release very soon.

      Due to unfortunate challenges during supply chain difficulties that everyone in the industry has been facing over the past year, some of our engineering resources have been tied up on unforeseen emergency tasks which has unfortunately caused delays on the update development and release.

      Thank you for the feedback, new stuff is on the way.
      • Nov 17
  • New
    Tergonzaga30
    Newcomer - Level 1
    2021-11-12

    Hi, I would like to ask if there is any damage or circuit protection for polytune 3? I mistakenly connected my 9v center negative psu to output my polytune.

    0 9
    • Tergonzaga30
      Dale_M

      Hi there, protection diodes associated with the dc supply so it should be ok, however we would advise you do not make a habit of it and always check which PSU you are connecting. ! I hope this puts your mind at ease.

      • Nov 12
  • New
    Pigpang
    Newcomer - Level 1
    2021-11-07

    Hello. I have a product called e.q station and  port ch1 to ch6 do not boot it up. But the ch7 and ch8 is booting up. What should I do to boot ch1 to ch6 as normal?

    0 14
    • Pigpang
      PedroRodrigues Hi, Pigpang, thank you for your post, to recall a Channel you must press to initiate Recall operations. EQ station operates with both individual Channel presets and global Scene presets.
      You should also check the Channel presets where all information for a full channel setup is stored.
      By default, a preset folder is created in the folder where the Editor is installed.
      The default installation folder is: C:/Program Files/TC Electronic/EQ Station However, presets folders can be created on any location on your hard disk.
      Please also consider that System parameters are not stored with presets.
      These parameters can be stored by performing a System backup.
      The System backup feature is accessed via the Setup page.
      If this does not work I would suggest performing a System Reset.
      To set your unit to default settings please Press OK and confirm to recall factory default settings.
      Parameters in the Network and Device menu are NOT recalled/reset and presets are also kept.
      Thank you
      • Nov 8
    • Pigpang
      Pigpang

      Thank you for you to replying me.
      However I can not connect the PC and EQ station. Is anything I hove to install beside EQ station v2.30?

      • Nov 13
Go to page