Statistics

267,754 members
147,251 posts
  • New
    HKI22
    Newcomer - Level 1
    2021-12-17

    Hi,

     in August this year I bought an Plethora X5 2nd Hand from a Person in Germany. (I’m living in Germany too) The newest Firmware was installed. 

    The unit worked well since then at Gigs and Rehaersals . At first with the 4 cable method using my Bluguitar Amp1.

    Two weeks ago, during a Rehearsal the Volume of the Amp reduces without any influence, just from one second to another and when trying to switch a plethora effect, the volume remains low and the plethora produces crackling noises. I unplugged the cables from Plethora to the amp and the Amp switched back to the original volume.

    Shortly after a Restart the same issue occurs.

    I changed the cables and put it in the normal way to the effects loop of the amp.

    For some time this was ok, until the same error came up again and is now continuously, even after actualizing the Firmware and Factory Reset. 

    It's a strange error. 

    It seems, the plethora doesn’t like loud Guitar Riffs. Each time I play the guitar louder, the volume of the plethora decreases with a crackling noise. Softly tapping to the cable or the casing starts the normal volume again for some seconds, bevor the crackling continues.

    So, has anybody any Idea ?

    Because of the 2nd Hand Buy i have no Original Bill. Where could I get it repaired?

    Greetings

    Helmut

     

    read more...
    0 25
    • HKI22
      WilliamR Hello, William from musictribe here. Sorry for the delayed response. Could you click the support tab above and create a tech support case. Someone will contact you asap. It would also be helpful to provide a video clip of this happening for us to review.
      • December 21, 2021
    • HKI22
      HKI22

      Hi William, in the meantime i'm in contact to one of your colleagues (Nicolas) . I don't think it is a problem, I can solve. If you guess me, I should re-solder all the points on the circuit board, it's no problem for me. Otherwhile I need an Service point Adress for a repair.

      • December 22, 2021
  • New
    madman171
    Newcomer - Level 1
    2021-12-07

    Hello Musictribe and tc electronic team,

    can you tell me if the System6000 Licences execept the System6000 Integrator are running with an MKI System?

     

     

     

    0 9
  • New
    MichaelMeche
    Contributor - Level 2
    2021-12-02

    Where do we post to ask for additional effects. An Eq and overdrive would be really nice and really make the X5 special

    0 17
    • MichaelMeche
      Nigel67 Hi MichaelMeche. For product enhancement requests, please contact the Technical Team and they will raise your request with the Design Team. They can be contacted by by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • December 4, 2021
  • New
    Electronic77
    Newcomer - Level 1
    2021-12-02

    I am waiting for my License! VSS3 Native! The Bill is paid but I haven't receive Serial! PLEASE HELP NOW!

    This is the 3rd time writing to you! I need answer!

     

    Bill Number:

    1522711

    Sie haben an MUSIC Tribe Commercial NV Inc. gezahlt

    Danke, dass Sie PayPal nutzen.

    Details Ihres Einkaufs

    Ihr Transaktionscode:

    46104716N9590031T

    Kaufdatum:

    30. November 2021

    Zahlung an:

    MUSIC Tribe Commercial NV Inc.

    [email protected]

    read more...
    1 11
    • Electronic77
      Josicx Der Support ist echt ne reinste Vollkatastrophe. Warte seit 4 Tagen auf meine Lizenz. Wahrscheinlich sind deren Server irgendwie überlastet? Frechheit dann nichtmal ein Statement oder irgendwas zu schreiben. ??
      • December 2, 2021
    • Electronic77
      PedroRodrigues Hi Electronic77 thank you for your post, can you please provide me your PAYPAL purchase confirmation and your ILOK USERNAME so I can check what happened. Thank you
      • December 2, 2021
  • New
    JGRSOUND
    Newcomer - Level 1
    2021-12-02

    Hi Music Tribe Members!

    At Nov 27th 2021 I brought an TC VSS4 Native (Upgrade from VSS3 native) via your website.

    I didn't get an activation card yet! My already checked my spam folder, there is nothing.

    It seems the I am not the only one having an issue with that.

    I am sure you are working hard on a solution.

    Here is my PAYPAL confirmation with

    Transaktionscode 4RN439446L657813Y

    Transaktionsdatum 27.11.2021 02:32:50 MEZ

    Rechnungsnummer 1522146

    SYSTEM 6000 NATIVE
    BUNDLE, UPGRADE FROM
    $299,00 VSS3 NATIVE USD

    Artikel 947200016

     

    What can I do?

    Best,

    JR

    read more...
    1 13
    • JGRSOUND
      PedroRodrigues Hi JGRSOUND thank you for your post, can you please provide me your ILOK USERNAME so I can check what happened. Thank you
      • December 2, 2021
    • JGRSOUND
      JGRSOUND

      Hi! My iLok user ID is "JohannesRothenaicher" (without the quotes of course) . Kindly, Johannes Rothenaicher

      • December 3, 2021
  • New
    aqui
    Newcomer - Level 1
    2021-12-01

    Hi guys! Has the entire customer service team died? I need urgent help with my TC 6000 since 9 days ago, a no one is answering my emails, nor the case CAS-505082-L4B3Z4 I wrote 6 days ago.

    I need my TC System back to finish an album, and master it.

    Please, where I need to send my request to receive my Tc System 6000 licenses back? Thanks!

     

    IT'S URGENT!!

    read more...
    0 58
    • aqui
      ChrisEdwards1 Hi aqui, upon checking your case I can see a response was sent out on 01/12/2021. Could you please just confirm this was recieved? Please check your spam/junk folder as on occasion we have seen responses route to these locations. If you cannot find the response please let me know and I will request it be resent.
      • December 1, 2021
    • aqui
      aqui

      Hi there, the only thing I can see is that my case has been defined as solved. But, no, there is no answer in my inbox, nor in my junk or spam folders. Please, could you resend me that code urgently. Actually, could you paste it here?

      • December 2, 2021
    • aqui
      aqui

      Apart from that... and I'm talking now as the computer engineer I am, What's is Message and Tickets area for? What's the meaning of these areas? Supposedly, you should be writing there the answer to our cases, so that us, the users, can get online the answer to our cases, instead of be waiting for an email getting our inbox that even can get the spam folder instead. It's crazy! Well, I accept that your system can send a message to my email letting me know that you have an answer waiting for me in your ticket's service... But the message/answer itself sent by email and the Message and Tickets area being completely empty? That's insane man, and please, give your engineer my congratulations! I'm kidding, of course! LOL

      • December 2, 2021
    • aqui
      aqui

      Please, resend me that email, and PLEASE, explain your programmer that the concept of this new musictribe platform is a complete fail. Please, re think this or you are going to lose lots of potential clients.

      • December 2, 2021
    • aqui
      aqui Just to show you, this is what I see in my Tickets area and message area. NOTHING!
      • December 2, 2021
  • New
    Chappellj
    Newcomer - Level 1
    2021-12-01

    Good morning,

    I just purchased a Plethora X5 and it is fantastic.  The sounds and effects are beyond anything I have had before.  I have watched a lot of the videos and I have no complaints, everything operates just like it should.  Firmware updates are easy and the TonePrint app is amazing.  It is a great edition to my TC Helicon Harmony V100.

    I was wondering if there would be plans to add external Midi sync, so that an external drum machine can sync with the Looper like the Ditto X4 and Flashback X4 can.  It would be an awesome feature as that is the only thing I am not currently able to do with this pedal.

    I appreciate all of the support for this and other TC projects, especially with all of the worldwide supply chain issues and the effects of Covid on the workplace.  Keep up the good work.  Joel

    read more...
    0 22
    • Chappellj
      TC-Mike Hi Joel, sorry for the late reply and thank you for the kind words . Midi Sync for al time-based Fx and for the Looper are high on the feature request list for the Plethora X5 but there is unfortunately no timeframe avalable.at this point.
      . Best regards and stay safe, Mike
      • December 10, 2021
  • New
    DougBGT6
    Newcomer - Level 1
    2021-11-29

    I love this thing! I've been playing with it for a week it's great. I've updated the firmware and I've been down loading Toneprints from the app.  I look forward to updates, but for the moment I'm happy. Except, the flashing light on the Flashback, I know what I've set the delay to, I can hear what I've set the delay to, I don't need a light strobing at me. On the news they warn you if a report with flashing lights is coming up. Have I missed something? Can I turn this off? Otherwise it's a plaster over the light.

    Doug

    read more...
    0 10
  • New
    MilanRadjen
    Newcomer - Level 1
    2021-11-26

    How can i get further from trying to connect to Pay Pal?? Is it TC problem or what?

    1 11
    • MilanRadjen
      ChrisEdwards1 Hi MilanRadjen, Is it possible to expand further on the issue you have encountered as it is currently not fully clear? If you can provide any screenshots that may be of great help.
      • November 26, 2021
    • MilanRadjen
      PedroRodrigues Hi MilanRadjen, please check you case as I have replied to your assistance request as well as on your original post above. Thank you
      • November 28, 2021
  • New
    yann_
    Regular Contributor - Level 1
    2021-11-25

    Signature presets, for the Midas peq3000, dyn3000, Brickwall HD, Master X HD... 

    more presets for all of them please... Curious what other can get out of it. 

     

    1 17
Go to page