Statistics

285,529 members
167,509 posts
  • New
    chenaux123
    Newcomer - Level 1
    2022-05-20

    Hey folks,

     

    One of my Tannoy Gold 8 monitors stopped working yesterday and I wonder if it is just a blown fuse.

    But I can not find a fuse near the power input.

    Anyone know where the fuse is found?

    Thanks,

    eric

    read more...
    0 1
    • chenaux123
      Nigel67 Hi chenaux123. The fuse is internal on the switchmode power supply. If the unit is under warranty, I would advise filling out a technical support ticket and getting the unit repaired. If you try repairing the speaker yourself and it is more than the fuse then the repair centre may notice that the unit has been opened and a repair attempted which voids the warranty. To fill out a ticket, click on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • May 21
  • New
    Keff001
    Newcomer - Level 1
    2022-05-21

    Yoh Team, just got the KXD15, set it up and thought lets give these pre sets a try. So, 100 odd presets, no listing of what does what. Web not much help, has anybody got a list of the presets that they would like to share. I'd be appreciative if such a beast existed.

    Regards Keffo

    read more...
    0 1
  • New
    Elinor
    Newcomer - Level 1
    2022-05-12

    Hi, how do I get the harmony to sound on key to match my voice. Also how do I connect my guitar correctly. Thanks. 

    0 7
  • New
    ayaishidavocal
    Newcomer - Level 1
    2022-05-17

    Hi! I have a problem with mounting Perform VE to mic stand. I went to local music shop and tried to mount it to 3 different mic stands, but non of them worked. They were standard mic stands, but they were too wide to mount. It made me think it might come with a wrong part and it's because I bought it in Japan? Also do you have specific mic stands that you recommend?

    I already watched a Mic Stand Mount Tutorial on youtube. I just have a hard time to find a mic stand which fits to the Perform VE. 

    Please let me know if you can help me! Thank you so much! 

    read more...
    0 14
    • ayaishidavocal
      NicJonesMT Hi There.
      The Mic Mount is universal and should clip onto most stands. It is a bit stiff/tough to clip on as this prevents the VE from slipping once mounted.
      If the Mic stand is too thick on the base section, try extending the stand up and mounting to one of the higher segments.
      • May 18
  • New
    bobgray123
    Newcomer - Level 1
    2022-05-16

    I just purchased a ditto looper and am trying to determine if the firmware is up to date. Attempting to run the firmware update program on Mac I discover that the update program to do this is outdated. Can you help?

    0 7
    • bobgray123
      NicJonesMT Hi Bobgray123.
      We have raised this with the development team. At this time the only option would be to run the updater on a Mac with an older Operating system or to run the updater on a PC.
      • May 18
  • New
    Denny1
    Newcomer - Level 1
    2022-05-17

    Can anyone tell me where I can find tutorial videos for the latest version of software for I Pad? please. 

    0 7
  • New
    Boydsongs
    Contributor - Level 2
    2022-05-13

    Hi,

    I have 2 VL3's and mostly love them - one has started acting up, and is unusable, and I can't find anyone to service it. The display flashes on powerup, and if it happens to load - it starts flashing erratcally duting operation. HELP!?!

    read more...
    0 5
    • Boydsongs
      NicJonesMT Hi Boydsongs.
      Can you please click support at the top of the page and submit a technical support ticket. From there we can then advise you further.
      • May 15
  • New
    Aedaan
    Newcomer - Level 1
    2022-05-14

    Hey,

    I just bought a Plethora X5 and I ran into some problems:

    1. Sometimes it randomly restarts.

    2. It's quite noisy, especially with the compressor (so very much), tremolo and vintage echo. Some serious buzzing or white noise. It gets even more noisy when it's connected to the computer.

    3. Apparently I cannot get some pedals to be together: some effects appeared as "grayed out" (both in the pedalboard and in the app), and the app tells me that they are "not audible". For example, I could not get a compressor and reverb together, which sounds really odd.

    And yes, it's upgraded to the latest firmware (1.3.11), and I have restarted it many times.

    So...what is happening? Am I missing something? Is this unit flawed?

    Thank you

    read more...
    0 8
    • Aedaan
      NicJonesMT Hi Aedaan.
      Can you please click support at the top of the page and submit a technical support ticket.
      • May 15
  • New
    JerryCallo1
    Newcomer - Level 1
    2022-05-15

    I just want to say this is the worst technical support I have ever experienced. I have a legitimate issue with my product and there is no one to help. I will definitely never be buying a product from this company again.

    1 13
  • New
    Milcastro
    Newcomer - Level 1
    2022-05-11

    hello guys! Just ask me for advice on what to do next, I already got the Ticket Number.

    0 2
Go to page