Statistics

293,992 members
177,049 posts
  • New
    farcompton
    Newcomer - Level 2
    2022-08-11

    Hi, I would like to find a power amp to go in my iP1000 sub cabinet. I sent the amp to a repair shop a long time ago and at the time, they did not have a schematic to fix it, so they sent it back to Turbo Sound. Turbo Sound delivered a new unit to me, but I have this near new condition cabinet and tower that I can't use.

    If anyone has a working iP1000 amp let me know.

    Thanks,

    Farley

    read more...
    0 0
  • New
    Aks123
    Newcomer - Level 1
    2022-08-10

    My i-nuke 12000dsp amp blew up (sounded like fireworks) and now I need parts for it. Where do I get the power control board or all the parts needed to fix the amplifier. I opened it and saw a few resistors and diodes burn but I'm yet to carry it to a certified tech for a full parts list. So please assist me to get my amp up and running again........Ps- I have a video of how inside looks after the blowout......

    read more...
    0 10
    • Aks123
      Nigel67 Hi Aks123. You can purchase parts through our local authorised service centres or if there isn't one in the country that you reside, please contact our Super Partner for your country. Please go to the following link and select the country to find your service centre or click the 'Store' option to find your local Super Partner https://www.behringer.com/buy.html?type=POS Many thanks
      • Tue at 11:01 PM
  • New
    Dadolg
    Newcomer - Level 1
    2022-08-09

    Hi there!

    I have a problem with one channel of fp10000 - CPL red led staedy on  with no audio present on input and no loudspeaker connected.

    I tryed  if it still works and it do, but significantly lower level.  red led goes on few seconds after powering.. fan does not go in high speed.

    Any ideas? thaks for reply!

    BR, Damir

    read more...
    0 2
  • New
    djtetei
    Newcomer - Level 1
    2022-08-05

    Currently Behringer power amplifiers power ratings are expressed using the term "max power" and Behringer officially states that "you can expect the RMS/continous power rating would be "around" half the declared max power rating".

    What does "around" half really means? It is "around half" at least or "around half" at most?

    Specifying "Max power" only for a power amplifier could mean that its continous long term power rating may be anywhere over "around half" or under "around half", which makes it difficult to design and calculate a sound system and to choose the proper power amplifier for the loudspeakers for which the continuous and peak power ratings are known.

    What methods or guidelines does Behringer use or follow to determine the power rating of its power amplifiers?

    Are amplifiers tested with sine wave test tones at different frequencies inside the supported bandwidth?

    Are amplifiers tested with pink noise (what crest factor) inside the supported bandwidth?

    Are amplifiers tested with both or all channels driven?

    What is the maximum THD allowed during the power rating procedure?

    What is the resolution of the digital signal processing units used on the power amplifiers with DSP?

    Thank kindly!

    read more...
    0 8
    • djtetei
      WilliamR Hello, Please click on the support link above and create a tech support case and an agent will get back to you ASAP.
      • Aug 5
  • New
    ColinRD
    Newcomer - Level 1
    2022-08-05

    Hi gang,

    I have a C10:8x amp that appears to be sending signal crossing over to channels it shouldn't be on (proper signal on B, appears to be bleeding to A sporadically). I have shifted the wiring at the back gently and it appears to have removed the issue but I am wondering if anyone has experienced the internals of the amp malfunctioning to cause bleeding between channels. Would a power cycle of the amp be advised?

    Thanks!

    read more...
    0 2
  • New
    Ythg
    Newcomer - Level 1
    2022-08-04

    Hello,

    I have followed the manual's instructions for setting the power amp in bridge mode (dip switches 4-5 OFF, dip switches 6-7 ON). My signal chain is as follows:

    Bass guitar > Sansamp RBI > Behringer EP2500 > Gallien-Krueger 410SBX Plus (8ohm, 800W RMS)

    I have tried using both the Speakon and 1/4" speaker outputs, but the volume that comes out is very low, even with the output level on both the Sansamp and the Behringer at maximum.

    Any help appreciated. 

    read more...
    0 72
    • Ythg
      Paul_Vannatto The Speakon connector has to connect the speaker wire to the 1+ and 2+ for bridge mode. The default speakon connection is 1+ and 1- (for non-bridge mode). Dismantle the speakon connector and change the wire on 1- to 2+.
      • Aug 4
  • New
    dbrigham913
    Newcomer - Level 1
    2022-08-02

    The blue light on the front of the speaker is flashing and no sound comes out.

    0 11
    • dbrigham913
      Nigel67 Hi dbrigham913. What is the power LED doing on the rear of the speaker? Is this flashing as well? In which position do you have the switch for the front LED? If it is in Lim, try moving it to the Off or On position and see if you get audio from the speaker. Either way, it would appear that the speaker has a fault. Please fill out a Technical Support ticket and include the serial number of the speaker and your proof of purchase (invoice) so we can advise further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • Aug 2
  • CesarBua
    Contributor - Level 2
    2019-05-20

    Hi,

    A year ago I bought two Lab Gruppen IPD2400.
    After a few uses, now one of them does not turn on.

    When I plug it to AC, it does not go to stand by mode. And does not turn on.
    Fan runs, ethernet socket shows activity lights blinking, and Intellidrive Controller can connect with a valid IP address, but does not synchronize. 

    Seems that DSP is not working.

    Anyone has experienced something similar? Any ideas?

    Very frustrating. After investing money on top class brand amps, it only lasted a year.

     

    Regards

    read more...
    0 330
    • CesarBua
      wsl

      Hello


      Same problem here with a new ipd2400 at first start-up.


      No stand-by mode , black display , but fans at full speed. After 1 hr I cut the power en reconnect the power cord. The amp starts normal.


       

      • January 21, 2020
    • CesarBua
      benilange Hello CesarBua, were you able to solve the issue? I have the same issue on one of my IPDs.
      • Jul 31
  • New
    panpro
    Newcomer - Level 2
    2022-03-22

    I need detailed Information for this parts:

    E5:4 / (SN 19827416)

    LS OUTPUT Connector

    Class 2 Wiring 

     

    E12:2 / (SN 38209446)

    Balanced Outputs connectors

    Lautsprecher Class 2 Wiring connectors

    I need part number and any detailed description, that i can deliver it anywhere

    It is urgent

     

     


    View Attachment
    read more...
    0 73
  • New
    Zenonite
    Newcomer - Level 1
    2022-07-28

    Hi,

    We are using a PMP 6000 Power Amp/Mixer with 2 8ohm Speakers. We want to discard these speakers and run powered speakers from the line out.

    Is it possible to run the PMP 6000 with out speakers attached to the power amp outputs.

    Thanks

    Jez

    read more...
    0 3
    • Zenonite
      WilliamR Yes, you can run powered speakers from the line out of your PMP6000 without the mains hook up.
      • Jul 28
Go to page