Statistics

298,812 members
182,477 posts
  • New
    Cblair819
    Newcomer - Level 1
    2022-08-03

    Does anyone know if the Midas m32r has a Testing mode?     Think of an SC48 with its test mode.   

    0 9
    • Cblair819
      Paul_Vannatto No it does not
      • Aug 3
    • Cblair819
      KevinMaxwell Years ago we thought we had something wrong with one of the M32 mixers that we had and support told us a key combination to press to put it into a self test mode. I don't remember what the key combination was but I will see If I can find out for you. and then see if it works with the current firmware.
      • Aug 3
    • Cblair819
      KevinMaxwell Well the fellow I work with that owns the 2 Midas M32 mixers that I have regularly used found the Key combination to put the M32 (I assume that it should work on the X32 also) into the Surface Test mode. It is - with the mixer off press and hold the Home, Meters, Routing and Setup buttons all at the same time and turn on the power while holding them. Let them go when you see the mixer start in the test mode. I am not 100 percent sure how you are SUPPOSED to get out of it but turning it off and then on again it comes back on like it should.
      • Aug 6
  • New
    rogerpedrol1
    Newcomer - Level 1
    2022-08-02

    Hi there, 

    So we have 3 HD's in a Broadcast environtment and using automixer in AFL insert and SOLO config on PFL. I was expecting to have SOLO PFL but the insert of this automixer in AFL is causing SOLO following AFL too. Is that normal behaviour? Do other consoles work that way?

    Best regards,

    roger 

    read more...
    0 12
  • New
    mhbidadi94
    Newcomer - Level 1
    2022-07-25

    Hello.

    I bought this MR18 from December 2021. It's unstable.

    It's mean at switch on gain is +27db , sound is good then switch off and again at switch on gain is +27db , sound is low !!
    Also FX faders one time -15db are good. Next time switch on FX are not good at -15db but FX at 0db are good !!

    Sometimes I have no signal at all.
    Sometimes the signal is very weak and cannot be heard at the output.

    Sometimes the volume gain is high, sometimes the volume gain is low, no matter how much I increase it, it is still useless
    I also did a factory reset, but it was useless
    There is no difference between any of the inputs, microphone, aux, there is no difference
    As I said, sometimes there is no signal at all.

    The supply of parts is not my problem, it is your problem and you should fix the problem. Otherwise, I will file a legal complaint against you.
    My MR18 has 3 years warranty, so I will come to Dubai next week. Please take my device back and give me a new one.

    read more...
    0 19
    • mhbidadi94
      Nigel67 Hi mhbidadi94. You will need to contact the shop that you purchased the unit from and ask them to repair the unit under warranty. If you would like to talk to our Technical Team with regards to your issue, then please raise a Technical Support ticket. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • Jul 25
      • unstable Midas MR18
        mhbidadi94 Hi Nigel67
        I mentioned my MR18 problem to the prolab store and also email [email protected]
        But still none of them gave me any correct answer about which country and which store and to which person I should return the mixer.
        • Jul 25
      • unstable Midas MR18
        Nigel67 You need to contact the store that is on your invoice for when you purchased the unit. Contact them and ask them to repair the unit under warranty.
        • Jul 25
  • New
    jacobi184
    Newcomer - Level 1
    2022-07-20

    I have a single fader that has stopped moving when changing pages or fader flipping. The fader still works. The console still registers the movement when I manually move it up and down but it won't budge when changing which causes tons of problems. Any idea what could be the cause of it?

    read more...
    0 14
    • jacobi184
      KevinMaxwell It sounds like the belt slipped off of the positioning motor. Do you know if there was a time when the fader wanted to move to a different position (like when switching layers) and there was something in the way and the motor may have fought to make the change. I think that can cause a belt to slip off or for the motor to have a problem.

      There are some mixers that will fight to get the fader where it is supposed to be and other mixers that if something is in the way it will interpret that as the new position it needs to be in and not fight it.
      • Jul 21
    • jacobi184
      MarkNorgren FWIW, I just ordered a replacement fader from Sweetwater for mine. I was told a 4-5 month wait! I would check the belt as well.
      • Jul 23
    • jacobi184
      jacobi184

      Thanks for the replies. It randomly started working again. Which makes me worry more because now I'm not sure why it stopped and why it started back...

      • Jul 25
      • M32 Fader not automatically moving
        KevinMaxwell Strictly a guess but maybe the fader belt slipped just enough that is got lodged on the rim of one of the pulleys and then it slipped back down eventually when the fader was manipulated. How did the fader feel (when it wasn't working correctly) compared to the other faders when you moved it? Was it WAY smoother (no resistance at all) or was there a slight stiffness to it?
        • Jul 28
  • New
    SoPro
    Newcomer - Level 1
    2022-07-20

    I'm specifying a system for a boat that has performers on its deck while they go on local sightseeing excursions or private parties. It would seem ideal to use an M32C in a rack below decks with a DL16 that could plug into either of 2 ethercon jacks at the 2 designated "stage" areas.  Problem is that they'll need main outputs at the rack to feed amplifier(s) and should be able to use a background music source at the rack, too.

    Unfortunately, the M32C itself has absolutely no analog I/O except for a pair of aux outs intended for IEMs (I think.)  I don't see a way to directly feed it a BGM source or to connect main outs to rack mounted amp(s).

    Can we add a DN4888 I/O at rack and is it compatible to be used simultaneously with the stage DL16?  Can the DL16 and the DN4888 simply connect to the 2 rear ethercon jacks of the M32C?

    Thanks

    Randy

    read more...
    0 25
    • SoPro
      Paul_Vannatto The DN4888 is a StageConnect stagebox which will not work with the M32 (or X32), since those consoles do not have a StageConnect port. It would be better to either get a Behringer SD8 to use with the M32C or get an X32 Rack instead of the M32C and a stagebox.
      • Jul 20
    • SoPro
      theog1989

      The DN48 series of hardware feature Ultranet, which is compatible with the M32/X32.

      • Aug 18
  • New
    BodieDoyle
    Contributor - Level 2
    2022-07-20

    I cannot find anything on Midas' website, or promotional material, as to whether the 16 mic pre-amps have 48v phantom power available to them; plenty of mentions of passing power to the unit itself, but, nothing regarding whether the pre-amps have 48v?

    read more...
    0 6
  • New
    Axl666
    Newcomer - Level 3
    2022-07-15

    Hi,

    it looks like I'm too dumb for that, but where do i have to click to see my registered products?

    Thanks for your help!

     

    cheers!

    0 7
    • Axl666
      Nigel67 Hi Axl666. At the present time it is not possible to see all your registered products vi your account, but this is coming in a future release. If you send in a Technical Support ticket, then we will be able to make a print off of all the products you have registered. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • Jul 17
  • New
    shu2900
    Newcomer - Level 1
    2022-07-17
    0 24
  • New
    Zabass
    Newcomer - Level 1
    2022-07-15

    Hello, I am looking for this piece to replace the old one that does not work anymore, impossible to find it on the internet, thanks for your help!!!

    MKT-PSU-1 for Venice U32

    0 12
    • Zabass
      Nigel67 Hi Zabass. Please advise in which country you reside and I will be able to help you further. Many thanks
      • Jul 16
      • MKT-PSU-1  for Venice U32
        KevinMaxwell I will guess France since their email address ends in .fr
        • 2
        • ·
        • Jul 16
      • MKT-PSU-1  for Venice U32
        Nigel67 In which case, please contact EVI Audio France and they will be able to help you further. Please make sure that you tell them it is for a Venice U 32 as there were three different versions of this power supply. You require a MKT-PSU-1V1.

        EVI Audio France SAS

        Parc de Courcerin, Allée Lech Walesa Parc de Courcerin, Allée Lech Walesa

        Lognes

        France 77185

        +33 164 808468

        www.eviaudio.fr
        • 1
        • ·
        • Jul 17
  • New
    cristtiah
    Contributor - Level 1
    2022-07-15

    Hi anyone knows where we can buy MIDAS stageboxes in the US, or rent one? Thanks i appreciate it.

    0 3
    • cristtiah
      Paul_Vannatto If anyone will have them, it will be Sweetwater
      • Jul 15
    • cristtiah
      cristtiah

      they are not sure when they are getting it either, saw some in ebay but twice the price

      • Jul 15
Go to page