Statistics

306,337 members
190,724 posts
  • New
    howiemco
    Newcomer - Level 1
    2022-03-30

    Can I use a 1/4 Y cable to run 2 cabinets with my PS1 - EVH 2x12 & EVH 1x12

    Thanks,

    Howie

    1 14
    • howiemco
      howiemco I am using a 5150 Iconic amp head.
      • Mar 30
    • howiemco
      NicJonesMT Hi Howiemco
      I wouldnt recommend doing this. Most splitters are designed to work with Line/Inst level signals, not Power amp outputs. Doing so could potentially damage your equipment.
      • Mar 31
  • New
    danielebardi
    Newcomer - Level 1
    2022-01-20

    Hi all,

    i have just purchased a HA-40R, but i need a compatible food switch pedal (to switch between Clean channel to Overdrive channel).

    Can you help me?

    Thanks in adv

     

    Daniele Bardi

    0 22
    • danielebardi
      Dale_M Hi there, I cannot see a Behringer footswitch for this but looking at Muziker who sell these amps, they reccomend users often buy this one: https://www.muziker.co.uk/soundking-al-201-w
      • Jan 20
    • danielebardi
      Clean I bought a regular footswitch for my HA-40R, but it automatically switches off the reverb when plugged in. Is that a problem more people encountered, or is it dependent on the switch pedal?
      • Feb 21
  • New
    bijnos
    Newcomer - Level 1
    2022-02-17

    Hi. Please HELP ... Thank you so much ...

    Will gladly pay $20 for the " PARTS LIST " of  TC Electronic BG500 custom bass amp combo .

     

    0 43
    • bijnos
      Dale_M We are not able to share this with non partners of the business. If you need spare parts for your BG500 simply go to the support tab and raise a Parts ticket.
      • Feb 17
  • New
    syamilaliff
    Newcomer - Level 1
    2022-02-07

    Hi,

     

    May I know how do I buy the replacement part for BDM1?

    It is for Bugera 6262 Non Infinium

    0 23
    • syamilaliff
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact our parts team by clicking on Support and then Spare Parts.
      • Feb 7
  • New
    morganGary
    Newcomer - Level 1
    2022-01-11

    I have no output to my speakers from my Guitar Amp.

    The Technical Department informed me it could be my Pre amp valves.

    The pre amp valves consist of 1x12AX7A, 1x 12AX7B and 2x 12AX7C

    On the net it just sells sets of four 12AX7 not numbered A, B Or C.

    Can just put the set of four Valves which I can buy or do I need A,B and C type Valves and if so where can I get them.

    All the best Gary

    read more...
    0 24
    • morganGary
      WilliamR Hello, William from the music tribe here. The Bugera 333 Infinium will take any combination of 12ax7 tubes.
      • Jan 11
      • Bugera 333 Infinium Amp
        morganGary Brilliant thank you for that. I will order today and hopefully that will resolve the problem
        • Jan 12
    • morganGary
      morganGary Brilliant thank you for that. I will order today and hopefully that will resolve the problem.
      • Jan 12
  • New
    Amplifyus5150
    Newcomer - Level 1
    2021-12-28

    When I turn on the gsystem, it defaults to a 00 entry 

    when i step on the bottom buttons, it adds a 00& a small 1 or 2 etc etc beside the 00. Only the 00/1 button lights up. If I step on the 2nd or any other button beside the 1st....they dont light up.  
    is my gsystem defective or am I missing something? 

    read more...
    0 31
    • Amplifyus5150
      WilliamR Hello, William from musictribe here. Please click on the support button above and submit a tech support ticket. If you can send a video showing this behavior, this will be very helpful for the tech support agent in helping you resolve this issue.
      • December 28, 2021
  • New
    angstema
    Newcomer - Level 1
    2021-12-26

    Hi all,

    when i put on the Mp3 jack connection my phone and play some music from spotify or youtube, my Behringer don't work. Why? Maybe the Mp3 input is broken? Or maybe my Behringer can't play music from external devices? Can someone help me? If the same phone connect with a little JBL with jack cable he play music with no problems. Something is wrong with my HA-20R.

    Thank You all!! 

    read more...
    0 19
  • New
    MikeSwift
    Newcomer - Level 1
    2021-12-25

    The fuse blew in my Bugera 1990 Head.  I replaced it with a T3.15AH250V (as specified in the manual).  After replacing it the amp powers on,  I can see power amp tubes glowing.  But no sound and no light coming from the channel switch.  Do you know what is going on with this amp?"

    read more...
    0 38
  • New
    baldypr
    Newcomer - Level 1
    2021-12-14

    I need j65-00001-02269 power traf for T-50, where I can purchase

    0 16
    • baldypr
      KyleJohnson Hello, Kyle here with Music Tribe. To order parts please click on Support and then Spare Parts.
      • December 14, 2021
      •  Bugera T-50
        baldypr Thanks
        • December 14, 2021
  • New
    underdog
    Newcomer - Level 1
    2021-11-30

    I AM LOOKING FOR A KNOB FOR THIS AMP. CAN ANYONE KNOW WHERE TO GET THEM. THANKS

    0 14
    • underdog
      Nigel67 Hi underdog. Please submit a ticket to our spares team and they will get back to you with pricing and availability. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. Many thanks
      • December 4, 2021
Go to page