Statistics

306,346 members
190,734 posts
  • New
    rmaczis
    Newcomer - Level 1
    2022-12-01

    Using an Eventide Powermax (600mA) to power x5 and a few drive pedals.  Running Octonaut Hyperdrive and Vertex Dynamic Distortion pedals thru x5 Effects Loop.   Power occasionally cuts out during performance and then automatically reboots.  Have upcoming gigs...need advice fast!

    read more...
    0 9
    • rmaczis
      PedroRodrigues Hi rmaczis, thank you for your post, you must confirm that you power your PLETHORA X5 with the correct specification to avoid any issues. The unit must be powered using a Standard 5.5 / 2.1 mm Positive Centre Negative PSU that supplies 9 VDC, offering a minimum of 600 mA, as stated on the manual below. Please confirm that the power supply you are using fits these requirements.
      • Dec 4
  • New
    bgordonmiller
    Newcomer - Level 1
    2022-11-27

    Help! I'm a Mac user, and when I download the firmware update, it's a ".bin" file -- I've never heard of that before. I checked w Mac support, and they said it's not Mac compatible.

    I've looked around the TC Electronics website, to see if I can find Plethora x5 firmware updates for Mac, but so far, no dice. 

    Any help is much appreciated!

    read more...
    0 3
    • bgordonmiller
      ChrisEdwards1 Hi bgordonmiller, the .bin file is the correct file to update your Plethora X5. Instructions on how to use this file are found within the firmware release notes a PDF Copy of this is available via the product page, however, I have included these below for you:

      1. Connect your Plethora X5 to your computer with the included USB cable.
      2. Plethora X5 will show up as a mass storage device on your computer.
      3. Drag and drop the firmware “.bin” file onto the root of the PLETHORA mass storage device.
      4. Disconnect the USB cable once transfer is complete.
      5. Power cycle your Plethora for the firmware upload procedure to start.
      6. Wait until the update procedure has finished loading.

      DO NOT remove the power from your unit whilst the update is in progress.

      NOTE: We recommend disabling spotlight INDEXING and emptying your TRASH folder before updating
      when using MAC to transfer the “.bin” file to your Plethora unit.

      NOTE: If your unit has 1.0.101 and you want to update to 1.2.18 or newer, then please update to
      1.1.55 first.

      Please note that to get max benefit from the new effects, you will need the latest version of the
      Toneprint app 4.5.5 or newer that can be found in the app store, google PLAY store or downloaded for
      MAC or PC here:
      • Nov 27
  • New
    DanielCosta
    Contributor - Level 3
    2022-11-08

         Hi there! I need more! I've been thinking on upgrading to the Boss RC-600 but I still believe that there could be something new from TC Helicon. Can anybody show me the light?

    0 2
  • New
    BobDem1
    Newcomer - Level 1
    2022-10-26

    Every major music store is back ordered.  When will you be shipping new Play acoustics 

    0 4
    • BobDem1
      PedroRodrigues Hi BobDem1, Thank you for your post, as we do not sell any product directly to end users, it falls on our Partners to manage all the shipping process directly. For information on this matter I would suggest to follow the link below and contacting our partners in your Region: https://www.tc-helicon.com/buy.html. I hope this helps. Thank you
      • Oct 27
  • New
    ShaunCam
    Newcomer - Level 1
    2022-09-13

    Hi.

    After living with this pedal, I learnt to live with its querks. It sounds great but there are some extremely basic features that make no sense in a live setting using with  a pedal switcher with MIDI:

    1) When a board is selected via Program Change signal, there is a lag, which I now understand from previous TC communications about time needed to change boards. The most frustrating part is that if the PC is sent for the currently selected board, it mutes as though a new board is selected, so even using just 1 board for a variety of songs requires a work-around. Is it possible to fix this so the board doesn't refresh?

    2) Master midi clock sync, please.

    3) MIDI activation for Tuner, please.

    4) MIDI access to 2nd function on footswitches for tap tempo/bpm sync, please.

    Most of these suggestions should enable us to not require changing boards so often and having the hassle of the signal muting.

     

    Great product though. What it does well, it does very well!

     

    read more...
    0 16
    • ShaunCam
      WilliamR Thank you for your suggestions, I have passed them on to our developers.
      • Sep 13
    • ShaunCam
      ShaunCam I'm assuming that TC never put the correct opto-coupler into to midi in circuit of the Plethora to be able to read the 24 pulse / beat signal, right? This is probably why they can't sort it out... Suggestion: Plethora X5 version 2, with the right circuit, in black, please
      • Oct 21
  • New
    Jasonphelan82
    Newcomer - Level 1
    2022-10-15

    My computer died recently (straight after I got the pedal and made some presets which...the Editor was very annoying to figure out (not particularly user friendly...for me anyway) - so I am curious, now that I have my computer back up and running - is it possible to import the TP1, TP2 and Tp3 presets to the App I have re-downloaded and installed?

    read more...
    0 3
    • Jasonphelan82
      NicJonesMT Hi Jason. Unfortunately no. The communication from the pedal to the TP app is bi directional, meaning that the app cannot read the settings that are stored on the pedal.
      • Oct 18
  • New
    Herb1
    Newcomer - Level 1
    2022-07-13

    Hi Everyone, 

    Does any one know of a underboard multiple 9V power supply (like the Styrmon Ojai or Truetone 1spot) that has 600mA in at least one of its power outputs to provide power to the TC Plethora X5 which is 600mA?

    Can only seem to find ones that are 500mA or below have checked all major brands - or is there another solution I maybe missing to neaten up power to Plethora and pedals all in one under pedalboard

    read more...
    0 27
    • Herb1
      PedroRodrigues Hi Herb1, we always advised the to use the original PSU supplied with your Plethora X5 that supplies the unit with a standard 5.5 / 2.1 mm 9 VDC, centre negative > 600 mA. Effectively I also did some research and I was not able to find a multiple power supply that offers more than 600 mA as the Plethora X5 requires.
      • Jul 14
      • >600mA power supply for Plethora X5
        Herb1 Hi Pedro
        • 1
        • ·
        • Jul 14
      • >600mA power supply for Plethora X5
        Herb1 Thank you for your fast reply, ok thanks - was trying to find a longer cable than the orginal PSU and also only have the one power lead heading into the pedal board.
        • 1
        • ·
        • Jul 14
      • >600mA power supply for Plethora X5
        Herb1 I did just find that new Ciok DC7 power supplyto have 660mA outlets would this be suitable to use?
        • 1
        • ·
        • Jul 14
      • >600mA power supply for Plethora X5
        jlcaze Yes I use the DC7 with the plethora. It works fine.
        • Jul 20
    • Herb1
      AZCoyoteGear There are also some cables that combine two outputs to add their output together so two 300 can be used to sum up to the 600
      • Jul 15
    • Herb1
      karl1672 I use a mini ISO brick (MXR) that has an available 9V / 800 ma output - works great with my X5
      • Oct 13
  • New
    Copachad
    Newcomer - Level 1
    2022-10-10

    I love the BodyRez in the TCHPA. I'm mostly a strummer and lead picker. I use a pick all the time. Do you recommend using BodyRez at 100 percent?

    0 8
    • Copachad
      NicJonesMT Hi Copachad.
      It's ultimately down to your own preference. I'd recommend playing with the setting until you find something that suits your play style and needs.
      • Oct 11
    • Copachad
      Copachad

      I understand that but I was just curious what TCH actually recommends since they were the one's who made the unit in the first place.

      • Oct 11
  • New
    derrickp1985
    Newcomer - Level 1
    2022-10-10

    Not sure if I am asking this question the right way. I want to know if there's an option to turn off that will allow the x3 to load new boards without any of the FX turned on. it's very annoying to want to switch to a new board midsong then it loads all 3 FX(or sometimes 1, or 2 or none, seems random) completely messing up your sound.

     

    Hope this makes sense, please help.

    read more...
    0 4
    • derrickp1985
      PedroRodrigues Hi derrickp1985, thank you for your post ,unfortunately there is not, the Plethora works like a pedal board and remembers the last bypass state of the FX pedals on each board and there is no way to reset all FX to bypass at board change. What I would suggest is to make copies of board with all Fx turned off or switch them off before changing to another board. I hope this helps. Thank you
      • Oct 11
    • derrickp1985
      derrickp1985

      thanks for your reply! so however i save the board(with pedals on/off) is how it will enable when i switch boards?

      • Oct 11
      • X3 - can you make it not engage FX to be turned on/off when switching boards?
        TC-Lars Hi derrickp1985

        How you leave the board (with pedals on/off) when you navigate to a different board (or power-cycle the product), is how that board will be loaded the next time.

        Sort of like how the TonePrint single-pedals remember their state (on/bypassed) when you power-cycle them.

        So if you end your gig on e.g. board #3, with all FX turned on for that last ending with all effects active and stomping the mash switch on your Tape Echo style delay, and then turn on your pedalboard at the next rehearsal, still on board #3, then all the FX will be 'on' for that same board.
        • 1
        • ·
        • Oct 25
  • New
    mustelphia
    Newcomer - Level 1
    2022-09-29

    I uploaded the Factory Presets into my TC-Helicon Duplicator (Factory Tight & Factory Loose) and now I can't get the latest presets with higher volume back. I can only see 3 packages on the cloud (Octave Down, Octave Up & Original Factory Presets) and neither my presets or the cloud will update no matter how many times I update the firmware. Please help me, I already tried uninstallying and installying again Voice Support 2 and the missing presets just won't show.

    Can someone please share the latest presets so I can import them manually to my Duplicator? without them it's basically useless.

    read more...
    0 3
Go to page