250,738 members
127,934 posts
  • New
    Newcomer - Level 1

    Helllo ireinstalled my pc butt i cant find the driver and software plz help me out!

    0 33
    • ingmar
      NicJonesMT Hi ingmar.
      All software for our products can be found on the TC Electronic Download Centre at the following link.

      There is a Small "Show all versions" option that you need to tick, and then if you search "Powercore" all available documents and software will appear.
      Please be aware that Powercore is long discontinued and we no longer officially support the platform. If the software you need is missing you would need to check on user forums to see if anyone else can provide this.
      • Jun 6
  • New
    Newcomer - Level 1

    Finally decided that, rather than fumbling and floundering around, I'd come here & ask (hopefully) the guys that know the answers...

    Bought a QX1202USB a little while back & have been using it as a quick & dirty way to listen to my guitar & play along with YouTube videos & other music tracks. So far, so good.

    However, I notice that there's a chunk of software that I can download & as I'm now wanting to do some recording using Reaper, I wondered how the "All software for Windows" could help (if at all) and, if it can, wtf do I need to do to make it work?

    It includes...

    • Audio software (Audacity & Podcasting stuff) - though I'm going to use Reaper so can probably ignore these
    • VST Effects - a zipped folder containing other zipped folders
    • VST Hosts 
    • VST Instruments - a zipped folder containing other zipped folders

    So, do I have to unzip each one in turn or can I do in one go & if so, where do I send them to and how do I use them?

    Would really appreciate it if someone could point me in the right direction as I've not much hair left that I can risk tearing it out!


    0 51
    • Fozman1959
      Paul_Vannatto Reaper is definitely a good choice for a DAW (my favorite). If you are using Windows as your OS, then the VST Effects (and maybe VST Instruments) can be used in Reaper. Understand that the QX1202USB USB output is stereo only and outputs the Main LR. So if you want to record separate tracks, you will need to pan one of the instruments/vocals hard right and the other one hard left. Then bring them into Reaper as 2 mono inputs.
      • Jun 3
  • Nyllet
    Newcomer - Level 1
    Hi, I bought the Finalizer app 2 days ago through PayPal payment, and didn't receive any confirmation e-mail for iLok registration. Added ticket CAS-117192-H9G1Z0 in Care Portal but no human answer in 48 hours. What to do next?
    0 60
    • Nyllet
      NicJonesMT Hi there,

      I have emailed you earlier today. Can you please check your spam/junk folder and let me know your iLok User ID.

      I can then manually deposit the license for you.
      • July 7, 2020
        Nyllet I've replied to your email now.
        • July 7, 2020
        Nyllet Thanks Nic, works fine =)
        • July 7, 2020
  • New
    Newcomer - Level 1

    Hi there ! need some help..


    I Bought MD4 Yesterday through paypal (order 1520199), I received the confirmation mail from paypal but a this time ive still not receive any license code.

    Please, some help will be appreciate !





    0 57
    • LevynGarner
      WilliamR Hello, I messaged you to sort this out for you.
      • May 12
      • Bought MD4 Native yesterday and still not received any license
        LevynGarner Thanks for reply I have replied to message with the requested infos !
        • May 13
  • New
    Newcomer - Level 1
    J'ai un MR18 et des problèmes avec l'application M air sur ipad (ios 14).
    Quand je sauvegarde un preset GEQ, il est impossible de le charger sur un autre bus ...
    Quelqu'un a-t-il expérimenté cette erreur ?
    Sur Android, cela fonctionne, mais l'application est moins pratique.
    0 56
  • New
    Contributor - Level 1

    is there any software available to use on a iMac to control the XR18??

    0 77
  • New
    Newcomer - Level 1

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.


    Since yesterday at least. What had happened?

    0 76
    • panamatom
      Dale_M Hi there which version are you trying to download? Mac or PC?
      • Apr 14
    • panamatom

      like it is in headline: PC

      • Apr 14
      • can´t download x-air edit for pc
        Dale_M Sorry my bad, can you share the link and I will get the developers to check out what is happening
        • Apr 14
    • panamatom

      No problem, here is the link:
      • Apr 14
  • New
    Newcomer - Level 1

    I just downloaded the new app for Windows 10 and when I click the check for new tone prints button the app locks up during the update process.

    Windows task manager shows the app as not responding.

    This is in the event viewer.


    The program TonePrint_64bit_4.4.18_4abab17.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
    Process ID: 34a8
    Start Time: 01d7301d4c9a7c88
    Termination Time: 14
    Application Path: C:\ToneprintApp_Windows64bit\TonePrint_64bit_4.4.18_4abab17.exe
    Report Id: 27d37bbc-9697-4721-8f95-5cd0e04bc33b
    Faulting package full name:
    Faulting package-relative application ID:
    Hang type: Unknown

    0 50
    • skategeezer
      WilliamR Hello, I would try deleting the app and redownloading a fresh one and see if you get the same behavior. The download you have may have just got corrupted.
      • Apr 13
  • New
    Newcomer - Level 1

    No receipt either

    ilok: tmatomas

    email: [email protected] 


    1 39
    • Tmatomas
      PedroRodrigues Hi Tomas Please log in your ILOK ACCOUNT as the MD4 HD NATIVE was activated on the Mon Apr 05 2021 11:19:26 GMT+0100 (British Summer Time). Thank you
      • Apr 7
  • New
    Newcomer - Level 1

    I feel pain every time I try and navigate this site.

    So I am trying to register VSS3 in the hope of being to download the new version (which I'm sure will be another rigmarole). I cannot register VSS3 because the brand drop-down does not work (see attached pic).

    I had to jump through hoops to even register this account, now I can't actually do anything. I cannot even create a support ticket because that also needs the brand selecting, so I cannot even contact support to tell there is an issue with the support form! Genius. 

    I woud like to add this is the most awful portal I have had the misfortune to use. Finding this forum is a chore, and I couldn't even post earlier for some reason. Please tell me someone is working on improving it.

    1 80
    • MrArkadin
      Nigel67 Hi MrArkadin. I am very sorry for the inconvenience that you are experiencing. I have notified our web team and they will be looking at a fix for the issue you are experiencing. In the meantime, I will open a case for you and send an e-mail. You should receive it shortly. Please also check your Spam / Junk folders to make sure it hasn't gone in there. Apologies again.
      • Apr 5
      • VSS3 product registration
        Nigel67 E-mail just sent
        • Apr 5
Go to page