306,248 members
190,618 posts
    Contributor - Level 1

    We updated our firmware yesterday and when we checked all of our presets that we created were deleted.  Is there any way to get them back?  We're going to create them again and save them to a flash drive in the future but I'd like to not lose that work.  I'm assuming they're gone, but I'm just wondering.


    0 234
    • NCCC-AV

      @NCCC-AV  Probably gone sorry to say. You might try reloading the old firmware version and double check but I very much doubt that will work...however nothing lost in so doing except a little of your time.

      • January 3, 2020
    • NCCC-AV

      I had the same issue. There was no way to undo it. Sorry about that. 

      • January 9, 2020
    • NCCC-AV

      I'm so glad that I joined Music Tribe tonight.  I was going to update our X32 before worship practice tonight.  I still have the flash in my pocket.  Thank you all for the thread about the update clearing all of the settings out of the mixer.  Now I know to save everything before I do the update!!!!

      Thanks again!!!

      • February 1, 2020
  • MyBones
    Contributor - Level 3

    There seems to be a bug.

    Configuring the library "Local IO", I engaged the 48 V power to some channels. When changing to the "Card Playback" configuration, the 48 V power keeps engaged, but is not shown on the panel, shown at the rear plugs lights only

    I do not want to have the 48 V power to be engaged in the "Card Playback" setup, but it seems to be copied from the "Local IO" into this.

    This should be corrected.





    1 151
  • mcfwc
    Contributor - Level 1


    I am looking for an iOS app to control the X32 Compact Digital Mixer. When I look for the X32-Mix, it says the App needs to be updated for the latest iOS. 



    0 148
    • mcfwc

      Mixing Station Pro is a good one and is available from the app store-I think it's $6 or $8 but it's well worth it and well supported.


      Many users here have this and are very happy with it.

      • January 23, 2020
    • mcfwc

      Go to the App store and update the app.  It is free.  I use the same app on my iPad and it works great.  

      • February 1, 2020
  • IanDalgairns
    Contributor - Level 1
    Hello. I have a Behringer Epx2000 amplifier. Everything was working fine until I tried some new speakers encountered a problem. Now when i turn on the unit, the 'limit' led's flash on, go off then nothing else really happens. Here is a clip I uploaded to YouTube to describe things better, the unit has nothing plugged into it during the clip :

    Does anyone know what might be occurring?
    0 1,188
    • IanDalgairns
      InactiveUser Dear Ian,

      Sorry to hear you are having difficulty with your EPX2000. I shall PM you for your contact details to get this matter resolved.

      Kind Regards,

      Fiona Hammond


      MUSIC Group

      • April 22, 2013
  • AlexLane
    Community Manager
  • BertdeVries
    Contributor - Level 2
    Is it possible to have a delay on output A or B when linking them to other speakers, or does the IQ15 only have an input-delay?
    0 398
  • ScottReedII
    Contributor - Level 1
    I'd like to use a Bluetooth A2DP lavalier or headset mic with the MPA40BT system but when I tried it with a couple of units they wouldn't pair. Is it possible to do this or not?
    1 288
  • Em1ly

    1 122
Go to page