Statistics

293,463 members
176,456 posts
  • New
    Mikey333
    Newcomer - Level 1
    2022-01-18

    A couple years ago I called TC Helicon for help setting up my Play Acoustic, a fine unit, but a real bear to set up. They helped a lot getting my rig running.
    Today I return to TC Helicon for help and see four people with headset Phone microphones/earpieces at the top of the page BUT NOT ONE SINGLE PHONE NUMBER FOR ANYONE TO CALL, as I did last time.
    Does this mean we are now only helping each other on a forum? No more live chat with a tech there? Is this a cost-cutting move?
    I'm now really doubting TC Helicon's sincerity at helping its customers.

    read more...
    1 18
    • Mikey333
      Nigel67 Hi Mikey333. I am sorry, but there is no telephone support at the present time. You can however contact our Technical Support Team through our Care Portal ticketing system, where they will help you through any questions that you have. To contact the Tech Team, please click on the Support tab at the top of the page. In the new page that opens, scroll down and click on the Technical Support tab. Fill out the ticket and a colleague will come back to you with an answer. Many thanks
      • Jan 18
  • New
    AaronJ92
    Newcomer - Level 1
    2022-05-25

    i bought a behringer um2 interface with the hopes of recording guitar. i have had nothing but issuses since day one. with trial and error including installing all 3 drivers, different cords, and differnt settings in windows 10 for a short time the nasty popping and latency issues will go away. i just woke up and now there is this terrible hiss in the background and i think ive beeen sent a faulty unit. whats worse is there is no way to contact behringer and this website wont accept my proof of purchase because the file is too big. im not super tech savy and this is ridiculous that there is no phyical number to call for instances like this. what can i do at this point i want to send this back for a new one and i literally cant take any road to do so. both behringer and this website should make it easier to contact them and the that proof of purchase tab is real bs any file size should be accepted...

    read more...
    0 10
  • New
    Drtr
    Newcomer - Level 1
    2020-11-13

    T C Helicon Voice Live Extreme3. After turning on the processor, I try to go to the "layers" like the instructions say.  That means pushing the "looper" button.

    All I have is a red led light.  I can not get a blue or purple led light anymore.  Have I pushed something to stop the blue and purple lights from activating?

    Or is the processor no longer working and if so, where do I send it for repair?

    read more...
    0 34
  • New
    Nandopr81
    Newcomer - Level 1
    2022-01-02

    Good Morning everyone and happy new year!!!Well the question is...Can i use my Bugera 6262 Infinium with the Ps1 powersoak?I know that the Ps1 it's a 100w Max power attenuator and the 6262 it's a 120w amp but,i've heard something about the real power of the 6262 it's 85 R.M.S Watts and could fits perfectly with the Ps1 powersoak so...Can anybody tell my something about this?

    read more...
    0 37
  • New
    YaizaCuenca
    Newcomer - Level 1
    2020-12-12

    Hi there! Anybody knows how to restore the fabric values of this relic? Thanks!!?

    0 60
  • New
    AaronMoore
    Newcomer - Level 1
    2021-01-12

    did they do away with the 2.06 update? when i update, it says the latest is 1.3.5
    i read some people where having troubl;e with the later updates. maybe they did away with they newer ones?
    i use windows btw

     

    0 75
  • New
    SimonSimmoEliot
    Newcomer - Level 1
    2021-08-08

    I own a V-tone GMX 1200H and I am having trouble getting the amp head and FCB1010 on the same channel. I just want them both on on channel 1

    I follow all the steps in the amp and midi controller manual and the Channel number of 1 on amp still keeps flashing and number dose not go solid. It says in the manual it will stop flashing when the amp and foot switch are on the same channel and I have also went through all the steps to set the foot controller to channel 1 and the 1 on the amp does not go solid I just want to use the foot switch to call up effect patches, channel switch and effect on off control and expression pedals I basically want to use it as an effect controller for the

    V TONE on the amp head but I can’t start programming until I get both the amp head and the foot switch on the same channel and the channel number on the amp head goes solid.. plz help I’m finding it hard getting info about GMX V Tone and FCB1010 setup the user manuals are very vague. And any advice how to program the FCB1010 to be pretty much used as a pedal board to switch between FX in the head and channel switch and effect on and off and expression pedals would be great. It mentioned in the GMX V Tone manual the the FCB1010 is a great MIDI controller and channel switch and effect on and off for the FX built into the GMX 1200H V Tone.

    read more...
    0 62
  • New
    AndrewAsbury
    Contributor - Level 2
    2020-11-28

    Is anybody having any issues trying to connect their VL3X to a Mac using Big Sur? Mine just loops around rebooting when USB connection made. Tried on two laptops and same thing happens. I've been having issues with my VL3X crashing and rebooting in one particular song that then sends it a bit crazy, so I don't know if I'm dealing with one or two issues!

     

    Thanks

    Andrew

    read more...
    0 72
  • New
    Zippy1
    Contributor - Level 1
    2020-10-29

    hello again the looper i bought in January has been belive was refurbished! Ditto x4 looper no.14304709 I havent tried it in months and it doing the same thing the other X4 did the timeing starts to looping at different times! And also when pushing down on the buttons it takes more time to stop! my other ones Yes I bought 2 more Dont do that! it takes too much time while im playing to hold and wait! And unfortunatly I cant download a new program because My new Mac doesnt have plug cords to download it too! Will You please take it back and give me another one I would appreciate it!

    read more...
    0 49
  • New
    ShaneRehberg
    Newcomer - Level 1
    2020-11-13

    I have an ip1000 that I gig out with every other week. The last 2 weeks, after about an hour of playing the sound slowly started to go out. After another 30 minutes it went out completely. 

    0 28
    • ShaneRehberg
      KyleJohnson Hi Shane, Kyle here with Music Tribe. I recommend you contact us directly for assistance. Please click on Support at the top of the page, then scroll down and select Technical Support.
      • November 13, 2020
Go to page