• 2020-04-04

    speaker no longer powering up.  lim led flashes briefly when powered on

    0 55
    • Callan Berry
      Rex Beckett

      @callanberry 


      Hello Callan, welcome to the community.


       


      I suggest that you raise a Care ticket for Service Repair explaining your problem. This is done by clicking on Support at the top of the page and then clicking the Create a Care Ticket button. This is only possible if you have completed all the required fields in your profile. Make sure that you fill-in every required field on the Care form.

      • Apr 4
  • 2020-02-03
  • 2019-10-12

    I sent back a Samson VX8.1 line array pa unit that was not working properly and decided instead to buy a Turbosound IP1000 which I rec'd 10/12/2019.  I only ran the IP1000 a few hours to practice on my Roland RD-2000. The rear metal plate where inputs plug in, gets almost too hot to touch.  Should I be concerned about internal heat build up as I don't see a visible cooling fan nor any air vent ports.  On the Samson VX8.1 I returned, plus many other models I've researched, do have a visible cooling fan and or air venting with some having possible non-visible internal fans. On this blog somewhere, I read someone was asking IF there was an effective way to retrofit a cooling fan solution for their speaker.  I do "know" that excessive heat does in fact break down electronics over time.  IS there any internal fan or any air porting/venting in any of the Turbosound Inspire IP1000 thru IP3000 models? I like the sound I'm hearing, I'm also thinking about pa system longevity too.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    read more
    0 83
  • 2019-10-02

    Hello, 

    I will be attending the bpm trade show this weekend in Birmingham and o note that you will also be attending, I did enquire last year about the ip300 but you hadn't brought 1 with you

    if poss can I ask that you take 1 this year so I can have a look / listen as very interested in a pair

     thanks Ryan

    read more
    0 57
  • 2020-03-10

    Hi guys I'm looking for processor settings for turbosound tq315.

    If it helps I'll be running them passively using a turbosound lms d24 processor. 

    0 41
  • 2020-02-13

    Hi all.  Am a new owner of a IP300.  I plan to get another, plus one or two subs, and am looking at different online purchase options.  Are the European models of Turbosound speakers identical to North American models, apart from the fuse?  i.e., if I bought a European model of the IP300, could I make it North America "ready" simply by changing the T 3.15 A H 250 V fuse to the T 6.3 A H 250 V?  

    read more
    0 68
  • 2020-06-21
    I have two IP2000 speakers and one works fine but the other has very little volume and sound seems to break easily. Looking for advice since I have little knowledge about speakers.
    0 35
    • mmccutchen
      Gary Higgins Hi, the only advice to start anyway is duplicate every setting from the working one to the faulty one, if no improvement, you may need to put in a CARE ticket to have it repaired.
      • Jun 21
    • mmccutchen
      Gary Higgins The gain settings need to be equal, dsp etc. Easy to skip one by mistake.
      • Jun 21
    • mmccutchen
      Alexander Lane Try Performing a factory reset;

      Hold down the encoder Knob and Setup button while powering on the unit, follow all the on screen test instructions.
      • Jun 23
  • 2019-05-20

    I have 2 IQ15's that are less than a year old and really haven't had much use.

    At Saturday's show one of them after being powered on for about 3 minute and without any load shows "over temp" on the display and stops audio output.

     

    Contacted the point of sale and it's a 4-6 week turnaround for repair, which is very disappointing indeed.

     

    Anyone else had this issue?

    read more
    0 166
  • 2019-06-26

    Hey all,

    I have been using the IP2000's for a few months now.   They sound great....until I have to push them for a bit more volume.  I have a small band with pre recorded tracks for Bass and Drums...we sing and play guitar over these tracks.

    I seems there is a general agreement to set everything on the speakers DSP to "0" to use these as a PA speaker with a mixer.   However, it seems there is not a clear explaination as to how much input to use to optimize the output of the speaker.  

    The ouput runs hot and pegs out very quickly...to the point the system will cut out or clip.  I think Turbosound should do a video addressing input and output settings.  On the DSP display it will show the input at two bars and the output quickly goes off the scale.   It is hard to balance these two settings.  

    Does anyone have their own experiences to share?

    read more
    0 221
  • 2020-07-26

    We inherited the use of some ip82 and we have also purchased some in order to

    balance the system and keep the systems intact. Used as std. upper-mid unit.

    The overall impression is a good compromise of enclosure, woofer, crossover and horn 

    dispersion, but not the tweeter which is a disappointment when compared to the rest

    of the system. We therefore have to use DSP correction files in our loudspeaker management

    adapted to various venues in order to correct for this. Otherwise, it measures reasonable,

    but sound harsh, no distinctive upper end etc. When will this unit be upgraded?

     

    read more
    0 2
    •  Carl James
      Alexander Lane Hi Carl. I will forward to the relevant people. I can't give an estimate as to when updates may come but any feedback is welcome and listened to! :)
      • Jul 27